Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Gioteck EX-05 not working properly.


08 Jul 2012   #1

Windows 7
 
 
Gioteck EX-05 not working properly.

I have a Gioteck EX-05 headset, and when I plug it in, my computer detects it and installs the drivers, however it continues to play sound through its speakers and not my headset. The headset appears in device manager, but it is not listed as a playback device in the Devices and Printers section of the Control Panel. I have tried un-installing and Re-installing the drivers, but that doesn't work. The Gioteck support team haven't been any help so far either. I don't know what else to do!
Please help!

My System SpecsSystem Spec
.

08 Jul 2012   #2

Windows 7, 64 bit Home SP1, Win 8.1.1 Pro 64 bit
 
 

Doing a google search for the Gioteck EX-05 headset, everything points to Xbox setup and not PC??

Go to the Sound/Playback panel and RIGHT click in a blank area of that panel and check to show disabled and disconnected devices (if not checked) and then see if the headset is listed, and if you can enable/use the device.
My System SpecsSystem Spec
08 Jul 2012   #3

Windows 7
 
 

The headset is multi-format. It can be used with an Xbox, a PS3 and a PC. The headset is not listed under disconnected or disabled devices.
My System SpecsSystem Spec
.


08 Jul 2012   #4

Windows 7, 64 bit Home SP1, Win 8.1.1 Pro 64 bit
 
 

Did you install the drivers first and then connect the headset, or did you connect the headset first?

If you connected the headset first, that can be a problem with many USB devices and in that case it should be uninstalled and a new install performed and the headset not connected until after the drivers are installed. To uninstall, connect the headset then go to the Device Manager, RIGHT click on the entry for the device and then LEFT click "uninstall". Also check the box to uninstall the drivers. Disconnect the headset, restart the PC and then start the install over, installing the software then physically connecting the headset.
My System SpecsSystem Spec
09 Jul 2012   #5

Windows 7
 
 

No software or drivers came with the headset. When I plugged it in my computer installed it automatically.
My System SpecsSystem Spec
09 Jul 2012   #6

Windows 7, 64 bit Home SP1, Win 8.1.1 Pro 64 bit
 
 

Go to the Devices and Printers and see if it is shown there. If it is, right click on it and you should get some options and maybe one will be to use the device, etc.

Nothing much on the internet about it except how to connect and use it with an Xbox. Not even a link to the manufacturer's web site.

Another possibility. Connect the headset to the pc then go to the Device Manager and it should be listed there. If it is listed, see if there is an error code or if its shown working OK. If its not shown, look at the USB section and see if there is an "unknown device" listed and if it is, that is most likely the headset and that it didn't get installed correctly. In either case, RIGHT click on the entry for the device or the unknown device and the LEFT click "Uninstall". Then physically disconnect the headphone and restart the PC. After Windows starts connect the headset and Windows should detect and install it. If this takes care of it, when you want to disconnect it, use the Safely Remove Hardware icon (in the Notification Area/Sys Tray) and "Stop" it before disconnecting so its status does not get corrupted in Windows.
My System SpecsSystem Spec
10 Jul 2012   #7

Windows 7
 
 

That didn't work either.
My System SpecsSystem Spec
Reply

 Gioteck EX-05 not working properly.




Thread Tools



Similar help and support threads for2: Gioteck EX-05 not working properly.
Thread Forum
Alt codes not working properly General Discussion
Browser not working properly Network & Sharing
CD Rom not working properly Hardware & Devices
usb ports not working properly Hardware & Devices
Aero not working properly General Discussion
No GUI boot not working properly BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:27 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33