Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Asus Xonar D2X no sound

26 Aug 2012   #1
x45641

Windows 7 Ultimate x64
 
 
Asus Xonar D2X no sound

hello,

i just bought the Asus Xonar D2X soundcard uninstalled all drivers of the Realtek HD 7.1 On-Board Sound, then installed the latest driver version 7.12.8.1794 of Asus Xonar D2X.

+Sound Card sits perfect in the motherboard slot
+Sound Card immediately detected on startup by Windows 7 Ultimate 64 bit
+Sound Card in Device Manager says: "This device is working proberly" and "no conflicts"
+Sound Card in Control Panel->Hardware and Sound->Asus Speaker set to default speakers
+Tryed enabled/disabled "HD Audio Controller" in BIOS, i thought this was BIOS´s way to say "On-Board Sound"
+Installtion of drivers went very fast and without of any interference or error messages and said in the end "Drivers were successfully installed. Reboot now."

Yet i have no sound.

Thanks for your help


My System SpecsSystem Spec
.
26 Aug 2012   #2
BugMeister

Windows10 Pro - 64Bit vs.10547
 
 

I have a Sonar X-Fi card installed - not the same, I know - but..

With my mobo, I didn't need to uninstall the onboard RealTek Drivers - I just updated them to the latest version..
then I installed the appropriate Sonar X-Fi soundcard drivers "over the top", so to speak..

once this is done the UI that comes with - (in my case) the Creative drivers - becomes functional, and takes precedence over the RealTek interface..

- the new soundcard's own drivers should kick in automatically, if you select that device as the default..
My System SpecsSystem Spec
26 Aug 2012   #3
x45641

Windows 7 Ultimate x64
 
 

yesterday i tried to install the Asus drivers without uninstalling the On-Board drivers and the PC took over 10 minutes for the "Asus driver installation bar" to fill, and then nothing happened, i waited another 10 minutes but nothing happend. The screen was just like that, full installation bar, no message of successful installed, no message to reboot now, nothing.

today i uninstalled the Realtek On-Board drivers first, then installed the Asus Drivers and it didnt take 10 seconds to say successful installed and reboot now.
My System SpecsSystem Spec
.

26 Aug 2012   #4
BugMeister

Windows10 Pro - 64Bit vs.10547
 
 

I'd be inclined to uninstall all of the sound drivers, and the ASUS Xonar software then..

1. install all the latest Realtek drivers for your onboard sound - make sure you select the correct set (check your mobo manual for info)..
2. reboot
3. then install your new Hardware drivers and software (which should contain the ASUS user-interface)
4. reboot
5. select the ASUS Xonar device as the default..

- from here on only use the Xonar interface to adjust settings
- even though the RealTek drivers remain in place, they only provide mobo support for the new card..
My System SpecsSystem Spec
26 Aug 2012   #5
x45641

Windows 7 Ultimate x64
 
 

but wouldnt it take me back to the point of yesterday?

if the On-Board drivers are installed and then i try to install the Asus drivers, nothing happens, the installation takes forever...

what is pretty strange is that, i just chose the Asus Speakers as default in the VLC player and the "up-down-moving-sound-bars" are moving but no sound, despite 5.1 speakers all plugged in the jacks

in the manual it says if the card dont get enough power, there wont be coming any sound out of it, may be thats why.
My System SpecsSystem Spec
27 Aug 2012   #6
BugMeister

Windows10 Pro - 64Bit vs.10547
 
 

could you fill your system details..
if it is a power problem, then we'd need to see your full specs..

- cheers!
My System SpecsSystem Spec
27 Aug 2012   #7
x45641

Windows 7 Ultimate x64
 
 

thanks for your help so far

i stopped windows from installing by it self, installed the original driver 1794.

The sound works.

But only Front jack.

And the Asus Audio Center wasnt installed. Start-All Programms-Asus Xonar D2X Audio-it says "empty"

i run Windows 7 Ultimate 64 bit and many people have this problem, some people tried with older drivers and it worked, i dont know, just lets see.
My System SpecsSystem Spec
27 Aug 2012   #8
x45641

Windows 7 Ultimate x64
 
 

there are many crazy things... :

1. when i let windows 7 ultimate 64 bit "detect&install" its windows drivers, then even in control panel-hardware sound-sound-Asus Default Set Speakers-Configure Speaker Test no matter 5.1 or 7.1-all speakers plugged in the Asus Sound Card give Sound

But video files with 5.1 sound only come out of the speakers in "Front jack".

2. Original drivers are only install-able when going to Device Manager-Sound, Video, Game Controller-right click Asus Xonar D2X Audio Device-left click Update driver software

because when i try to install the original driver by "Double Clicking" the setup.exe file, the installation starts and then says "Please plug-in Asus Xonar Sound Card", no matter older or newer drivers. and as i said the Asus Audio Center, which i see responsible for the sound only coming out of the Front jack, is not configureable, because it wasnt installed with the latest original driver by installing it through Device Manager-Update driver software.

btw: i took a look, at what windows actually installs, when i let it installs automatic by detection of new SoundCard on start up...its the exact same latetst original driver, that i install. so, unneccasary to interrupt windows.
My System SpecsSystem Spec
08 Oct 2014   #9
dannyk90

Windows 10 Pro
 
 

Same problem, you know what I don't have time for this bs. My motherboard's sound is just as good and works instantly. I'm getting rid of the sound card lol.
My System SpecsSystem Spec
Reply

 Asus Xonar D2X no sound




Thread Tools




Similar help and support threads
Thread Forum
ASUS XONAR DS 5.1 on Win7
Hi all, firstly I'm a CAD Engineer not a computer wizz kid so I can understand PC's if explained. I needed a PC to run Inventor at home but I've gotten p...d off at the moo poo I get from some of the dealers so I decided to figure it out myself as best I could and so far the results are good. ...
Sound & Audio
Asus Xonar D2X
Anyone have any Luck with this card. Just looking to get some feedback before I try out the new RC. Thanks.
Drivers
Asus Xonar D2
which drivers are using, the ones off the asus website?
Sound & Audio
Asus Xonar DX Help
I have the above card, and i cant get 5.1 sound through S/PDIF... I have the lateset drivers(its beta though) and my speakers are the Logitech Z-5500.. When i was using XP all was working perfect, but now i am getting 2.1 sound through S/PDIF and no sound through the single connection.. Thanks...
Sound & Audio
Asus Xonar D2
Hi there, Just got this soundcard for my desktop but not installed yet. I am installing it on a Win7 RC (x64) machine. Which driver should I use? Link please... Anyone tried all the apps that comes with it? Do they all work on the x64 or should I just skipém for now? Thanks
Sound & Audio
Asus Xonar D2X
I have this sound card and I found that everytime I booted hsmgr.exe or hsmgr64.exe would pop up a warning window asking me if the file was safe to run. There are two files needed for the Asus control center to work. On each pop up show more info to find the path of each process. Go to the...
Sound & Audio


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 04:26.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App