Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Can't play any music files, error 0x80070057

12 Sep 2012   #21
Anak

Microsoft Community Contributor Award Recipient

Win 7 Home Premium 64bit Ver 6.1.7600 Build 7601 - SP1
 
 

Quote   Quote: Originally Posted by najodleglejszy View Post
so. I've deleted the remnants of McAffee. I've been using Eset Smart Security (which hasn't found any viruses by the way), but I've been reading about MSE and I think I'll just, ahem, take off my black eye-patch I've also used ESETuninstaller before installing MSE, which is now doing another scan.
Okay, lets run with MSE for a while to see if it makes a difference.

Quote   Quote: Originally Posted by najodleglejszy View Post
the log is, well, HUGE, so I'll better put it in an attachment.
Have it, it looks like everything is in order.

Quote   Quote: Originally Posted by najodleglejszy View Post
I'll check Lenovo site via IE in a minute, although I doubt it will find anything other than I did manually. it looks like there's only one "flavour" of Z580 laptop (back in days I owned Y550, when I was downloading drivers from Lenovo site, after selecting Y550 model, I had to choose some kind of sub-version, which isn't a case with my Z580).
edit: auto-detect function works only with Think series. however, I'm sure I've downloaded the right drivers.
Well it was worth a try.

Quote   Quote: Originally Posted by najodleglejszy View Post
I was also wondering if it could be some codec's fault?
As long as you are hearing system sounds the OS's codec's are okay, and the media players you are using should have their own.

Have you tried getting fresh copies of the media players, and re-installing?
Here is the link for: Windows Media - Microsoft Windows If you look below, first column you will see a link to help explain codec's, and codec FAQs in the one to the far right.

When you said:
Quote   Quote: Originally Posted by najodleglejszy View Post
also: there's no sound in movies.
Are you getting any messages saying that your 580 is missing any codec's, and is this with your DVD player?

Have you checked Event Viewer?
  • Type eventvwr in search.
  • Go to the Windows Logs > Application in the left hand column.
  • Note anything in red that relates to the problem.
  • Please record the event ID, and the Source Code, and post them in your next reply.
  • If there are a lot just pick the first few different ones.

It could be an upper/lower filter problem. Installing, and removing programs that have their own codec's can corrupt the ones that were already there, and working.
Depending on your answer, check these out but check back before proceeding.
If you don't, and proceed, follow the directions explicitly!

This tells you to run the troubleshooter: Your CD drive or DVD drive is missing or is not recognized by Windows or other programs

This is for Vista, but should work for 7 it is a more detailed explanation that you will see below the advice to run the troubleshooter in the above link:
The CD drive or the DVD drive does not work as expected on a computer that is running Windows Vista


My System SpecsSystem Spec
.
15 Sep 2012   #22
najodleglejszy

Windows 7 Home Premium x64
 
 

my video player doesn't show any errors, just plays .mkv files as always, except there's no sound.

I just checked Event Viewer. there are looooo-hoooo-hoooots of errors sourcing from NSDSvc (which is related to Lenovo Fast Boot service; I've already found that users have got errors related to this function in Event Viewer and it
s not such a big deal) and pretty much the same amount of errors related to something called ESENT:

Code:
- <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
- <System>
  <Provider Name="ESENT" /> 
  <EventID Qualifiers="0">447</EventID> 
  <Level>2</Level> 
  <Task>12</Task> 
  <Keywords>0x80000000000000</Keywords> 
  <TimeCreated SystemTime="2012-09-12T12:52:29.000000000Z" /> 
  <EventRecordID>24169</EventRecordID> 
  <Channel>Application</Channel> 
  <Computer>Flogiston</Computer> 
  <Security /> 
  </System>
- <EventData>
  <Data>Windows</Data> 
  <Data>2616</Data> 
  <Data>Windows:</Data> 
  <Data>-338</Data> 
  <Data>11</Data> 
  <Data>136</Data> 
  <Data>C:\ProgramData\Microsoft\Search\Data\Applications\Windows\Windows.edb</Data> 
  <Data>136</Data> 
  <Data>147</Data> 
  <Data>149</Data> 
  </EventData>
  </Event>
uninstalling my media players, downloading fresh copies and installing one by one hasn't helped either. I guess I'll just surrender and format it after the weekend :/
My System SpecsSystem Spec
16 Sep 2012   #23
najodleglejszy

Windows 7 Home Premium x64
 
 

I did as I said. after reinstalling Windows everything's fine so far.
My System SpecsSystem Spec
.

16 Sep 2012   #24
Anak

Microsoft Community Contributor Award Recipient

Win 7 Home Premium 64bit Ver 6.1.7600 Build 7601 - SP1
 
 

Quote   Quote: Originally Posted by najodleglejszy View Post
my video player doesn't show any errors, just plays .mkv files as always, except there's no sound.

I just checked Event Viewer. there are looooo-hoooo-hoooots of errors sourcing from NSDSvc (which is related to Lenovo Fast Boot service; I've already found that users have got errors related to this function in Event Viewer and it
s not such a big deal) and pretty much the same amount of errors related to something called ESENT:

I guess I'll just surrender and format it after the weekend :/
Be careful with that NSDSvc service, I've seen reports where if it is disabled or deleted it can cause problems with other .dll's/drivers to load, and in turn cause boot problems. Lenovo is aware of the problem, but no word on a fix.

ESENT is:
Quote:
The Extensible Storage Engine (ESE) is an advanced indexed and sequential access method (ISAM) storage technology. ESE enables applications to store and retrieve data from tables using indexed or sequential cursor navigation.

Source: Extensible Storage Engine
With it being a database for programs it could of been behind the media player issues, but not the NSDSvc errors.

Extensible Storage Engine Reference

Quote   Quote: Originally Posted by najodleglejszy View Post
I did as I said. after reinstalling Windows everything's fine so far.
I was going to ask if you had an installation disk to do a repair, reinstall or if you felt like doing a factory reset.
Glad to hear you have your 580 working again.

If your paying for that Eset Smart Security I'd go ahead, and reinstall it if you were happy with it.
My System SpecsSystem Spec
17 Sep 2012   #25
najodleglejszy

Windows 7 Home Premium x64
 
 

Quote   Quote: Originally Posted by Anak View Post
Be careful with that NSDSvc service, I've seen reports where if it is disabled or deleted it can cause problems with other .dll's/drivers to load, and in turn cause boot problems. Lenovo is aware of the problem, but no word on a fix.
I'm not planning on disabling it, thanks for the warning though

Quote   Quote: Originally Posted by Anak View Post
ESENT is:
Quote:
The Extensible Storage Engine (ESE) is an advanced indexed and sequential access method (ISAM) storage technology. ESE enables applications to store and retrieve data from tables using indexed or sequential cursor navigation.

Source: Extensible Storage Engine
With it being a database for programs it could of been behind the media player issues, but not the NSDSvc errors.
I also thought that NSDSvc isn't the culprit, that's why I haven't even posted any code related to it.

Quote:
If your paying for that Eset Smart Security I'd go ahead, and reinstall it if you were happy with it.
well, as I said, I got rid of my black eye-patch, arrr
My System SpecsSystem Spec
Reply

 Can't play any music files, error 0x80070057




Thread Tools




Similar help and support threads
Thread Forum
some sound files do not play with some music players only under win 7
Here is a tough one for the audio gurus out there. I have been recording lectures on my phone for years using a program called Easy Voice Recorder. It records in wav format. I transfer the files to my PC and convert them to smaller mp3's, which I typically play with winamp. I could of...
Sound & Audio
Getting Error when trying to play video files
i have already tried posting this in another section of the forums and nobody has helped me over there so i will post this here when i try to click play all when playing video files i get the error saying no playable file is found, but i can open up a folder and play video files individually though...
Software
Windows couldn't play any music files although drivers working
http://i1146.photobucket.com/albums/o530/HTHVampire/Pc%20Stuffs/Capture_3.jpg http://i1146.photobucket.com/albums/o530/HTHVampire/Pc%20Stuffs/Capture_2.jpg http://i1146.photobucket.com/albums/o530/HTHVampire/Pc%20Stuffs/Capture.jpg Hi guys, here's the problems that i encountered:...
Sound & Audio
HELP!!!!!.....cannot play any music or video files........HELP!!!
hey guys i have some troubles to play all kind of media files now. the problem comes out a few days ago and i have no idea what may be the reason. i am very sure i didn't install anything to my computer and there is no notifications to tell me anything that is damaged etc. and i just reinstall...
Music, Pictures & Video
Error 0x80070057 moving files to External Hard Drive? Help
Just bought a 250 GB Seagate External USB Hard Drive. While Transferring/Copying all the folders and files from my Desktop contents (12 GB) I received the following Windows(Not Seagate's) Error which was "0x80070057" ALSO:I made sure no file being transferred was IN USE by any process so...
Hardware & Devices
How do I get Aimp to play my music files?
Hi Charles and welcome to 7forums. I downloaded and installed Aimp but how do I get it to play my music files. At the moment they are all on a seperate drive and I access through W7 libraries. If I right click on an album I get a choice to play in Winamp or WMP so how do I get Aimp in this...
Software


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 14:32.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App