Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Realtek HD Audio: Equalizer not working properly

09 Sep 2012   #1
Tornato7

Windows 7 Home Premium 64-bit
 
 
Realtek HD Audio: Equalizer not working properly

I'm trying to use the Realtek HD Audio Equalizer from the manager window under the sound effects tab... Anyway, I can change the values on the multi-band equalizer just fine, but they have no real response. The overall volume is affected but the individual frequencies are the same. If I set them all to 0, or all the highs to zero, etc. The final output is the same.

Any way I can get the equalizer working?

Thanks.


My System SpecsSystem Spec
.

10 Sep 2012   #2
fireberd

Windows 7/10 64 bit
 
 

What model PC? or if its a custom built, what motherboard? Please fill out the My System Specs so we can better try to help you.

My RealTek manager does not have any of those functions, and I have a new Gigabyte motherboard.
My System SpecsSystem Spec
10 Sep 2012   #3
Britton30
Microsoft MVP

Windows 7 Ultimate X64 SP1
 
 

Hi Tornato7 Welcome to Seven Forums.
To help us help you would you please add your systems specs? Here's how: System Info - See Your System Specs
Under System Manufacturer/Model Number add whether it is a desktop or laptop and whether self built.

Log in to Seven Forums and you will be able to transfer the info directly to your specs page in your profile directly from the System Info app.

@Jack, In Realtek manager go to either of the tabs I have circled, then in the lower pane click that icon I have circled, it should open the equalizer. you may not have an optical tab.

-realtek.jpg


My System SpecsSystem Spec
.


10 Sep 2012   #4
fireberd

Windows 7/10 64 bit
 
 

The Gigabyte supplied RealTek, that I have (and I have the latest driver version) does not have that. However, I have the Gigabyte supplied THX and SoundBlaster Creative Xfi software enhancement that does have the EQ.
My System SpecsSystem Spec
10 Sep 2012   #5
Britton30
Microsoft MVP

Windows 7 Ultimate X64 SP1
 
 

Quote   Quote: Originally Posted by fireberd View Post
The Gigabyte supplied RealTek, that I have (and I have the latest driver version) does not have that. However, I have the Gigabyte supplied THX and SoundBlaster Creative Xfi software enhancement that does have the EQ.
I see, my driver is Nov 2010 which is the latest ASUS has. Your THX drivers may have supplanted the Realtek EQ since that is a much better audio chip.
My System SpecsSystem Spec
10 Sep 2012   #6
fireberd

Windows 7/10 64 bit
 
 

Its still RealTek audio chip, just the extra software add-ons (enhancements) provide the eq and other functions.

The differences in what the vendors supply (how they implement the sound hardware) is the reason I always tell users to first try the PC or motherboard vendor's drivers first. I used to do a lot of support on the Dell forums and that was particularly true with most Dell models, non Dell sound drivers either did not work or did not work correctly.
My System SpecsSystem Spec
10 Sep 2012   #7
Dwarf

Windows 8.1 Pro RTM x64
 
 

Quote   Quote: Originally Posted by Tornato7 View Post
I'm trying to use the Realtek HD Audio Equalizer from the manager window under the sound effects tab... Anyway, I can change the values on the multi-band equalizer just fine, but they have no real response. The overall volume is affected but the individual frequencies are the same. If I set them all to 0, or all the highs to zero, etc. The final output is the same.

Any way I can get the equalizer working?

Thanks.
It sounds like the equalizer is working as it should. Think of it as a set of volume controls, each one centred on a particular frequency. As you adjust the control settings, you are effectively changing the proportion of that particular frequency in the final output.
My System SpecsSystem Spec
Reply

 Realtek HD Audio: Equalizer not working properly




Thread Tools





Similar help and support threads
Thread Forum
Realtek Equalizer Settings
This is for those who, like me, have been looking for where the frequency equalizer (enhancement) settings for Realtek are stored. Here is a zipped file with some settings. These are the plus (maximum) and minus (minimum) settings of each frequency enhancement in turn. This is the code...
Sound & Audio
Realtek audio, Gigabyte mobo: strange-sounding audio, mic not working
I have a self-assembled desktop PC - full specs in the signature below, but in short, it has an AMD Phenom II X6 1090T processor on a Gigabyte GA-970A-DS3P mainboard, which uses a Realtek Azalia ALC887 on-board sound system. I have no loudspeakers and listen to the computer sound exclusively...
Sound & Audio
Realtek HD Audio Manager Equalizer not working
Hello, I just bought a MSI Z77-G43 motherboard and I did a clean installation of Windows 7 Ultimate 64bit and when it started up the audio was already working which is normal. Then I installed the basic drivers (chipset,lan,audio).(Ok just so you know the situation) Now the volume changes on...
Drivers
Missing 'equalizer' in Realtek HD audio manager
As the title says, I have no equalizer even thought I'm using the latest version of the driver. I did a lot of research but couldn't find a way to fix it :/
Sound & Audio
Audio jack not working properly
Since yesterday my laptop has been doing something very weird. I can't get any audio through the headphone jack. The laptop's speakers work fine. When I plug in the headphones then the sound continues to come out of the speakers. When I check the sound devices it shows that the headphones are...
Sound & Audio
Realtek equalizer
I upgraded from XP to 7. When i was using xp, the equalizer in the realtek control panel worked fine. I prefered this over a built in software equalizer such as winamp because it would eq everything, such as youtube, vent, and anything else. But now that ive upgraded to windows 7, the...
Sound & Audio

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 15:14.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App