Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: USB headset doesn't work anymore

11 Sep 2012   #1
Solanine

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1
 
 
USB headset doesn't work anymore

I recently bought a new graphics card for my computer, and since then I've updated windows and installed it's drivers.
The problem I have had since buying the video card, is that no USB headset's now work with my computer.

I've tried updating my audio drivers (which doesn't give me any sound at all). To uninstalling and reinstalling drivers for both the headset and the audio itself.
So far nothing has worked, I have full speaker functionality, but no headsets will work, nor will the microphone on my webcam anymore either.
Is there perhaps more I can do?

I have system spec's in my profile, but if there is anything else I should post please let me know.
Thanks!


My System SpecsSystem Spec
.
11 Sep 2012   #2
HammerHead

win 7 X64 Ultimate SP1
 
 
USB Headset

If your USB ports are working. I would try the easy fix first.

Check your device manager and make sure the headset and driver is loaded and functioning.

In the start search box type "sound" (no quotes) and select sound. Your headset should show up as a device. It should be selected as default. For some apps you have to change this default back and forth because the code in the app is not written for a head set. I'll post a clip of my sound panel but it does not show a headset. I have none on this machine. But if yours is loaded correctly you will have it.

Attachment 231337
My System SpecsSystem Spec
11 Sep 2012   #3
Solanine

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1
 
 

It is showing up in the sound panel, however it will not allow me to make it a default device, and when I click the recording tab, the screen freezes completely.
If I try to click the Headset from the sound icon in my taskbar, it says "No audio device is installed" but it appears perfectly fine on Device Manager.
My System SpecsSystem Spec
.

11 Sep 2012   #4
HammerHead

win 7 X64 Ultimate SP1
 
 
USB Ports

Is your USB ports working?

What brand of head set and what driver do you have loaded?
My System SpecsSystem Spec
11 Sep 2012   #5
Solanine

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1
 
 

Yeah the USB ports work fine, I am able to plug in a USB drive, or my external HDD or charge my cell phone via USB without an issue at all.

I just bought a Corsair Vengeance 1500 and downloaded the most recent drivers off the website today once it arrived. Before that I was using a Microsoft LifeChat LX3000 and that was when the issue first presented itself. I at the time assumed it was the headset itself, but I believe it is more than that now.
My System SpecsSystem Spec
11 Sep 2012   #6
HammerHead

win 7 X64 Ultimate SP1
 
 
Graphics Driver

AMD Radeon 7700 series.

I am looking for a driver for this card. So far I haven't found a 64 bit win 7 driver. What driver do you have loaded?
My System SpecsSystem Spec
11 Sep 2012   #7
Solanine

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1
 
 

I have the catalyst software installed. Version 8.0.881.0 i think, thats what my program list says. I've also used the disc that came with the video card itself as well. Should I try another video card driver update?
My System SpecsSystem Spec
11 Sep 2012   #8
HammerHead

win 7 X64 Ultimate SP1
 
 
Check This Out

I think I found a newer driver.

AMD Radeon

It says Vista in the file name. The page refers to Win 7 also.

Do you use driver sweeper when changing graphics drivers?
My System SpecsSystem Spec
11 Sep 2012   #9
Solanine

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1
 
 

I have never heard of that program, I usually just uninstall if it tells me to, then install the new one.
My System SpecsSystem Spec
11 Sep 2012   #10
HammerHead

win 7 X64 Ultimate SP1
 
 
That Will Work But

I use driver sweeper. It takes out all of the old driver files and reduces the chance of the wrong file being used. Plus you get some space as a bonus.

Read about here.

Guru3D - Driver Sweeper
My System SpecsSystem Spec
Reply

 USB headset doesn't work anymore




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Wireless Network Adapter doesn't work anymore
Hello, i have an ASUS X55VD and the wireless adapter isn't working anymore. I tried troubleshooting, reinstalling the ASUS drivers (Ralink and Atheros drivers), uninstalling and uninstalling & deleting the driver from device manager. I tried uninstalling the antivirus (ESET SS 8). The wired...
Network & Sharing
ALT-TAB doesn't work anymore...
Hello everyone, Yesterday I suddenly noticed that my ALT-TAB wasn't working anymore, Ive searched google for hours on how to fix it but i couldn't find anything that fixed my problem. When I press Alt-Tab, I get a menu with File, Edit, View, Tools and Help in the window that I currently have...
General Discussion
Will a Headset microphone still work if I cut it off the Headset?
I have a almost broken headset, but the microphone still works fine, The microphone is connected on the wire right before the headset, Its not actually touching the headset itself. Would this microphone still work if the headset was cut off? Sorry but I can't manage to take a photo but
Hardware & Devices
Google Chrome doesn't work anymore ...
Hello my friends, One day, suddenly, when i opened the chrome, it didn't open any web page; And i almost waited for 5 minutes.. nothing
Browsers & Mail
Why doesn.t my autoplay come up anymore? Help?
When I insert any type of media, cd, dvd, flash drive anything it doesn't show me that window anymore? Is there a way to fix this?
General Discussion
Dual boot with XP doesn't work anymore...pls help
Ok, a bit of a background on this: I HAD a dual boot with XP and Win 7 on two separate drives with a menu system at the beginning. a) XP on an IDE - 80gig - installed first about 3 years ago b) Win7 64 bit - SATA 1T - installed in the new year. I lost the 80gig drive and so I bought a new...
Installation & Setup


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 23:56.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App