Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Bass and subwoofer not working in Windows 7 64 bit


17 Sep 2012   #1

Windows 7 Ultimate x64
 
 
Bass and subwoofer not working in Windows 7 64 bit

Ok I may seem repeating the thing posted before by some guys but it's a real trouble for me.My system's specs are as;
Dell N-5110 Core i7-2630QM 2.0GHz
Windows 7 Ultimate 64 bit Service Pack 1
Ram 4 GB
When I plug in Creative SBS A320 Speaker System - 2.1 , I can hear sound but there is no bass at all with music playing.I tried many solutions/fixes but can't get rid of this annoying thing.I have installed Realtek High Definition Audio Driver and also have pre-installed Dell Audio by IDT.I checked the Bass Boost in Speakers=>Enhancements, Installed/Re-Installed drivers/ Checked pins.I really don't wanna mess up with my drivers again so decided to ask some reliable expert like you people.Speakers are perfect with other devices except for my Laptop.
Do I need any Audio Manager to install on my system?Can I solve my problem you know how empty it feels without Bass.
(By the way Like many others, My system speakers are also dead for no reason.Cant hear anything without external sound system/headphones)

My System SpecsSystem Spec
.

17 Sep 2012   #2

Windows 7, 64 bit Home SP1, Win 8.1.1 Pro 64 bit
 
 

First, you must use the Dell supplied drivers. Non-Dell drivers in many cases will either not work or not work correctly.

Here is the correct Dell IDT driver for the N5110. Drivers and Downloads | Dell [United States]

Install that and then see if it fixes it. As you have installed an incorrect driver, the RealTek, you may have to completely uninstall all sound drivers before installing the correct one.
My System SpecsSystem Spec
17 Sep 2012   #3

Windows 7 Ultimate x64
 
 
Ok!!

Now that's the exact reason why I love you guys so much..Go and search other blogs and forums,you will see tons of solution with 'dos' and 'donts' filling all over in replies..But here I have seen many threads, No other than straightforward & sensible solutions..Thanks alot 'fireberd' ..My Sound looks fine with sound system now..(Will be back with my system's own audio problems soon but let's get some rest before. ) Thanks for helping out to the Illiterate' people like me all around the world.You people are web Heroes.. R.E.S.P.E.C.T

God Bless!!!
My System SpecsSystem Spec
.


18 Sep 2012   #4

Windows 7, 64 bit Home SP1, Win 8.1.1 Pro 64 bit
 
 

Thank you for the nice complements. We try to help.
My System SpecsSystem Spec
Reply

 Bass and subwoofer not working in Windows 7 64 bit




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:01 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33