Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: No Sound After Reinstall except through HDMI

18 Sep 2012   #1
sweeptheleg

Windows 7 Professional 32 Bit
 
 
No Sound After Reinstall except through HDMI

I recently did a fresh install of Windows 7 Professional 32-bit, my laptop came new installed with Windows 7 Home Premium. Everything works fine and showed no errors. When I tried to play any sound, nothing works. The equalizer on the speaker shows sound going up and down but still no sound. Nothing is showing being muted, I've checked all the settings many times, etc. I've let windows find the drivers, I've manually tried drivers (Vista_Win7_Win8_R270) nothing works. I have two drivers Realtek High Definition Audio and High Definition Audio Device installed. I've uninstalled and reinstalled trying only one driver, etc. I get no sound through headphones or external speakers. I do get audio to my TV through HDMI however.

I had no problems before the reinstall except that my headphone jack sensor hung up and could not be fixed so I disabled that in the registry on my old setup. After reinstall sound doesn't work with or without the jack sensing disabled.

Any ideas would be appreciated. Thank you.


My System SpecsSystem Spec
.

18 Sep 2012   #2
bassfisher6522

Windows 7 Ultimate 64 bit
 
 

After upgrading to 7 Pro, did you install the sound driver for you make and model PC?
My System SpecsSystem Spec
18 Sep 2012   #3
sweeptheleg

Windows 7 Professional 32 Bit
 
 

Thanks for your reply! Yes, I have tried the latest drivers from MSI (my laptop) site to no avail. I even tried the drivers CD for Win 7 that came with the laptop. Still no sound. When I uninstall the drivers and just install the Realtek driver, there is a X over the sound icon until i restart. Windows 7 installs the other driver and everything appears to work, but still no sound. Kinda crazy.
My System SpecsSystem Spec
.


19 Sep 2012   #4
bassfisher6522

Windows 7 Ultimate 64 bit
 
 

Crazy indeed...when you moved up in OS, did you change the bit format...from 32 bit to 64 bit?
My System SpecsSystem Spec
19 Sep 2012   #5
sweeptheleg

Windows 7 Professional 32 Bit
 
 

No, I did not. I'm usually pretty good with computer, but I can't seem to figure this one out.
My System SpecsSystem Spec
23 Sep 2012   #6
ounikao

Windows 7 Home Premium
 
 

From my experience, sometimes windows changes the default sound device when you connect different outputs and such. Right-click on your speaker icon in your task bar and select "Playback Devices". Then right-click your primary sound card or sound device and hit "Set as Default Communication Device". See if that helps
My System SpecsSystem Spec
04 Oct 2012   #7
sweeptheleg

Windows 7 Professional 32 Bit
 
 

Thanks, nothing works. I may be out of luck. I tried a Linux distro and still no sound. I am stumped because the sound worked just fine before upgrading.
My System SpecsSystem Spec
Reply

 No Sound After Reinstall except through HDMI




Thread Tools





Similar help and support threads
Thread Forum
Sound Control panel takes 2 minutes to open; HDMI sound inconsistent
Brand new Windows 7 Home Premium (6 bit) computer. When I click on the Sound control panel item, sometimes it takes 1-2 minutes to open. But that's kind of minor (although I'd like to know how to fix it), because sometimes the HDMI sound to my HDTV works fine, and sometimes it doesn't work at all....
Sound & Audio
ati7790 hdmi audio override VIA onboard unless uninstall/reinstall VIA
TBH I'd be happy with sound from both HDMI and VIA onboard. PC to HDtv via HDMI. HDMI sound always overrides onboard VIA sound (v10_1200a) If I want to use onboard, Device Manager: I have to uninstall VIA High Definition Audio then Scan for Hardware Changes, viola. Reboot, must repeat...
Sound & Audio
NO SOUND TROUGH HDMI ON ACER AX3400-U3032 and No HDMI Icon in sound se
Had to replace motherboard from authorized acer parts dealer now I get no sound through HDMI port. I did through the original board until it got fried by electrical surge. Can any one help or send me a picture of the inside the same model to make sure all jumpers on the motherboard are in the...
Sound & Audio
No sound through speakers.Jack not being detected.HDMI sound only?
So I've got a problem,I changed my case 2 days ago and everything went great,all working as it should be.Up until an hour ago,when the lid got stuck in one of the little clips so after a quick bang it went in.But then I lost my picture on both monitors. So I went to investigate,I ended up...
Sound & Audio
no sound through tv via hdmi, sound plays through laptop speakers (idt
Yesterday I installed a new external hard drive - following the installation - my sound no longer played through my television (video is fine, HDMI connection) and sound now comes ONLY through the laptop speakers. The option for HDMI Audio doesn't appear in the 'sound' menus. I have 'checked'...
Sound & Audio
No sound via audio jacks, but sound via hdmi.
I recently done a new build, not with the same specs I have on here; i5 2500k p8z77-m pro sapphire radeon 6870 I cannot get any sound through the front+back headphone jacks, realtek doesnt detect any audio devices, however i can mess around with the settings to get windows to say i have...
Sound & Audio

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 04:49.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App