Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: spdif output not working properly

23 Sep 2009   #1

windows 7
 
 
spdif output not working properly

Hi , i have been using Windows 7 RC for awhile now .I have the coaxial spdif output on my Gigabyte Ep 45-ds3r board connected to my home theartre amp.Have been getting 5.1 sound with no problems.I recently installed Windows 7 enterprise edition to my pc and now only have 2.1 sound.Have tried the latest drivers from Realtek and Gigabyte which make no difference.I tried the driver on the motherboard disc and the previous driver i had installed, still no good.The mb uses the Realtek alc 889a codec.Any help would be much appreciated

My System SpecsSystem Spec
.

26 Sep 2009   #2
dnr

Windows Vista Ultimate
 
 

Quote   Quote: Originally Posted by mrplane View Post
Hi , i have been using Windows 7 RC for awhile now .I have the coaxial spdif output on my Gigabyte Ep 45-ds3r board connected to my home theartre amp.Have been getting 5.1 sound with no problems.I recently installed Windows 7 enterprise edition to my pc and now only have 2.1 sound.Have tried the latest drivers from Realtek and Gigabyte which make no difference.I tried the driver on the motherboard disc and the previous driver i had installed, still no good.The mb uses the Realtek alc 889a codec.Any help would be much appreciated
My issue is similar, except that I have Windows 7 installed is on a brand new 64-bit machine. The HDMI output form the GIGABYTE | GV-R467ZL-1GI card works fine, but the SPDIF output from the ASUS P5Q PRO TURBO does not work. ASUS says there are no BIOS setting to change. Also, an external DVD drive plugged into the same SPDIF slot in my Amplifier works, while the optical output from the board does not. The SPDIF device shows as an option under Playback Devices, but when enabled, there is no sound.
My System SpecsSystem Spec
13 Feb 2010   #3

Windows 7 - 64 bit Ultimate
 
 

i have the same sort of problem, only 2 channels when using my SPDIF out to connect to my home theathre system...

this is so annoying !!!!! p.s. i am using XFI Fatality Pro sound card.....
My System SpecsSystem Spec
.


22 Mar 2010   #4

Windows 7 32-bit
 
 

Try ac3filter and select SPDIF passthrough mode
My System SpecsSystem Spec
Reply

 spdif output not working properly




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 10:28 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33