Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: No Sound in HDMI

27 Oct 2012   #1
Uchiha

Windows 7 Home Premium x64
 
 
No Sound in HDMI

Hi, and thanks in advance

I just bought a new HDMI cable and plugged it into my Bravia™.
I've got a Lenovo Y560 and I just can't get my music to play through the TV.




Attached Thumbnails
No Sound in HDMI-aa.jpg   No Sound in HDMI-untitled.jpg  
My System SpecsSystem Spec
.

27 Oct 2012   #2
fireberd

Windows 7/8.1/10 64 bit
 
 

There is NO HDMI audio listed in the snapshot you show. You will need HDMI audio enabled (if you have it). In the Sound Playback panel, RIGHT click in an empty area and then LEFT click Show Disabled and Disconnected devices. If the HDMI is now shown you can select it as the default playback device.

If it is not shown, and the PC is supposed to have it, update the Video driver.
My System SpecsSystem Spec
28 Oct 2012   #3
Uchiha

Windows 7 Home Premium x64
 
 

Quote   Quote: Originally Posted by fireberd View Post
There is NO HDMI audio listed in the snapshot you show. You will need HDMI audio enabled (if you have it). In the Sound Playback panel, RIGHT click in an empty area and then LEFT click Show Disabled and Disconnected devices. If the HDMI is now shown you can select it as the default playback device.

If it is not shown, and the PC is supposed to have it, update the Video driver.
Could you tell me how to do that ?? I've tried a lot but to no avail....
I've got a Lenovo Y560 with ATI Mobility Radeon HD 5730 and Intel HD Graphics.
My System SpecsSystem Spec
.


28 Oct 2012   #4
fireberd

Windows 7/8.1/10 64 bit
 
 

As you have both the Intel HD Graphics and the ATI, I don't know how you select which one to use. The ATI Radeon has HDMI audio listed in its specifications. I don't know if the Intel HD Graphics also has that.

The Lenovo users manual (should be one loaded on the PC, I have a different model Lenovo ideapad and it has it) should detail how to select which video device.

The latest AMD (ATI) driver can be downloaded and it will contain the needed HDMI audio driver. But, I can't guarantee that will fix the problem. This is really a subject for a different forum section, even though it is on audio, since it involves proper PC configuration.

Here is the AMD (ATI) driver download: AMD Catalyst

Otherwise you may want to repost about the HDMI configuration issue on a different forum section.
Here is one that may be applicable: Installation & Setup - Windows 7 Forums
My System SpecsSystem Spec
28 Oct 2012   #5
Uchiha

Windows 7 Home Premium x64
 
 
Solved !!

I did it !!
For all the others with ATI or Y560 related problems -->
Just head to Device Manager -> System Devices and enable both High Definition Controllers. Then go to Sound[Control Panel] and enable HDMI output from there !!

Cheers !
My System SpecsSystem Spec
07 Feb 2015   #6
johnnybgood

 
 

good stuff!!! (works for audio and video / display)

anyone having these problems, try Uchiha solution first (above)... easy and quick!!! if doesn't help then do the harder things. nearly gave up and settled on a lousy old VGA and mic / earphone cord.. what a waste.. next i'm going to get the wireless thing going to TV. have to buy a thingamejig for it though. just wondering how bloody hard the config changes will be :/ know original post was an old one but THANKS MATE!!!!!! so simple yet so difficult to spot.. should be auto these days don't you think???????? Cheers buddy from me

for interest. i had an htpc hooked thru amp then from there to tv (hdmi cables) worked great. sold that and just pulled and reinserted cables to my Y560. think it would work? no. so went from there and fixed via this thread. if you connect your new lappy or pc like i did and change settings as detailed above they will revert back to your device settings (Y560 anyway) when you pull the hdmi cable out. just thought i'd mention that function does seem to work on auto

just in case any wiz bang techies are shaking thier heads... i duplicated process with my HP beats lappy and THAT did all on auto... so it's an ibm thang

tags: Y560 HDMI PORT. Y560 hdmi sound. Y560 hdmi video. Y560 hdmi display
My System SpecsSystem Spec
Reply

 No Sound in HDMI




Thread Tools





Similar help and support threads
Thread Forum
No sound through HDMI
A few days ago, I plugged a HDMI cable into my new laptop and watched a few videos on my HDTV. No problems whatsoever. Since then though, every time I plug in the HDMI cable, the video comes through just fine, but there's no sound. I've found several threads with similar problems, both here and on...
Sound & Audio
Sound Control panel takes 2 minutes to open; HDMI sound inconsistent
Brand new Windows 7 Home Premium (6 bit) computer. When I click on the Sound control panel item, sometimes it takes 1-2 minutes to open. But that's kind of minor (although I'd like to know how to fix it), because sometimes the HDMI sound to my HDTV works fine, and sometimes it doesn't work at all....
Sound & Audio
NO SOUND TROUGH HDMI ON ACER AX3400-U3032 and No HDMI Icon in sound se
Had to replace motherboard from authorized acer parts dealer now I get no sound through HDMI port. I did through the original board until it got fried by electrical surge. Can any one help or send me a picture of the inside the same model to make sure all jumpers on the motherboard are in the...
Sound & Audio
No sound through speakers.Jack not being detected.HDMI sound only?
So I've got a problem,I changed my case 2 days ago and everything went great,all working as it should be.Up until an hour ago,when the lid got stuck in one of the little clips so after a quick bang it went in.But then I lost my picture on both monitors. So I went to investigate,I ended up...
Sound & Audio
no sound through tv via hdmi, sound plays through laptop speakers (idt
Yesterday I installed a new external hard drive - following the installation - my sound no longer played through my television (video is fine, HDMI connection) and sound now comes ONLY through the laptop speakers. The option for HDMI Audio doesn't appear in the 'sound' menus. I have 'checked'...
Sound & Audio
No sound via audio jacks, but sound via hdmi.
I recently done a new build, not with the same specs I have on here; i5 2500k p8z77-m pro sapphire radeon 6870 I cannot get any sound through the front+back headphone jacks, realtek doesnt detect any audio devices, however i can mess around with the settings to get windows to say i have...
Sound & Audio

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 11:11.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App