Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.



Windows 7: NVIDIA HDMI audio not working Win 7. Worked on Ubuntu

19 Jan 2013   #1

Win 7 x86
 
 
NVIDIA HDMI audio not working Win 7. Worked on Ubuntu

Athlon 64 3400+
Geforce gt210 PCIE
2gb RAM

I had Ubuntu 12.04 installed on this machine as an XBMC HTPC using the HDMI video and audio with the Geforce 210 until yesterday. I had a Win 7 license to use so I planned to rebuild the machine to do the same tasks with Win 7 then I could use Hulu and Netflix also.

Both the audio and video over HDMI had been working for several months on Ubuntu but I just cannot get the audio to work with Win 7. Video is working fine over HDMI. The 210 has onboard audio processing so I do not need any other cables. I am fairly technical and just cannot see why it will not work.

I have the latest Nvidia driver 310.90 for that card installed. I have tried uninstalling and reinstalling the driver several times. You can see in the images of the device manager that it sees my onboard Realtek sound card (which I have tried disabling in BIOS with no luck on HDMI audio) and the Geforce 210. There are no devices with warnings like it is missing drivers for the HDMI audio. All Windows updates are installed.

The Nvidia control panel detects my Samsung TV but when I open the audio properties I only see the Realtek device or nothing if I have the onboard audio disabled in BIOS.

There were no hardware changes at all. I literally just installed Win 7 over Ubuntu and now HDMI audio does not work. I thought Win 7 would be easier to setup than Ubuntu :P

Screenshots on Imgur
HDMI not working - Imgur

My System SpecsSystem Spec
.

20 Jan 2013   #2

Microsoft Community Contributor Award Recipient

Windows 7 Home Premium x64 SP1
 
 

Welcome to Seven Forums bigzdog. I see HDMI audio problems all the time, and there is never just one fix. But looking at your picture, the HDMI choice isn't even listed in sound. It is likely a Realtek configuration issue. Have a look at the Realtek sound manager and the digital output section. I don't have the Realtek to look at any particular settings. Hopefully someone else will add some specific info. A Guy
My System SpecsSystem Spec
28 Feb 2013   #3

Windows Home Premium 7 64 bit
 
 

I am having the same exact issue. I have been searching forums and I have tried solutions that have worked for others but not for me. I also had it working with Ubuntu. I posted over at geforce.com. I will let you know if I come up with anything and let me know if you fix it please. Thanks.
My System SpecsSystem Spec
.


14 Mar 2013   #4

Windows 7 Ultimate x64 (SP1)
 
 

I have the same issue. I have been contacting Nvidia to try and get this resolved. I was only able to get audio to work in Ubuntu before installing any drivers. After updating/installing drivers in Ubuntu I lost audio. I have yet to have any luck with hdmi audio in windows.

My post: Nvidia GeForce GT 610 HDMI Audio Issue
My System SpecsSystem Spec
15 Mar 2013   #5

Windows Home Premium 7 64 bit
 
 

I did finally hear back from xfx support after a week of waiting. Here is their response:

its possible the audio drivers didnt install correctly. Are you using any virus/malware protection? Go through the steps in this guide: http://xfxstorage.com/Support/ATI-Dr...leshooting.pdf . On the driver sweeper step go here: Driver Fusion - The Complete Driver Solution its been renamed to driver fusion. Let us know if that works. Be sure to reinstall the drivers from AMD.COM or NVIDIA.COM after.

I tried the steps in the pdf with no luck. The driver fusion software they had me download to clear out the registry of the drivers didn't work. It told me I had to pay for the premium version to delete the files. I even tried to delete the manually but Windows wouldn't let me. I bought an AMD card to put in it's place but now I get no picture at all. It might be because it is a pcie 2.1 and my motherboard is not. Or I might try putting the Nvidia card back in so I can install AMD drivers and then swap the cards again.
My System SpecsSystem Spec
Reply

 NVIDIA HDMI audio not working Win 7. Worked on Ubuntu





Thread Tools



Similar help and support threads for2: NVIDIA HDMI audio not working Win 7. Worked on Ubuntu
Thread Forum
Nvidia GeForce GT 610 HDMI Audio Issue Sound & Audio
Nvidia HDMI audio issues. Sound & Audio
HDMI Audio Out, Realtek + Nvidia Sound & Audio
hdmi audio nvidia g100 problem.. HELP Graphic Cards
No sound from HDMI device Nvidia and Realtek HD Audio Sound & Audio
Nvidia Geforce GTX 260 HDMI Out With Audio? Graphic Cards
no audio hdmi w7 rc but worked on beta Sound & Audio

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 09:35 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33