Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: No Audio Output Device installed

06 Oct 2009   #1

Windows 7 Professional
No Audio Output Device installed

Here are my computer's details:
- HP Pavilion dv6915nr Entertainment Notebook PC
- NVIDIA GeForce Go 7150M/nForce 630M
- AMD Turion X2 64
- Windows 7 Professional Installed

Like everyone, I had windows 7 (32-bit) working perfectly when I did a fresh install. Originally, I had Windows Vista on this laptop, but I converted to 7 as son as I got the chance. In fact, a few of my mic driver problems with the RC were solved with this new one. Anyway, I ran my antivirus (Malwarebytes' Anti-Malware), and it identified 4 trouble spots. I trusted its judgement, I rebooted, but I came back with no audio whatsoever. I hover my mouse over the speaker icon in the tray, and all it says is "No Audio Output Device is installed." I try to troubleshoot it, I click on it, and it offers to download the specific driver. I downloaded it, installed it and rebooted, several times, and I still come back with no audio at all.

I checked the log that my AV makes, and, concerning the files it found, it says this:
"Files Infected:
C:\Windows\System32\drivers\drmk.sys (Spyware.Zbot) -> Quarantined and deleted successfully.
C:\Windows\System32\DriverStore\FileRepository\wdmaudio.inf_x86_neutral_aed2a4456700dfde\drmk.sys (Spyware.Zbot) -> Quarantined and deleted successfully.
C:\Windows\winsxs\x86_microsoft-windows-iis-sharedlibraries_31bf3856ad364e35_6.1.7600.16385_none_10bfc8e81625ecbd\iisreg.dll (Spyware.Zbot) -> Quarantined and deleted successfully.
C:\Windows\winsxs\x86_wdmaudio.inf_31bf3856ad364e35_6.1.7600.16385_none_603daf367b793e32\drmk.sys (Spyware.Zbot) -> Quarantined and deleted successfully."

I checked the Device Manager in the Control Panel, and under "Sound, Video, and Game Controllers" there are two devices: "Conexant High Definition SmartAudio 221" and "Microsoft Trusted Audio Drivers", each with a flag next to the icon. In the Properties of each one of them, in the Device Status in the General Tab, it says "Windows cannot load the device driver for this hardware. The driver may be corrupted or missing. (Code 39)"

I try to update the driver for both of them, and I click "Search automatically for updated driver software" and after a little time, it says that "The best driver for your device is already installed."

I tried going straight to NVIDIA's website and downloading and installing the drivers from the Support section as well. But that's not getting me anywhere either!

I remember seeing something about a co-processor somewhere, but I can't remember.

Can anyone help me? I need my audio!

My System SpecsSystem Spec

06 Oct 2009   #2


Device Manager
Uninstall the offending devices

Report results
My System SpecsSystem Spec
06 Oct 2009   #3

Windows 7 Professional

I uninstalled Malwarebytes' Anti-Malware

Then I rebooted

Everything's clean as a whistle....

This is the weirdest fix I've ever encountered my AV was the problem? Now I need a new AV, maybe Microsoft's Security Essentials will do me one better.
My System SpecsSystem Spec


 No Audio Output Device installed

Thread Tools

Similar help and support threads
Thread Forum
No Audio Output Device is Installed
I believe this is an issue regarding an update. I had this issue before and did a system restore to back before I had installed a certain program, and the issue went away. Now however, I do not have a restore point that will go far enough back. I started up my computer today and I was hit...
no audio output device installed
This is my wife's sony vaio, and she has had this problem with no sound on her laptop, when checking the volume control it says no audio output device installed. In device manager it says that she has Intel display audio. I need major help here please.
Sound & Audio
No AUDIO OUTPUT DEVICE IS INSTALLED, this is the message l got on sound icone since l installed windows 7 l have downloaded it several time the latest one it shows on control panel but not on device manager, l guess this is not really installed but l keep installing it and restat the laptop...
Sound & Audio
No audio output device installed
I bought a generic computer. It had windows vista installed and it used to display a message that No audio output device is installed . I recently installed windows 7 home premium 32 bit on it but it still says the same thing. I went to properties of it and found following error message.This device...
Sound & Audio
No audio output device installed...Tried everything, need some help.
All fixed...Hardware issue. Stripped it down and rebuilt it. Booted up and installed the drivers....woohoo I have sound Hi, I have had this problem now for a couple of months. What I have tried: Reinstall windows 7 Update bios Install the realtek high definition audio...
Sound & Audio
Realtek Audio: No Audio Output Device is Installed
Hello. Im having the dreadful "No Audio Output Device is Installed" problem on my realtek audio. It worked some months ago, but im in no position to do a roll back. Im sure the hardware is just fine, it works with Ubuntu. The computer is a Dell Vostro 430. My OS is win7 64bit. I tried...
Sound & Audio

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 18:45.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App