Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Bad sound quality in MC / good in WMP


08 Oct 2009   #1

windows7
 
 
Bad sound quality in MC / good in WMP - Solved

mp3s that play perfectly in WMP are playing with very bad quality in media center (cracking sounds, slow downs...).

I have seen people with similar issues but mostly with x64 setups. Can this be a driver problem and if so does anyone have a pointer for better audio drivers? This is really frustrating, any help greatly appreciated!

Here is my setup:

Operating System Windows 7 Professional Media Center Edition 6.1.7600

--------[ Summary ]-----------------------------------------------------------------------------------------------------

Computer:
Operating System Windows 7 Professional Media Center Edition
OS Service Pack -
DirectX 4.09.00.0904 (DirectX 9.0c)
Computer Name SALON
User Name Home

Motherboard:
CPU Type Intel Pentium 4 530, 3000 MHz (15 x 200)
Motherboard Name Unknown
Motherboard Chipset Unknown
System Memory 2048 MB
BIOS Type AMI (06/26/08)
Communication Port Communications Port (COM1)
Communication Port ECP Printer Port (LPT1)

Display:
Video Adapter GeForce PCX 5300
Video Adapter GeForce PCX 5300
3D Accelerator nVIDIA GeForce PCX 5300
Monitor Generic PnP Monitor [NoDB]

Multimedia:
Audio Adapter Intel 82801GB ICH7 - High Definition Audio Controller [A-1]

[ Motherboard ]

Motherboard Properties:
Manufacturer ASUSTeK Computer INC.
Product P5B-MX
Version x.xx
Serial Number MB-1234567890

My System SpecsSystem Spec
.

08 Oct 2009   #2

windows7
 
 

Update: I just installed the latest Realtek drivers and they don't make any difference.
The problem really seems to be Media Center specific, even the MC starting sound is garbled...
This really sucks, this is rendering MC completely unusable which was the only reason I installed Windows 7 in the first place

franck102
My System SpecsSystem Spec
08 Oct 2009   #3

windows7
 
 

Update2: I have setup ffdshow to decode MP3 in Media Center as described on Hacking Windows 7 Media Center - Plugins Codecs FFDShow dvrmstoolbox showanalyzer comskip haali shark007 - Hack7MC.com and it didn't make any difference.

The playback is poor when it is the only thing happening, and worthless if any activity takes place (pressing a button on the remote or a background image changing).

If the audio drivers are now running outside the kernel, maybe there is a way to give them an extra high priority?
My System SpecsSystem Spec
.


16 Oct 2009   #4

windows7
 
 

Solved... noticed that graphic activity (more than CPU activity) was causing problems, I installed an GeForce 9400GT and connected the MoBo (Asus P5) SPDIF out to the graphic card.
Perfect sound over DVI with that setup... no idea which of installing the new graphic card or switching to digital out did the trick though.
My System SpecsSystem Spec
Reply

 Bad sound quality in MC / good in WMP




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 02:17 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33