Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: No audio through HDMI on Dell XPS 15z

31 May 2013   #1
chancho333

Windows 7 Home Premiuim x64
 
 
No audio through HDMI on Dell XPS 15z

Hi,

I recently bought a Dynex HDMI cable. When I connect to my tv there are no issues with picture quality but there is no sound coming from my TV, just my laptop. The option to set it to default device doesn't work because it is grayed out and says not plugged in I've tried updating my drivers, and am 100% sure they all worked. Looking at my drivers I have:
High definition audio device
nvidia high definition audio
realtek high definition audio

what should I do
thanks


My System SpecsSystem Spec
.
01 Jun 2013   #2
fireberd

Windows 7/10 64 bit
 
 

Delete the High definition audio device, in the Device Manager then restart the PC, and see if that helps.

The High Definition audio device is a Windows installed generic, basic function, audio driver, since you have NVIDIA and RealTek you don't need the High definition audio device.

Also, with the video (Nvidia) and sound drivers, make sure you are using the Dell supplied drivers. I used to do a lot of support on the Dell forums and we found non-Dell drivers in many cases either did not work or did not work correctly.

Go to www.support.dell.com to access the drivers. Access the drivers by your service tag number.
My System SpecsSystem Spec
01 Jun 2013   #3
chancho333

Windows 7 Home Premiuim x64
 
 

It works! thanks so much.
My System SpecsSystem Spec
.

02 Jun 2013   #4
fireberd

Windows 7/10 64 bit
 
 

Cool. Glad I was able to help.
My System SpecsSystem Spec
Reply

 No audio through HDMI on Dell XPS 15z




Thread Tools




Similar help and support threads
Thread Forum
Dell l502x (NVIDIA 540M) HDMI Audio issues (multiple devices)
I have been trying to use my (win7.x64) Dell l502x laptop with my folk's new samsung lcd tv. I finally got the sound bit working (opening nvidia control panel refreshes the audio playback devices list), but I have several erroneous devices that appear (and disappear) when connecting the TV. ...
Sound & Audio
Realtek HDMI Output ATI HDMI Audio -Not Plugged In-
I'm trying to hook up my TV with my computer, and for the most part it's working. The video goes through and I get how to control it and everything. The only thing not working is the sound. I'm using an HDMI to HDMI cable, and like I said the video is fine. Also, when the cable is plugged into...
Sound & Audio
No HDMI audio after running Win 7 audio trouble shooter
I have an Acer Aspire Laptop 57362-4790 running Win 7 with all the latest updates. Audio is an Intel(R) High Definition Audio HDMI, and Realteck HDMI. Because I had no headphone output with the computer connected to my TV via the HDMI out I ran the Windows audio trouble shooter. I got a...
Sound & Audio
No Audio, HDMI (unplugged), No Audio device listed
Hi, I just got a new (cascaded) computer with seemingly no standard audio. The audio icon is a speaker with and X through it and the only audio device that populates the Playback Devices list is the HDMI digital audio. I have audio on the motherboard (think I can find it?? nope) and...
Sound & Audio
HDMI audio problem when connecting LCD TV to PC via HDMI
hi all, I have my media center PC connected to a Sansung LCD TV through an HDMI cable. Everything works fine; the PC detects TV and both audio and video travel through the HDMI cable from PC to TV The problem happens when I turn the TV OFF and ON. In this case, the video is back but not the...
Sound & Audio
Windows 7 - HDMI out no audio - Intel HDMI audio
Hey everyone, I recently upgraded to Windows 7 (Build 7100) from Vista (32 bit) and am having trouble getting audio from my HDMI out port. I am using the Mobile Intel 965 Express Chipset and have upgraded to the latest available driver but still no luck. I have attached a screen shot of my...
Sound & Audio


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 18:14.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App