Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: HDMI not carrying sound

30 Jul 2013   #1

Windows 7 Ultimate x64
 
 
HDMI not carrying sound

I recently installed my new HD Radeon 7950 Graphics card (which was traded in for my 5850). Since then I have been having problems getting sound to work through my TV's HDMI. I have read the forums to find an answer and I've tried several things to get it working.

1) Updated Graphics card drivers
2) Uninstalled and reinstalled the drivers for both my 7950 and 4850 graphics cards
3) Rolled back the drivers for the 7850
4) Changed the HDMI cable's slot in the TV (HDMI 1 is where is worked with my 5850 but I tried other slots just in case)
5) Pressed Windows+P button to change to "Projector Only", followed by Windows+P again "Extend" (this use to work since AMD would not keep my TV as the default audio device when it was plugged in)

I also find it very strange that I have 6 different (yes I said 6) AMD Digital Audio Displays in my playback options (see image below). Notice that the 2nd image is just scrolled down from the first so you can see all the options




Does anyone else have any other ideas?

My System SpecsSystem Spec
.

30 Jul 2013   #2

Windows 7 Professional x64 Linux Mint 16
 
 

Apparently all the ports from both cards can somehow carry audio , but with an adapter of some type or other.

My nVidia card also shows 4.

Don`t know why yours doesn`t default to HDMI when you hook it up.

Don`t change it to different ports on the tv, just use hdmi 1 and keep working at it.


Attached Images
 
My System SpecsSystem Spec
30 Jul 2013   #3

Windows 7, 64 bit Home SP1, Win 8.1.1 Pro 64 bit
 
 

I have the same listing in Sound/Playback devices for my HD7770 video card. In the screen shots shown, there is no HDMI cable plugged in, or if it is, the video card is not detecting it.
My System SpecsSystem Spec
.


30 Jul 2013   #4

Windows 7 Ultimate Retail Box (64-bit installed) + Service Pack 1
 
 

Just FYI: Double post:

HDMI not carrying sound HD 7850
My System SpecsSystem Spec
30 Jul 2013   #5

Windows 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by AddRAM View Post
Apparently all the ports from both cards can somehow carry audio , but with an adapter of some type or other.

My nVidia card also shows 4.

Don`t know why yours doesn`t default to HDMI when you hook it up.

Don`t change it to different ports on the tv, just use hdmi 1 and keep working at it.
AddRAM can you get your audio to work through HDMI with your card? With my old 5850 it only showed one HDMI and it wasn't an AMD port. Just the default HDMI.
My System SpecsSystem Spec
30 Jul 2013   #6

Windows 7 Ultimate x64
 
 

I believe the problem may lie in the fact that the 7050 uses Digital Multi-Point Audio (DDMA).
My System SpecsSystem Spec
31 Jul 2013   #7

Windows 7 Professional x64 Linux Mint 16
 
 

I plug my hdmi cable from my nvidia card to my hdmi 1 input on the tv and the picture and sound work perfectly, I don`t change anything, windows does it automatically.
My System SpecsSystem Spec
02 Aug 2013   #8

Windows 7 Professional x64 Linux Mint 16
 
 

Looking back at your 1st picture, I don`t see your hdtv in the list of choices, like it shows in mine. I think that`s your problem.

When it shows you just high lite it and choose Set Default, the sound will then go to the tv

Most hdtv speakers are terrible anyway, so I choose to either use my headphones, or, my Boston pc speakers have a mini plug audio out on them and I just run it to my Sony Home Theater receiver and play the sound through that. ( but only when I view something on the hdtv, or if I want to play a game and use the hdtv as the viewing source )

I need a bit longer HDMI cord to run the pc into my Sony receiver, then it will be perfect.


Attached Images
 
My System SpecsSystem Spec
04 Aug 2013   #9

Windows 7 Home Premium 64bit
 
 

Hi missionman,
i had the same issue with my 7850. but i found a solution today.

i hope i can describe it good enough in english, so here is what you have to do.

Go to device manager in control panel. then look for audio-, video- and game controller.
right click on AMD High Definition Audio Device or ATI HDMI Audio (if you installed Realteks ATI HDMI Audio driver).

click on driver update and choose the 2nd (search driver on computer) and then list on computer.

choose High Definition Audio Device (its the driver from Microsoft) , do not choose from AMD.

ignore the warning and click on yes.
now it should be working, but without HDCP.

hope you can understand this and hope it helps...

greetings from germany
My System SpecsSystem Spec
Reply

 HDMI not carrying sound




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 02:50 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33