Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.



Windows 7: Sound Control panel takes 2 minutes to open; HDMI sound inconsistent

12 Aug 2013   #1

Windows 7 Home Premium 64 bit
 
 
Sound Control panel takes 2 minutes to open; HDMI sound inconsistent

Brand new Windows 7 Home Premium (6 bit) computer. When I click on the Sound control panel item, sometimes it takes 1-2 minutes to open. But that's kind of minor (although I'd like to know how to fix it), because sometimes the HDMI sound to my HDTV works fine, and sometimes it doesn't work at all. The only sure fix is to reboot the computer, which isn't really what I want to do every time I want sound coming from the HDTV speakers.



More details: if I reboot the computer, and then switch from the monitor to the HDTV for my video output, I can open the Sound control panel (opens at normal speed) and then I select the HDTV to be the default sound device; and everything is good. At some point, I stop watching the HDMI output to the HDTV, switch the video to my main monitor, and the sound now comes out of the computer speakers. Great. That's what I want. I can even turn off the HDTV, come back 20 minutes later, switch the video back to the HDTV and the sound goes through the HDTV speakers. Switch back and forth a couple of times and everything works as expected. Great. That's what I want.



But at some later point in time, it stops working, and I don't know what triggers this. At this later point in time, I switch the video from the monitor to the HDTV, but now the sound remains with the computer speakers, if I try to open the sound control panel, it takes 1-2 minutes, and when it finally opens the sound control panel no longer lets me select the HDTV to be the default sound device. What's wrong? How do I fix this?

My System SpecsSystem Spec
.

13 Aug 2013   #2

Windows 7, 64 bit Home SP1, Win 8.1.1 Pro 64 bit
 
 

I had the slow opening sound panel/playback section for a while. I tried several things and all of a sudden the problem went away. Not sure what fixed it but I have updated the AMD video card drivers several times, no audio driver updates. The only common point is that I too have an AMD video card (HD7770).

In most cases, if the PC "speakers" (sound card) is set as the default audio playback device and then an HDMI cable is plugged into the PC it will automatically switch to the HDMI sound (and make it the default playback device), and if the cable is disconnected it automatically switches back to the speakers. If you are having problems accessing the sound panel, this is another option (for most) until you get the slow opening panel issue resolved.
My System SpecsSystem Spec
13 Aug 2013   #3

Windows 7 Home Premium 64 bit
 
 

Maybe my words weren't 100% clear, but when you say

Quote:
In most cases, if the PC "speakers" (sound card) is set as the default audio playback device and then an HDMI cable is plugged into the PC it will automatically switch to the HDMI sound (and make it the default playback device), and if the cable is disconnected it automatically switches back to the speakers.
that's exactly what happens when things behave normally.

But after an unknown period of time, this behavior stops, and the sound only comes out of the computer speakers even when the HDTV is turned on and video is sent to the HDTV via HDMI. That's when the control panel opens very slowly, and when it does open, I cannot select to use the HDTV as my speakers, the selection is greyed out.

Any ideas?
My System SpecsSystem Spec
.


13 Aug 2013   #4

Windows 7, 64 bit Home SP1, Win 8.1.1 Pro 64 bit
 
 

Check memory and running services the next time that happens. Sounds like something is hogging the memory and/or CPU time.
My System SpecsSystem Spec
28 Sep 2013   #5

Windows 7 Home Premium 64 bit
 
 

Apparent solution:

This is an empirical solution, it has worked for me, but I can't explain the cause and effect, if anyone can explain why this works, please speak up!

My solution is to open the Sound Control panel immediately on starting Windows, and LEAVE IT OPEN! At this point, with the sound panel staying open, regardless of whether I am using the monitor, or the HDTV via HDMI cable, the sound works as expected. When I switch to the HDTV, the sound switches properly. When I switch back to the monitor the sound switches properly. This success is very repeatable.

I have tested this for two weeks, and the original problem did not appear. When I closed the sound panel (as a test), the original problem re-appeared within hours.
My System SpecsSystem Spec
28 Sep 2013   #6

Windows 7, 64 bit Home SP1, Win 8.1.1 Pro 64 bit
 
 

As I mentioned, I can't say what fixed mine, but all of a sudden the delay problem went away.
My System SpecsSystem Spec
Reply

 Sound Control panel takes 2 minutes to open; HDMI sound inconsistent





Thread Tools



Similar help and support threads for2: Sound Control panel takes 2 minutes to open; HDMI sound inconsistent
Thread Forum
Solved Editing the sound in Control panel Sound & Audio
NO SOUND and my Realtek HD Audio will not open from the control panel Sound & Audio
Sound in Control Panel problem Drivers
Sound control panel configuration Sound & Audio
Can't open sound control panel Sound & Audio
Can't open sound control panel Sound & Audio
Can't open sound control panel Sound & Audio

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 02:20 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33