Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Problems with my Sigmatel Audo drivers

20 Oct 2009   #1
rpk2012

Windows 7
 
 
Problems with my Sigmatel Audo drivers

Okay I have an inspiron 1721 with Win 7 Ultimate installed on it. Everything works fairly well on it except I have no audio. It says no device installed, and I have tried all types of different versions, under compatibility mode, admin, and ect... when I try to install the drivers it says things along the line of "Device object not present, quite and restart system and try again."

I only had sounds once, and it was pure crazy loud static.


I am just lost.....

Update STILL TROUBLE: Audio drivers installed. I uninstalled what I found and it re-installed and did the same weird noise issues. Then when I rebooted, it shows no audio output device installed.


My System SpecsSystem Spec
.

21 Oct 2009   #2
scooterdog

Windows 7 Ultimate
 
 

Just an idea - have you tried to go into Device Manager (Windows-Break for a shortcut) and tried to remove any drivers found under 'Sound Video and Game Controllers'? And then let Windows 7 find the appropriate driver for sound.

Reading your post again I realize no drivers were detected did you use the Vista-specific drivers for your version of Windows 7 (32 or 64-bit)? Perhaps go to Microsoft Update Catalog and proceed from there?
My System SpecsSystem Spec
21 Oct 2009   #3
rpk2012

Windows 7
 
 

Quote   Quote: Originally Posted by scooterdog View Post
Just an idea - have you tried to go into Device Manager (Windows-Break for a shortcut) and tried to remove any drivers found under 'Sound Video and Game Controllers'? And then let Windows 7 find the appropriate driver for sound.

Reading your post again I realize no drivers were detected did you use the Vista-specific drivers for your version of Windows 7 (32 or 64-bit)? Perhaps go to Microsoft Update Catalog and proceed from there?

There are no official drivers, BUT I did get some of the vista 64 bit to install.. After the install it shows the sound card, but with a yellow exclamation mark, and asked to restart pc. when I did, it was no longer there after restart... Did this many times...
My System SpecsSystem Spec
.


26 Oct 2009   #4
rpk2012

Windows 7
 
 

UPDATE: Ok people, Update BIOS and it worked without having to do anything else!!
My System SpecsSystem Spec
Reply

 Problems with my Sigmatel Audo drivers




Thread Tools





Similar help and support threads
Thread Forum
Random intermittent Windows Skipping- Audo, Mouse, Video, System
Hello, I just purchased a custom build and had his problem that I cannot duplicate as it is random. I purchased components last week and had the problem so I exchanged everything and got new. Had system built new and problem is still here. Every so often my entire system will hiccup or...
General Discussion
5.1 LPCM audo with Windows Media Center?
Dear people, How can I get Windows Media Center (64-bit) to play 5.1 LPCM audo? (such as found on a Blu-Ray). Allegedly Windows Media Center is supposed to support LPCM; but I can't, for the life of me, get it to work for my m2ts files. Windows Media Player won't do it either (naturally). And I...
Media Center
Sigmatel drivers for dell inspiron 6000
Anyone have any advice to find drivers for sigmatel audio for a dell inspiron 6000. I cannot get any drivers to work so far. Any help would be great.
Drivers
Sigmatel drivers for Inspiron 9400
Hi all, I've searched the forum and got references to but can't find actual posts re: installing drivers for this. Dell Inspiron 9400 laptop, dual boot of XP Home and Windows 7, install of public beta went really well. In Win7 I have a volume icon in task bar, but no audio output I can hear......
Sound & Audio
New IDT/SigmaTel HD Audio Drivers 6230
Windows Vista/7 32-bit Windows Vista/7 64-bit hust download that cab file extract it with winrar, the update the driver in the device manager manually.
Drivers
Sigmatel Audio drivers won't install
Have a tablet PC that I just installed Seven onto. Even though it's an old box, Windows update found nearly all of the drivers. The one it didn't find is for the AC97 Sigmatel audio. So, I grabbed the drivers I used for Vista (they're actually XP drivers) and tried to install them. Did this...
Drivers

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 22:52.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App