Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: recording - no audio device is installed.


14 Sep 2013   #1

Windows 7 Ultimate 32 bit
 
 
recording - no audio device is installed.

i am having a problem here and it seems that no matter what i try i cannot seem to fix it. i downloaded teamspeak 3 yesterday because i wanted to chat with some gaming buddies while playing in a game server (fps) though when i started it up my mic was disabled, checked in the recording devices and have both show disabled and disconnected devices checked though there isn't any device there.

i can listen to music, hear in-game sounds alright through the speakers on my headphones though cannot use the microphone.

i have done the following:

1) troubleshooting / exploring additional options
2) resetting all settings in msconfig
3) un-installing the audio driver and restarting computer
4) checking for an update (the driver is up to date)
5) looking for solutions on google

none of them worked at all and nor had i found anything of relevance...
i have no options left as i do not know what to do, i could try to re-install Windows 7 though that may not work.

what should i do?
i am running Windows 7 ultimate 32 bit, its a stone computer and its got a HD audio device.

My System SpecsSystem Spec
.

14 Sep 2013   #2

Windows 7, 64 bit Home SP1, Win 8.1.1 Pro 64 bit
 
 

Not much to go on, for system model/specs.

Have you reinstalled the PC vendor's sound driver? If not, that is the first step. If you only have "HD Audio Codec" that is just the generic basic function Windows installed sound driver, and not the actual sound chip vendor's driver.

Did the sound and recording work before installing Team Speaker? If it did, use the System Restore function and restore the PC back to an available restore date that is PRIOR to installing Team Speak.
My System SpecsSystem Spec
14 Sep 2013   #3

Windows 7 Ultimate 32 bit
 
 

not sure if it's because of teamspeak or not as all i know is it was working before but its not working now. going to restore the computer and see if that helps...

there is no restore point beyond today for some reason so i cannot restore the computer back to an earlier time. i have tried re-installing the driver but that didn't work either so if i were to download the codec then what codec would i need?
My System SpecsSystem Spec
.


14 Sep 2013   #4

Windows 7, 64 bit Home SP1, Win 8.1.1 Pro 64 bit
 
 

There is no "codec" that I know is needed for recording other than what is built into the sound driver, and Windows.

Uninstall Team Speak, then restart the PC.

Try a complete reinstall of the sound. Go to the Device Manager, RIGHT click on the entry for the sound device to highlight it and then LEFT click "uninstall". DO NOT check the box to also uninstall the drivers. Restart the PC and when Windows starts it will detect and reinstall the sound. If there were any corruption between Windows and the sound this will fix it. If this does not fix it, repeat the uninstall but this time also check the box to uninstall the drivers. Then when Windows starts, do not let Windows look for drivers. Instead install the correct vendor specific sound driver.
My System SpecsSystem Spec
14 Sep 2013   #5

Windows 7 Ultimate 32 bit
 
 

alright i'll give it a shot.
My System SpecsSystem Spec
14 Sep 2013   #6

Windows 7 Ultimate 32 bit
 
 

sorry for the double post, have uninstalled the driver for the HD audio and also uninstalled teamspeak but even after restarting the pc and re-installing that doesn't fix the problem.

the problem is i cannot record, cannot use the microphone. i can hear sounds fine, i have tried just about everything i can think of or what was advised to do and there is still "no" device installed for recording sound/using the microphone.
My System SpecsSystem Spec
14 Sep 2013   #7

Windows 7, 64 bit Home SP1, Win 8.1.1 Pro 64 bit
 
 

Can you post the PC Vendor and model number or the motherboard vendor/Model so I can take a look at what you have. Without that there is nothing, above what I've already suggested to do.

Also did the record ever work? (or was this the first time you tried it).
My System SpecsSystem Spec
15 Sep 2013   #8

Windows 7 Ultimate 32 bit
 
 

the pc vendor is xstone and i'm not sure what the model number is. the motherboard vendor is intel and the model number is E210882.

the record software used to work before but for some reason it isn't working now, i used to be able to use my mic when chatting over skype so i'm not sure what's going on.
My System SpecsSystem Spec
15 Sep 2013   #9

Windows 7, 64 bit Home SP1, Win 8.1.1 Pro 64 bit
 
 

The E210882 is not the Intel board number, according to Intel that could be some regulatory number but not indicative of the board model. The board model would be something like DP35DP, etc.

I would uninstall any other audio application, such as the Team Speak, Skype, etc. Also, if you have a web cam disconnect/uninstall it as I've seen several recording problems that were caused by web cams. Restart the PC and then see what happens with the recording. Some of these applications tend to conflict or take over the PC sound.
My System SpecsSystem Spec
22 Sep 2013   #10

Windows 7 Ultimate 32 bit
 
 

sorry for the late reply as i was busy with college work.
that was my mistake i was looking at the wrong part of the board, the board is an intel board and the correct model number is D945GCZ.

edit -

before you suggest trying to update the audio driver the driver is already the latest version however, i'm a little confused because there seems to be two audio drivers installed. One is IDT which is for windows vista and another is realtek which is for windows xp...

edit-

was thinking of doing a clean install of Windows 7, though might actually restore it back to factory settings instead and was wondering if that would fix the problem or not? because since installing skype back at the start of the year and installing ts3 there has been a load of updates from microsoft and all of which are just slowing down the pc now.
My System SpecsSystem Spec
Reply

 recording - no audio device is installed.




Thread Tools



Similar help and support threads for2: recording - no audio device is installed.
Thread Forum
No Audio Devices Are Installed in Recording Tab Sound & Audio
An Audio Recording Device Cannot Be Found Sound & Audio
Win7 can't find audio recording device Hardware & Devices
No audio recording device Sound & Audio
Realtek Audio: No Audio Output Device is Installed Sound & Audio
No audio recording device installed or found Sound & Audio
Recording: no Audio devices are installed. Sound & Audio

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 06:24 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33