Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: New X-Fi Win 7 Beta Drivers


15 Feb 2009   #21

Windows XP
 
 

Quote   Quote: Originally Posted by Sailindawg View Post
Ought to work fine. I'm using an XtremeMusic that's a couple of years old now. My card works fine with these drivers. It's some of the newer lower end cards that don't so so well at the moment.
Tanks!!!!

My System SpecsSystem Spec
.

16 Feb 2009   #22

Windows 7 Professional 64-bit
 
 
New X-Fi Drivers Do Not Solve Problems with All System Configurations

I'm currently using these beta Creative X-Fi drivers (v2.18.0008 released 1/28/2009). I previously tried the default Win 7 as well as the modded Creative drivers posted in these forums - all exhibit the same problem.

Note to all who read this thread. The default Win 7 and beta Win 7 Creative drivers work fine for many Creative sound card model / motherboard / RAM combinations, but do NOT work for ALL combinations - at least in 64 bit Win 7. What we know so far is that there is a known issue with PCI bus latency where nVidia nForce4 motherboards are being used with Creative cards. There also appears to be a bug in the new driver that mishandles memory management when your system has >3GB RAM. In my case, with my system combination, the only workaround that has had any success has been to use MSCONFIG to limit my RAM to 2GB. Not great for system performance (although performance is surprisingly still more than adequate for non-RAM intensive multi-tasking with Outlook, IE, and Office), but at least I have acceptable sound quality so I can listen to Pandora while I work.

See my original post (#17) on p.2 of this thread and the subsequent discussion that ended up in a different Win 7 Forum thread here for more details on symptoms, root causes, and failed attempts (to date) at resolution of X-Fi crackling, popping, and sound cut-out.

Dale

P.S.
Please click on icon above and add to my reputation if you have found my posts to be helpful.
My System SpecsSystem Spec
22 Feb 2009   #23

Windows 7
 
 

I just noticed on creatives website that they now have windows 7 drivers for X-fi Titanium and Titanium fatality, so for those of you who were left out in the beta drivers in the OP, check out creatives site and look at the beta drivers for your card.
My System SpecsSystem Spec
.


24 Feb 2009   #24

Seven
 
 

Hey all,

Just installed Seven Beta 1...working great...installed creative xfi beta drivers for my xtreme audio...its working excellent...but just wondering why does it show a red x over the sound icon in the right bottom task bar? Its working fine but it just annoys me to see the X I guess I am OCD =). Any ideas?

THANKS,

::rayman::
My System SpecsSystem Spec
24 Feb 2009   #25

Windows 7 Professional 64-bit
 
 
Speaker Icon

Quote   Quote: Originally Posted by rayman121985 View Post
Hey all,

Just installed Seven Beta 1...working great...installed creative xfi beta drivers for my xtreme audio...its working excellent...but just wondering why does it show a red x over the sound icon in the right bottom task bar? Its working fine but it just annoys me to see the X I guess I am OCD =). Any ideas?

THANKS,

::rayman::
Check Manage audio devices under Hardware and Sound...Sound in Control and see if anything appears to be amiss re enabled devices. One possibility could be confusion between onboard sound and your xtreme audio. Have you disabled onboard sound?

Dale

P.S.
Please click on icon above and add to my reputation if you have found my posts to be helpful.
My System SpecsSystem Spec
24 Feb 2009   #26

Seven
 
 

Wierd the reg edit fixed it...the one you apply for the gadgets disappearing after you turn the uac off...so after I applied the reg fix my gadgets are back and my sound doesn't have an x over it anymore! AWESOME! THANKS!

::rayman::
My System SpecsSystem Spec
26 Mar 2009   #27

 
Just the drivers?/temp location of install files?

I run the new (2_18) driver install and it tells me that I don't have the
correct OS, and to upgrade to XP. WTF!
This is the CORRECT install file (SBXF_W7DRVBETA_US_2_18_0008.exe)

Anyone got a clue why this would happen or what the install file may be reading?
Anyone know where creative unpacks their drivers during the install?

Thanks
Will
My System SpecsSystem Spec
27 Mar 2009   #28

Windows 7 Professional 64-bit
 
 

Quote   Quote: Originally Posted by willr666 View Post
I run the new (2_18) driver install and it tells me that I don't have the
correct OS, and to upgrade to XP. WTF!
This is the CORRECT install file (SBXF_W7DRVBETA_US_2_18_0008.exe)

Anyone got a clue why this would happen or what the install file may be reading?
Anyone know where creative unpacks their drivers during the install?

Thanks
Will
What version OS are you running and what are your system specs (specifically which model sound card)? (Filling out System Specs in your profile helps us help you.)
My System SpecsSystem Spec
27 Mar 2009   #29

 

Sure;

Running EVGA x58 MB
6G OCZ RAM
x-fi fatality gamer card (pci)
zalman 750 ps
Win 7 build 7K
ATI 4830 Graphics card
samsung burner (SATA)
J. Skil SSD (128G) OS
V-Raptor 150G internal disk

Thanks
Will
My System SpecsSystem Spec
27 Mar 2009   #30

Windows 7 Professional 64-bit
 
 

Quote   Quote: Originally Posted by willr666 View Post
Sure;

Running EVGA x58 MB
6G OCZ RAM
x-fi fatality gamer card (pci)
zalman 750 ps
Win 7 build 7K
ATI 4830 Graphics card
samsung burner (SATA)
J. Skil SSD (128G) OS
V-Raptor 150G internal disk

Thanks
Will
Are you first saving the beta driver to disk and then running the executable?

Are all of your other device drivers properly installed per Device Manager?
My System SpecsSystem Spec
Reply

 New X-Fi Win 7 Beta Drivers




Thread Tools



Similar help and support threads for2: New X-Fi Win 7 Beta Drivers
Thread Forum
Solved Will Nvidia beta drivers work on 64-bit? Drivers
BSOD in BF3 beta, 285.38 drivers BSOD Help and Support
Auzentech Seven beta drivers now available Sound & Audio
Beta drivers/W7 7201 Graphic Cards
Drivers different from Beta? Network & Sharing
Beta Drivers out for Asus P6T Deluxe V2! Drivers
Netgear says NO to beta drivers? Drivers

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:53 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33