Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Suddenly No Sound Through HDMI on Dell XPS L702x

10 Oct 2013   #1
SuperBadFalcon

Windows 7 Home Premium 64-Bit
 
 
Suddenly No Sound Through HDMI on Dell XPS L702x

Hi everyone,

I am new here and I want to say thank you in advance for taking the time to assist me.

Ok,

I have a Dell XPS L702x which is about a year plus old. I have always used it with my Sony Bravia TV to watch movies on. Let it be known I also plug this laptop into a LGTV with no issues. Never have experienced a problem with video or sound, always has worked flawlessly. Yesterday, I plugged it into the LGTV to let my son watch a movie and was struck with the sound only coming from the laptop and not the TV as it should. The video was fine.

Last night, I took the laptop back to my room and did some digging as it didn't work on my Sony Bravia all of the sudden either. When I went to look in playback devices, I only had two options. First being speakers, and the second being RealTek Digital Output, which no matter what I did it says unplugged and I can not change anything about it or make it default. My TV is not listed anywhere as a playback device as I have read other places it should be.

I read a couple of threads here and there and decided to delete something out of Device Manager. So I went into System Devices and saw two versions of High Definition Audio Controller, so I deleted one of them and restarted my laptop and let it install the driver again. Voila, it worked.

So to today, I again tried to plug my laptop into the LGTV for my son, and again the problem has popped up. I did the same thing I did last night with no luck. Tried it again, no luck. I then visited the Dell website and downloaded the RealTek driver that coincided with my Service Tag to be sure there were no issues there. Still, no audio through the TV only through the laptop.

I've went back into to Device Manager and have noticed in System Devices there is only one version of High Definition Audio Controller now. I'm not really sure what sparked this problem and why it reappears after being fixed last night. As I said, this has worked flawlessly for over a year. If someone could please help me I would be grateful.

Listed under Sound Controllers currently is:
Intel Display Audio
RealTek High Definition Audio


EDIT FOR UPDATE :

Now when I go into Device Manager : System Devices, I see two on the High Definition Audio Controllers. Also, under other devices there are now two Audio Device on High Definition Audio Bus' listed with question marks.


My System SpecsSystem Spec
.
10 Oct 2013   #2
fireberd

Windows 7/10 64 bit
 
 

Uninstall both High Definition Audio devices in the Device Manager (you should only have one RealTek listed), DO NOT check the box to also uninstall the drivers, then restart the PC. When Windows starts it should detect and reinstall the RealTek sound (which is for the PC speakers). Not sure why two showed up.

The Intel Display Audio is the HDMI audio.

Dell also has a help forum, with users helping users. The laptop hardware forum can be accessed here: http://en.community.dell.com/support...op/f/3518.aspx
My System SpecsSystem Spec
10 Oct 2013   #3
SuperBadFalcon

Windows 7 Home Premium 64-Bit
 
 

Quote   Quote: Originally Posted by fireberd View Post
Uninstall both High Definition Audio devices in the Device Manager (you should only have one RealTek listed), DO NOT check the box to also uninstall the drivers, then restart the PC. When Windows starts it should detect and reinstall the RealTek sound (which is for the PC speakers). Not sure why two showed up.

The Intel Display Audio is the HDMI audio.

Dell also has a help forum, with users helping users. The laptop hardware forum can be accessed here: http://en.community.dell.com/support...op/f/3518.aspx

Thanks for replying, I was messing around with it while waiting for a reply and decided to check the driver for the NVIDIA and noticed there was a newer version available and updated it. After restarting again I noticed the other devices with problems in Device Manager had decided to install them selves again. Once again, my laptop was working fine. I suspect it will do this again real soon since it was working last night when I went to bed and broken again this morning.

Any idea what would cause it to keep corrupting?
My System SpecsSystem Spec
.

10 Oct 2013   #4
fireberd

Windows 7/10 64 bit
 
 

Hard to tell what is happening. Wait and see what happens. If you are lucky its fixed.
My System SpecsSystem Spec
11 Oct 2013   #5
SandeepP

Winndows 7 32 bit
 
 

Quote   Quote: Originally Posted by SuperBadFalcon View Post

Thanks for replying, I was messing around with it while waiting for a reply and decided to check the driver for the NVIDIA and noticed there was a newer version available and updated it. After restarting again I noticed the other devices with problems in Device Manager had decided to install them selves again. Once again, my laptop was working fine. I suspect it will do this again real soon since it was working last night when I went to bed and broken again this morning.

Any idea what would cause it to keep corrupting?
Hi SuperBadFalcon,

Welcome to Seven forums.

Please check the system for sometime and if the issue occurs again you should check out this link below for further information:

AUDIO FAQ

Keep us posted with the results so we can advise you further.
My System SpecsSystem Spec
Reply

 Suddenly No Sound Through HDMI on Dell XPS L702x




Thread Tools




Similar help and support threads
Thread Forum
LG TV & Dell Windows 7 64 bit - Sound won't work via HDMI
I cannot get sound to play through my HDMI cable from my desktop to my LG TV. I am able to do video but no sound. I have a Dell Windows 7 64 bit. Kaspsersky Internet Security I used to get sound and then after a couple of months of not connecting my Computer to my TV (because there was...
Sound & Audio
What is the HD interface for Dell L702X laptop?
Hi. I plan to purchase a 1 or 2TB internal HD for a Dell XPS L702X laptop and wondered what it uses. Is it using SATA 1, 2 or 3? Amazon lists all of these different options and I'd like to purchase the right drive for this machine. Thanks.
Hardware & Devices
BSOD - Dell XPS 17 (l702x) - W7 Ult 64-bit - Various bug check values
Okay, well this has been going on for a couple of months so I thought I'd finally post the details here and see if you guys can help me pin-point the problem? I bought a new Dell XPS 17 laptop (Core i7) earlier in the year which ran fine for the first couple of months but then started to...
BSOD Help and Support
BSOD when going to/coming from idle, Dell XPS L702x
Hi BSOD gurus, I've had this dell laptop for over a year now and has worked fine until recently, when I return to my computer i've found that i get the BSOD. Up until now, i've just closed the screen, and walked away and have had no problems. Now in order to avoid the BSOD, i have to shut down...
BSOD Help and Support
Dell XPS L702x screen won't come on after timeout
I have two brand new L702x's which are both playing up. when the screen turns off, as per the timeout set in power options, "Turn off the display", it won't come back on until I press ctrl alt del. Even when an external screen is plugged in, it doesn't come back on but the second screen does.......
General Discussion
Another No HDMI Sound post RC7 upgrade - Dell XPS
Ok.. I have seen it brought up here a couple times but my situation still seems a bit different. I also have no sound coming from my Hdmi out after upgrading to RC 7. I have a Dell XPS 1330 notebook. Audio is Nvidia HD Audio and IDT HD audio codec, both have latest drivers. When i open...
Sound & Audio


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 12:34.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App