Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Sound will play from headphones but not speakers. (Desktop)


09 Nov 2013   #1

Windows 7 Ultimate x64
 
 
Sound will play from headphones but not speakers. (Desktop)

I was having some issues with my harddrive having a memory leak and it was running out of space. I tried to install a Nvidia driver and everything got screwed up on my computer. I use a sli system with two video cards. I didn't realize at first it was my harddrive, so I switched the cards ports and later managed to get the video driver to install correctly after clearing space on my harddrive. My physical speakers have not worked since.

I can get audio to play perfectly now from my headphones, but my speakers will not play sound no matter how hard I try. I've tried making sure they're enabled, I've tried re-installing the audio driver multiple times. I've tried everything I can think of with my sound settings and I can't figure out what's going on. My physical speakers are a surround sound system. I have 3 ports (black, orange, green used right now) that my speakers use. The computer detects that these are hooked up in the realtek control panel (ports are highlighted while the rest are transparent).

In order to rule out an actual issue with the speakers, I tapped the tips of the plugins for the speakers and it reacted to tapping with sounds from the speakers.

I've cloned the harddrive to a new fixed one with a higher memory capacity since this problem started. I did a test for corruption with command "sfc /scannow" in run and found nothing. The new harddrive hasn't fixed the problem.

Any ideas?


My System SpecsSystem Spec
.

09 Nov 2013   #2

Windows 7, 64 bit Home SP1, Win 8.1.1 Pro 64 bit
 
 

Check the Control Panel/Hardware and Sound and finally the Sound Panel. Your "Speakers" (the RealTek) should be set as the Default Audio Playback device. If not, you will not get any speaker sound.

As you installed NVIDIA and whatever with the video, the HDMI may have been set as the default playback device, and in this case the headphones would work but not the speakers.
My System SpecsSystem Spec
09 Nov 2013   #3

Windows 7 Ultimate x64
 
 

Yea, I've tried going through and changing default devices. Trying to "test" any of the devices in playback is what I was doing to try to see if it was working at all. Whenever I try to "test" or "configure speakers" and do the sound test, it plays no sound at all, but will work perfectly when I have a headphone plugged in.

I've gone through and switched the speakers off and on as the default device and I've also gone into the sound options in the bottom right taskbar switching between what sound should be playing though, nothing has helped this issue. :/
My System SpecsSystem Spec
.


10 Nov 2013   #4

Windows 7, 64 bit Home SP1, Win 8.1.1 Pro 64 bit
 
 

I assume you are plugging the headphone into the front panel speaker jack. Try the headphones in the rear Green speaker jack and see if you hear anything.
My System SpecsSystem Spec
10 Nov 2013   #5

Windows 7 Ultimate x64
 
 

Hmm, well the headphones work by usb. The speakers work by the green, orange, and black jacks in the back. I'll try to see if plugging in a regular set of headphones into the speaker input works later today though.
My System SpecsSystem Spec
10 Nov 2013   #6

Windows 7 Ultimate x64
 
 

I tried plugging headphones into the jack. The computer gave me a notice that i had removed items from the audio jack. I then plugged in my headphones, the computer let me know that something had been plugged in. Started playing a video....no sound.....so the computer is recognizing the jacks....everything is enabled....yet it's still not playing sounds....I'm baffled here...
My System SpecsSystem Spec
11 Nov 2013   #7

Windows 7, 64 bit Home SP1, Win 8.1.1 Pro 64 bit
 
 

Something else to check. Since you were inside the PC, check the front panel headphone/mic connection on the motherboard. It may have been disturbed. In fact, temporarily unplug that from the motherboard and see if that makes a difference.

The USB connected headphones doesn't utilize the PC's sound device output so that can be throwing you astray.
My System SpecsSystem Spec
Reply

 Sound will play from headphones but not speakers. (Desktop)




Thread Tools



Similar help and support threads for2: Sound will play from headphones but not speakers. (Desktop)
Thread Forum
Play some sounds through speakers and some through headphones Sound & Audio
Speakers play ONLY when headphones are plugged in Sound & Audio
'Speakers: Not plugged in' issue. No sound from speakers/headphones? Sound & Audio
Speakers and headphones play at the same time? Sound & Audio
Headphones and speakers play at the same time Sound & Audio

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 06:30 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33