Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: klipsch promedia 5.1

11 Dec 2013   #1

Windows 7 ultimate 64-bit
 
 
klipsch promedia 5.1

Does anyone out there know where I might still be able to find one of the discontinued Klipsch promedia 5.1 surround speaker system? I have this exact system now(yes it is a computer surround speaker setup); but sometimes the huge subwoofer that came with the system starts crackling a bit and then the sound/bass starts cutting in and out sporadically. If not the whole system then just the subwoofer itself would help out too. Thanks Matt

My System SpecsSystem Spec
.

12 Dec 2013   #2

Windows 7, 64 bit Home SP1, Win 8.1.1 Pro 64 bit
 
 

Have you tried cleaning all the connectors, both at the PC and all the internal speaker system connections. Could just be a bad/dirty plug or jack.

A quick method is just to unplug each connector then plug back in.
My System SpecsSystem Spec
12 Dec 2013   #3

Win 7 Ultimate 64 bit
 
 

If you find a used set, check to see if sub has a fuse on the back. I've read the newer models weren't as well built as the earlier ones and the way to tell them apart was the newer ones didn't have a fuse.
My System SpecsSystem Spec
.


12 Dec 2013   #4

Windows 7 ultimate 64-bit
 
 

yea; I dont know if mine has a fuse or not as i have not really looked to see. I wish klipsch wouldnt of stopped making the promedia system as the sub has kick a$$ bass!!!; one time I accidentally turned it up a little too much and it dang near knocked things off my shelves above my monitor. lol.
My System SpecsSystem Spec
12 Dec 2013   #5

Win 7 Ultimate 64 bit
 
 

That sounds like my Corsair SP2500 (it's only a 2.1 system so you probably wouldn't be interested in it; it's great for music, though, when paired with my Asus Xonar Essence STX sound card). When I first set it up, I cranked everything briefly out of curiosity and almost wet myself! Dang!
My System SpecsSystem Spec
12 Dec 2013   #6

Microsoft Community Contributor Award Recipient

Windows 7 Ultimate 64
 
 

Are you sure the break up you hear isn't the woofer surround being damaged? If not then it could be amplifier related and starting with contact points and connections is always the first check point. If the unit isn't serviceable and you suspect is bad then look to ebay for replacement of parts or complete unit.
My System SpecsSystem Spec
Reply

 klipsch promedia 5.1




Thread Tools



Similar help and support threads for2: klipsch promedia 5.1
Thread Forum
New Klipsch Speakers Chillout Room
Best way to setup the Klipsch 4.1 speakers with Realtek Sound & Audio

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 10:33 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33