Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Advent T9403 - No Sound

25 Oct 2009   #1
schoolfrenz

windows 7
 
 
Advent T9403 - No Sound

I've upgraded this machine from XP to Win7 but the drivers for sound (CMedia CMI9880L) and Network (Creatix 405 PCI 802.11g wireless) don't install. They were ok for Win7RC.
I've spent a day searching for compatible drivers but nothing works.
Any advice out there?


My System SpecsSystem Spec
25 Oct 2009   #2
zigzag3143

Win 8 Release candidate 8400
 
 

Quote   Quote: Originally Posted by schoolfrenz View Post
I've upgraded this machine from XP to Win7 but the drivers for sound (CMedia CMI9880L) and Network (Creatix 405 PCI 802.11g wireless) don't install. They were ok for Win7RC.
I've spent a day searching for compatible drivers but nothing works.
Any advice out there?
SF

the drivers (if they are vista, or xp drivers) need to be installed in compatibilty mode. to do that you right click the file>properties>compatibility mode.

Let us know if you need help or it doesn't work

Ken
My System SpecsSystem Spec
27 Oct 2009   #3
schoolfrenz

windows 7
 
 

Quote   Quote: Originally Posted by zigzag3143 View Post
Quote   Quote: Originally Posted by schoolfrenz View Post
I've upgraded this machine from XP to Win7 but the drivers for sound (CMedia CMI9880L) and Network (Creatix 405 PCI 802.11g wireless) don't install. They were ok for Win7RC.
I've spent a day searching for compatible drivers but nothing works.
Any advice out there?
SF

the drivers (if they are vista, or xp drivers) need to be installed in compatibilty mode. to do that you right click the file>properties>compatibility mode.

Let us know if you need help or it doesn't work

Ken
I've tried various compatibility modes but none install the drivers. Previously they worked fine on XP SP3.
They did work when I did the same on Win7RC. Perhaps the difference is that RC was Ultimate whereas I've now bought and installed Home Premium?
Any further advice?
My System SpecsSystem Spec
04 Dec 2009   #4
nadeem

Windows 7 Ultimate
 
 

Hi there: I have the same problem. I can not find a driver for my sound card CMI9880L after I have upgraded to Windows 7 Ultimate.

Any advice would be greatly appreciated!

Nadeem.
My System SpecsSystem Spec
05 Dec 2009   #5
schoolfrenz

windows 7
 
 

I gave up and remained soundless pending purchase of a new machine.
My System SpecsSystem Spec
07 Dec 2009   #6
nadeem

Windows 7 Ultimate
 
 

Well, it's not that bad. Since I have a desktop computer, I can buy an extra sound card and just plug it in. Or you think that won't work either??!!!
My System SpecsSystem Spec
27 Jan 2010   #7
karl123

 
 
Sound in Windows 7 for C-Media CMI9880L

The following works.
Extract the driver in XP with a driver backup program (driver checker, etc).
Store it in a folder. (It is in the attachment: downlaod and unpack).
Goto Device Manager, right click Audio and select Update driver.
Point to the driver folder in next menus.
Ignore the message that the driver cannot be checked.


Attached Files
File Type: rar C-Media High Definition Audio Device.rar (3.35 MB, 1413 views)
My System SpecsSystem Spec
09 Apr 2010   #8
skenthome

 
 
No sound on Advent T9504 Cmedia 9880 sound card

Many thanks Karl. Worked great. I kust had to reboot and it was fine. Great work.
My System SpecsSystem Spec
12 Oct 2011   #9
dawnwatcher

WINDOWS 7 64 BIT
 
 
C-Media sound drivers

Thanks a million Karl123 for the link to the sound drivers. Downloaded them and installed onto a windows 7 machine. Worked right out of the box with no rebooting.
My System SpecsSystem Spec
14 Jan 2012   #10
andydgg

windows 7 32
 
 

karl123, thanks worked first time... after three days searching.
My System SpecsSystem Spec
Reply

 Advent T9403 - No Sound




Thread Tools



Similar help and support threads for2: Advent T9403 - No Sound
Thread Forum
laptop will not switch on advent k4000 Hardware & Devices
advent printer Hardware & Devices
Advent Drivers! Drivers
Advent drivers ? Drivers
Advent 5302 sound drivers Drivers

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 10:01 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App