Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: No Sound with HDMI connection

04 Jan 2014   #11
rabidwolf

Windows 7 Home 64bit
 
 

And this is with the HD Audio disabled in Control Panel --> Sound, allowing me to listen on headphones through the speakers.




Attached Thumbnails
No Sound with HDMI connection-cpssnip.png  
My System SpecsSystem Spec
.
04 Jan 2014   #12
Slartybart

x64 (6.3.9600) Win8.1 Pro & soon dual boot x64 (6.1.7601) Win7_SP1 HomePrem
 
 

Thanks
I see Realtek HD audio is enabled (and it's manager in Control Panel)

What happens if you enable the AMD and disable the Realtek?
Screenshots from my machine below


Attached Images
No Sound with HDMI connection-hdmi-aud-.png No Sound with HDMI connection-hdmi-b.png 
My System SpecsSystem Spec
04 Jan 2014   #13
rabidwolf

Windows 7 Home 64bit
 
 

Disabling Realtek Digital Output basically does nothing, my assumption is it disables the audio in the back of the case, which is set up for surround sound. Disabling speakers disables the audio jack in the front, and the HDMI needs to be disabled for sound to play on the "speakers".
My System SpecsSystem Spec
.

04 Jan 2014   #14
Slartybart

x64 (6.3.9600) Win8.1 Pro & soon dual boot x64 (6.1.7601) Win7_SP1 HomePrem
 
 

Ok, thanks.

I do not have the AMD HDMI Output checkbox ticked in the Volume Control Options (your screen shot does) - I only have "All devices cureently palying sound" ticked

When I open the volume mixer, I see
Speakers and Headphones (IDT HD Audio CODEC)
System Sounds

I do have the AMD volume control when I connect my laptop to my TV

A quick search found:
Uninstall both the Realtek and AMD drivers
Install only the AMD dirver

AND

Solved FIX - AMD HDMI no sound output to monitor speakers
My System SpecsSystem Spec
05 Jan 2014   #15
rabidwolf

Windows 7 Home 64bit
 
 

No luck.

I notice that my Device manager does not have the subheader "Audio inputs and outputs" that the link describes. In any case, I uninstalled both drivers and devices under "Sound, video, and game controllers" and only installed the AMD driver (the newest one that I downloaded from their website).

My devices no longer come with Realtek in their description, and I now have actual headphones as an option which is my front audio jack, but not matter what I disable or enable or set as default, my audio never plays through the TV. Im attaching a screenshot with as much information as possible.

I still have two devices under "Sound, video, and game controllers" even after the uninstall/reinstall, one by Microsoft and one by AMD. The disabling/enabling the AMD device appears to disable/enable the TV, while disabling the Microsoft device disables/enables the speakers,headphones, and digital audio in my video control options window.

Damn this is frustrating.


Attached Thumbnails
No Sound with HDMI connection-noidea.png  
My System SpecsSystem Spec
05 Jan 2014   #16
Slartybart

x64 (6.3.9600) Win8.1 Pro & soon dual boot x64 (6.1.7601) Win7_SP1 HomePrem
 
 

There are two HD audio controllers listed under System devices. I can't tell what they are, but sometimes driver uninstalls need a little help cleaning up.

Download, install, and run Driver Fusion
Direct Download

Anything Realtek - let Driver Fusion remove.

It might be necessary to uninstall AMD, run Driver Fusion, and then re-install AMD. Your choice, try to clean up only Realtek, or remove AMD, run Driver Fusion (this time any AMD or Realtek - let Driver Fusion remove), install AMD
My System SpecsSystem Spec
05 Jan 2014   #17
rabidwolf

Windows 7 Home 64bit
 
 

SOLVED!

Driver Fusion was not needed, although I did mess around with it for a bit. My solution was a bit counterintuitive.

What I had to do was run the .exe file that I used to install the latest AMD driver, but instead of installing, I had it uninstall everything form AMD. After that I reinstalled, selected custom install (instead of the reccomended express) and had it reinstall everything EXCEPT for the HDMI Audio Control. Rebooted the computer and BOOM, TV audio playing perfect.

Thank you anyone who even attempted to help me, I really appreciate you all giving me someideas to try. Let me know if I can answer and other questions or if anyone runs into this issue like I did.
My System SpecsSystem Spec
05 Jan 2014   #18
Slartybart

x64 (6.3.9600) Win8.1 Pro & soon dual boot x64 (6.1.7601) Win7_SP1 HomePrem
 
 

Great news rabidwolf!

What, if anything, did you do re: Realtek?
What's the staus of AMD HDMI then in DevMgr?

Your information might help others. We were on the reight track - driver conflict, but you worked through it.
Good job!
My System SpecsSystem Spec
05 Jan 2014   #19
rabidwolf

Windows 7 Home 64bit
 
 

The AMD HDMI is now just "Digital Audio (HDMI)" in the playback devices.

I uninstalled all of the realtek drivers before I did anything to AMD, so Realtek is essentially non-existent in my audio now. As a sidenote Realtek has a driver for my network connection, which I never touched since I need that for network connectivity, and that is still active under device manage-->Network Adapters, labeled "Realtek PCIe GBE Family Controller". Seems to have nothing to do with audio.

Im attaching screenshots of the current status of my playback devices and Device Manager, hopefully anyone with similar issues can take a look any help themselves.


Attached Thumbnails
No Sound with HDMI connection-dmanager.png  
Attached Images
No Sound with HDMI connection-pbdevices.png 
My System SpecsSystem Spec
07 Aug 2015   #20
icybergie

Windows 7 Ultimate x86
 
 

I had the same problem and stumbled onto this thread which gave me an idea which is much simpler and it worked.

Instead of uninstalling and reinstalling, just go to device manager, AMD HDMI audio and roll back drivers. It'll work immediately.
My System SpecsSystem Spec
Reply

 No Sound with HDMI connection




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Sound Control panel takes 2 minutes to open; HDMI sound inconsistent
Brand new Windows 7 Home Premium (6 bit) computer. When I click on the Sound control panel item, sometimes it takes 1-2 minutes to open. But that's kind of minor (although I'd like to know how to fix it), because sometimes the HDMI sound to my HDTV works fine, and sometimes it doesn't work at all....
Sound & Audio
NO SOUND TROUGH HDMI ON ACER AX3400-U3032 and No HDMI Icon in sound se
Had to replace motherboard from authorized acer parts dealer now I get no sound through HDMI port. I did through the original board until it got fried by electrical surge. Can any one help or send me a picture of the inside the same model to make sure all jumpers on the motherboard are in the...
Sound & Audio
No sound through speakers.Jack not being detected.HDMI sound only?
So I've got a problem,I changed my case 2 days ago and everything went great,all working as it should be.Up until an hour ago,when the lid got stuck in one of the little clips so after a quick bang it went in.But then I lost my picture on both monitors. So I went to investigate,I ended up...
Sound & Audio
no sound through tv via hdmi, sound plays through laptop speakers (idt
Yesterday I installed a new external hard drive - following the installation - my sound no longer played through my television (video is fine, HDMI connection) and sound now comes ONLY through the laptop speakers. The option for HDMI Audio doesn't appear in the 'sound' menus. I have 'checked'...
Sound & Audio
No sound with HDMI connection.
Ok, when I connect my HP DV6 laptop to my Samsung TV the picture works fine but the sound comes through on the laptop only, not the TV. The problem is that I don't seem to have the driver for HDMI audio output, see the below picture: http://img809.imageshack.us/img809/3569/soundd.png Now,...
Sound & Audio
no sound through hdmi connection
I have just upgraded from vista to windows 7 home premium. On vista, I could watch downloaded programs and movies on my LCD TV through a hdmi lead. I just plugged it in and it worked, with the sound coming through the TV and the stereo speakers ( which are connected to the tv). Now, I only...
Sound & Audio


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 15:47.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App