Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: No Audio via HDMI to TV

27 Oct 2009   #1

Windows 7 Home Premium 64 bit
 
 
SOLVED: No Audio via HDMI to TV

Hi,

I installed Windows 7 yesterday and at first I had no audio to my TV via the HDMI cable. I adjusted the settings via the sound icon on the taskbar, playback tab, changing whether the speakers or the Digital Output Device (HDMI), Sigmatel High Definition Audio Codec was the default. Eventually I got it to work.

Today, however it has stopped working again and no matter what changes I make, nothing works. When I right click on the playback device Digital Output Device (HDMI) and choose TEST, I get the message: Failed to play test tone. All sound comes through the laptop speakers.

I went to device manager and checked the driver for the codec and it was up to date.

When I was using Vista, to get the audio all I had to do was plug in the HDMI cable and the sound automatically went through the TV.

Does anyone have any ideas how to solve this?

My System SpecsSystem Spec
.

27 Oct 2009   #2

Windows 7 Home Premium x64 - Mac OS X 10.6.4 x64
 
 

Have you updated your Sound Drivers?
My System SpecsSystem Spec
27 Oct 2009   #3

Windows 7 Home Premium 64 bit
 
 

I thought by checking for updates to the Sigmatel High Definition Audio Codec I had checked for the sound drivers. Where else should I check?
My System SpecsSystem Spec
.


27 Oct 2009   #4

Windows 7 Home Premium x64 - Mac OS X 10.6.4 x64
 
 

Quote   Quote: Originally Posted by dezmaas View Post
I thought by checking for updates to the Sigmatel High Definition Audio Codec I had checked for the sound drivers. Where else should I check?
You checked these at your Computer Manufacture's website?
My System SpecsSystem Spec
28 Oct 2009   #5

Windows 7 Home Premium 64 bit
 
 

Yes, I downloaded all available updates and just now re-installed my sound and video drivers but to no avail.
My System SpecsSystem Spec
28 Oct 2009   #6

7600.20510 x86
 
 

Try setting the ATI HDMI out as your default audio playback device. Right click speaker icon in system tray near the time, choose playback devices. Right click ATI HDMI to do this.
My System SpecsSystem Spec
28 Oct 2009   #7

Windows 7 Home Premium 64 bit
 
 

Quote   Quote: Originally Posted by torrentg View Post
Try setting the ATI HDMI out as your default audio playback device. Right click speaker icon in system tray near the time, choose playback devices. Right click ATI HDMI to do this.
Yeah I've tried that, it doesn't work.
My System SpecsSystem Spec
28 Oct 2009   #8

Windows 7 Ult, Windows 8.1 Pro,
 
 

Try some different ATI display drivers. Some of them aren't outputting HDMI in Windows 7 consistantly.
My System SpecsSystem Spec
29 Oct 2009   #9

Windows 7 Home Premium 64 bit
 
 

This has been solved. Thanks for the replies.
My System SpecsSystem Spec
Reply

 No Audio via HDMI to TV




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 08:54 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33