Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Sound Card stops Windows from starting

21 May 2014   #1
warfighter67

Windows 7 Ultimate 64bit
 
 
Sound Card stops Windows from starting

Okay so recently I did a fresh install of Windows 7 x64 on a SSD, and I have (more like had) a Creative X-Fi Titanium. It was working fine until I decided to install my old copy of FL Studio 10. I went into the Audio settings and set FL Studio to use Creative ASIO, at which point my whole PC locked up for a good 30 seconds. Afterwards, my sound didn't work at all. I decided to restart my PC to possibly solve the issue, and when it restarted and got to "Starting Windows", it just froze there. I waited a good 2-3 minutes (it usually takes less than 3 seconds) and nothing happened, so I did a hard shutdown and restart and it still wouldn't move. I took the sound card out and used onboard audio and Windows started fine. So I turned off, put the card back in, and then had the same issue. What happened?!

TL;DR: Set FL Studio to use Creative ASIO on my X-Fi Titanium and that screwed up my sound and prevented Windows from starting after a restart.


My System SpecsSystem Spec
.
21 May 2014   #2
fireberd

Windows 10 64 bit
 
 

I have a studio using Sonar X3. I had an Xfi Titanium (the one with the separate front I/O console) and it caused conflicts within Sonar with my recording interface unit (a Focusrite Saffire Pro 40 at the time). I had to uninstall the SoundBlaster sound card and use my on-board that did not have an ASIO driver for my regular PC audio. (I now have a Roland Octa-Capture for my recording interface unit).

Do you have the on-board audio disabled in the BIOS when you are trying to use the SoundBlaster? If not, give that a try.

You could also try a startup repair, with the SoundBlaster installed and see if that helps. Here is how to run startup repair from Microsoft CLICK ME
My System SpecsSystem Spec
21 May 2014   #3
warfighter67

Windows 7 Ultimate 64bit
 
 

Quote   Quote: Originally Posted by fireberd View Post
I have a studio using Sonar X3. I had an Xfi Titanium (the one with the separate front I/O console) and it caused conflicts within Sonar with my recording interface unit (a Focusrite Saffire Pro 40 at the time). I had to uninstall the SoundBlaster sound card and use my on-board that did not have an ASIO driver for my regular PC audio. (I now have a Roland Octa-Capture for my recording interface unit).

Do you have the on-board audio disabled in the BIOS when you are trying to use the SoundBlaster? If not, give that a try.

You could also try a startup repair, with the SoundBlaster installed and see if that helps. Here is how to run startup repair from Microsoft CLICK ME
Thank you for the possible options. I will disable the on board audio next time I install the sound card.

For good measure, I'm going to delete everything Creative related and do a fresh driver install as well. I will let you know how it goes
My System SpecsSystem Spec
.

22 May 2014   #4
warfighter67

Windows 7 Ultimate 64bit
 
 

Disabling onboard (Realtek) HD audio did not work. I set FL Studio's Audio settings to use Creative ASIO and it froze up on me again but eventually set it, but my sound once again did not work. I restarted my PC and opened up FL Studio and it locked up on the logo splash screen for a good 15 minutes before I gave up and hard-rebooted. Startup Repair also found nothing, but the good news is that if I am more patient, it just takes a few minutes to start up if that ever happens again

Any reason Creative ASIO locks me up like that?
My System SpecsSystem Spec
22 May 2014   #5
fireberd

Windows 10 64 bit
 
 

Maybe its a problem or audio configuration issue in FL Studio? Does the SoundBlaster audio work OK in other PC applications?
My System SpecsSystem Spec
22 May 2014   #6
warfighter67

Windows 7 Ultimate 64bit
 
 

Quote   Quote: Originally Posted by fireberd View Post
Maybe its a problem or audio configuration issue in FL Studio? Does the SoundBlaster audio work OK in other PC applications?
Yes it works for other applications but after doing some googling, apparently Creative ASIO is a pretty shoddy driver and it's hit or miss whether it works for your setup or not, and I'm guessing my SSD doesn't like Creative (Other people have complained about SSDs before)
My System SpecsSystem Spec
22 May 2014   #7
fireberd

Windows 10 64 bit
 
 

I don't think its the SSD (I have two SSD's, one for Win 7 and one for Win 8). I've had my SoundBlaster installed, temporarily, in my Win 7 system and had no problems.

Although I don't like it and its hit or miss you can try the ASIO4ALL driver, or if the SoundBlaster has a WDM driver use that in FL Studio and see if it works.
My System SpecsSystem Spec
22 May 2014   #8
warfighter67

Windows 7 Ultimate 64bit
 
 

Quote   Quote: Originally Posted by fireberd View Post
I don't think its the SSD (I have two SSD's, one for Win 7 and one for Win 8). I've had my SoundBlaster installed, temporarily, in my Win 7 system and had no problems.

Although I don't like it and its hit or miss you can try the ASIO4ALL driver, or if the SoundBlaster has a WDM driver use that in FL Studio and see if it works.
Excuse my Ignorance but what's a WDM driver? I do plan on using ASIO4all but it's annoying that I can't hear anything else while composing (sometimes I like to open songs and listen while in my DAW to get on the spot inspiration, and other times I am in Skype calls with my friends, etc)
My System SpecsSystem Spec
22 May 2014   #9
fireberd

Windows 10 64 bit
 
 

In Sonar, I have the option of using ASIO or WDM/KS driver. My Roland Octa Capture and my MAudio Fastrack Ultra 8R both have ASIO and WDM drivers.

Windows Driver Model (WDM) (Windows Drivers)
My System SpecsSystem Spec
22 May 2014   #10
warfighter67

Windows 7 Ultimate 64bit
 
 

Quote   Quote: Originally Posted by fireberd View Post
In Sonar, I have the option of using ASIO or WDM/KS driver. My Roland Octa Capture and my MAudio Fastrack Ultra 8R both have ASIO and WDM drivers.

Windows Driver Model (WDM) (Windows Drivers)
Hmm, sounds interesting. Are there any WDM drivers for onboard audio? I don't recall having a WDM option with my Creative card installed (I took it out again because I don't need it for anything but music creation).
My System SpecsSystem Spec
Reply

 Sound Card stops Windows from starting




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Distortion sound using onboard realtek sound card on windows 7ultimate
Hello,i recently upgrade my system from xp to windows7,i use the same realtek driver and get distortions!I try severall drivers,disable all enhancements/levels on speakers properties with no result(2.1speakers-),i configure them in stereo mode,i reduce the default format to 44100 16bits(cd...
Sound & Audio
Track pad on stops working about 2-3 minutes after starting Windows 7
I have a Sony VAIO VPCEH. The track pad works upon bootup for about 2-3 minutes after Windows starts. It then abruptly stops working. I've already tried disabling everything in the startup menu. Has anyone else encountered a similar problem? If so, how was it resolved?
Hardware & Devices
Boot: "Starting Windows" then stops with black screen & active cursor
Windows 7, after "Starting Windows" stops with a black screen and mouse cursor. 1. I turned on my desktop PC after more than 3 weeks of non use, it was in its package/box. It booted nicely to the desktop but suddenly showed a BSOD and turned off. I turned it on again and it showed a message...
BSOD Help and Support
Toshiba Satellite L755D-S5106 stops at Windows starting bootscreen
Hello all, I hope I am not violating any rules but I just want this get fixed. I have tried everything so far what I have found on the web. The machine is running under Windows 7 64bit. The laptop is of a friend of mine. He said that it wont boot so I thought let me check it out. The case:...
Performance & Maintenance
FIFA 10 stops while it starting
After Installing FIFA 10 when I double click on FIFA10.exe after 3 seconds a black screen came up. It stayed 2 seconds then my os tells me that there's a problem and it tryins look for solution but it didnt find any so plese help any one who knows.:confused:
Gaming
Audigy Card stops my computer from starting
Ok so i installed win7 with out the sound card in and did all the usefull updates and such then i turn the pc off placed in the sound card and turnd it on it started normaly then i turned it off again to go sleep but i hadnt installed the drivers so this morning whn i tryed to start it it hung at...
Sound & Audio


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:12.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App