Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: No audio coming out of HDMI

29 Oct 2009   #1
Gigaflop

Windows 7
 
 
No audio coming out of HDMI

Going to admit to being a bit of a noob here. Once upon a time I used to build computers and had to deal with insane driver problems and other issues back in the day, but fast forward a few years and now I'm faced with a driver problem and have no clue how to resolve.

I have a Gateway P-6860FX laptop. It has an nVidia 8800M GTS and an HDMI output jack.

I did a full clean install of Windows 7, and no longer get audio output through the HDMI jack. I have spent 2 days trying to resolve this problem, but I'm at my wits end. Mind you, Gateway doesn't even seem to realize that Window 7 is out, considering they have NO mention of it in any of the driver support pages, and after contacting them, I have decided I will never buy a gateway again. They basically said that the laptop is out of warantee and they won't answer the support emails unless I PAY to call them. Awesome.

I know there are a lot of threads about HDMI audio not working, and this whole Realtek business, but I have NO idea if I have a realtek audio card. I can't find any info anywhere telling me what kind of audio chip is in my laptop. I went ahead and assumed it was since everyone seems to mention realtek, but when I installed the drivers... nothing happened. Nothing. Not even an error. It appeared to install... and everything was exactly the same as before. If I try to force windows to update the driver and point it to the realtek folder, it says I've got the latest version of the driver.

I've attached two screenshots of what I see in the sound control panel and the Device Manager... but no audio coming out of the HDMI. I'm not even sure what the heck S/PDIF is, and it sounds like it's some sort of connection between the sound card and the video card, but considering it is a laptop, I'm not even sure I'm supposed to see this. When I inspect the properties of it, Windows seems to think it's an optical output jack. I've deleted the driver and let windows reinstall it to no avail. Other images I've seen here, people seem to see an HDMI audio device. As can be seen from my images, I don't.

So does anyone have any idea?




Attached Thumbnails
-devicemanager-ss.jpg  
Attached Images
 
My System SpecsSystem Spec
29 Oct 2009   #2
ba5ik

Windows 7 Ultimate x64 RTM
 
 

Control panel>whatever your audio device is> set your device output as S/PDIF if you had it working on another OS(and it seems you did) this should fix it...
My System SpecsSystem Spec
29 Oct 2009   #3
Gigaflop

Windows 7
 
 

Quote   Quote: Originally Posted by ba5ik View Post
Control panel>whatever your audio device is> set your device output as S/PDIF if you had it working on another OS(and it seems you did) this should fix it...
I wish I had paid attention to what it looked like in Vista. I, for some reason, am pretty sure there used to be something that said "HDMI" before, but now all I have is this S/PDIF thing.

I'm not sure what you are referring to, I don't have anything specific to my audio device in my control panel. I only have what you see in the photos I posted. (Or am I mistaking what you're saying?)
My System SpecsSystem Spec
29 Oct 2009   #4
dj99

Windows Vista Home Premium -> Windows 7 Home Premium
 
 

I'm assuming you have the HDMI cable plugged in from your laptop to a monitor (TV?). On my Toshiba TV, there is a setting to switch between PC sound in (RCA cables) and digital input (SPDIF via HDMI cable). Just a thought.

Also, on my desktop, which is actually a floortop, the MSI video card came with a little two wire cable to pass the audio from the motherboard SPDIF header to the video card and onto the HDMI cable.
My System SpecsSystem Spec
29 Oct 2009   #5
chev65

Windows 7 Ult, Windows 8.1 Pro,
 
 

Quote   Quote: Originally Posted by Gigaflop View Post
Quote   Quote: Originally Posted by ba5ik View Post
Control panel>whatever your audio device is> set your device output as S/PDIF if you had it working on another OS(and it seems you did) this should fix it...
I wish I had paid attention to what it looked like in Vista. I, for some reason, am pretty sure there used to be something that said "HDMI" before, but now all I have is this S/PDIF thing.

I'm not sure what you are referring to, I don't have anything specific to my audio device in my control panel. I only have what you see in the photos I posted. (Or am I mistaking what you're saying?)
Assuming your drivers have been updated to support Windows 7, you will need to right click on the spdif icon and choose "show disabled devices" after that you should be able to choose HDMI then just set as default output device.
My System SpecsSystem Spec
30 Oct 2009   #6
hccsbbdbbc

Windows 7
 
 
Im having the same issues with the same hardware

I have the same setup as Gigaflop. I have now been trying for two weeks to find a solution to no avail. All preivous post in this forum do not solve the problem of: producing sound over the HDMI cable.

I've attached three screenshots of what I see in the sound control panel(I have the exact same results as gigaflop), Sound Device Driver Details, and Graphics Card Driver Details. The HDMI audio device is missing see attached.

I know the S/PDIF is the device that connects the video card to the sound card to allow ouput over hdmi. However, the HDMI audio device is still missing.

Current failed Attempts not mentioned in the post:

(1) The Gateway P6860 FX has an intel PM65 Chipset as specified here:
?????????????????????????

So I tried Intel PM 65 Chipset drivers. But nothing was installed or updated.

(2) I then saw a post that mentioned you may need to install and update for Nvidia HDMI Audio Driver. It also made no changes to my system.

(3)I tried the vista gateway Chipset Driver with no luck.

(4)I also uninstalled/reinstalled the Windows Driver but it has failed as well.

Im out of ideas. And would really like a solution other then reverting to Vista. That would be a wasted of my windows 7 purchase and I would not be able to utilize the new media center features.
[IMG]file:///C:/Users/DVR/AppData/Local/Temp/moz-screenshot.png[/IMG]


Attached Images
   
My System SpecsSystem Spec
30 Oct 2009   #7
ba5ik

Windows 7 Ultimate x64 RTM
 
 

Gateway Support Drivers & Downloads

get the sound drivers they are only 32bit,,, but apparently they work.

p6860fx Win7 no HDMI Audio Out
My System SpecsSystem Spec
30 Oct 2009   #8
hccsbbdbbc

Windows 7
 
 
That Solved the Problem

I want to give a special thanks to the previous poster. My problem is solved and Now I am quite happy.

Here is a screen shot of the drive being there after running the 32bit install from the previous post.


Attached Images
 
My System SpecsSystem Spec
30 Oct 2009   #9
ba5ik

Windows 7 Ultimate x64 RTM
 
 

Just glad to hear it worked
My System SpecsSystem Spec
31 Oct 2009   #10
Gigaflop

Windows 7
 
 
My thanks as well

I too wanted to chime in and say that the driver did indeed work for me as well.

Thank you very much ba5ik. You have saved my sanity.
My System SpecsSystem Spec
Reply

 No audio coming out of HDMI




Thread Tools





Similar help and support threads
Thread Forum
Realtek HDMI Output ATI HDMI Audio -Not Plugged In-
I'm trying to hook up my TV with my computer, and for the most part it's working. The video goes through and I get how to control it and everything. The only thing not working is the sound. I'm using an HDMI to HDMI cable, and like I said the video is fine. Also, when the cable is plugged into...
Sound & Audio
No HDMI audio after running Win 7 audio trouble shooter
I have an Acer Aspire Laptop 57362-4790 running Win 7 with all the latest updates. Audio is an Intel(R) High Definition Audio HDMI, and Realteck HDMI. Because I had no headphone output with the computer connected to my TV via the HDMI out I ran the Windows audio trouble shooter. I got a...
Sound & Audio
Asus K61-IC Sound coming from speakers when HDMI is plugged in
Hi everyone, Here is the issue I'm having. I have an Asus K61-IC dual booting Windows 7 Professional x64 (default) & Fedora 16 x64. In Windows, whenever I plug in a HDMI cable to watch a movie on my LCD TV audio will only come out of laptop speakers and when I open audio properties it says...
Sound & Audio
No audio coming out of HDMI - Gateway MD Series
My laptop is from this series http://www.google.com/url?sa=t&rct=j&q=gateway%20md2614u%20specs&source=web&cd=1&ved=0CC4QFjAA&url=http%3A%2F%2Freviews.cnet.com%2Flaptops%2Fgateway-md2614u%2F4507-3121_7-33496189.html&ei=r-1TT7aOCKnz0gG-tozgDQ&usg=AFQjCNE2rgnQAqsrz4bwF68hCxauiA-bHg and I'm not able to...
Sound & Audio
HDMI audio problem when connecting LCD TV to PC via HDMI
hi all, I have my media center PC connected to a Sansung LCD TV through an HDMI cable. Everything works fine; the PC detects TV and both audio and video travel through the HDMI cable from PC to TV The problem happens when I turn the TV OFF and ON. In this case, the video is back but not the...
Sound & Audio
Windows 7 - HDMI out no audio - Intel HDMI audio
Hey everyone, I recently upgraded to Windows 7 (Build 7100) from Vista (32 bit) and am having trouble getting audio from my HDMI out port. I am using the Mobile Intel 965 Express Chipset and have upgraded to the latest available driver but still no luck. I have attached a screen shot of my...
Sound & Audio

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:49.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App