Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Creative SBS 2.1 370 not working

18 Aug 2014   #1
kumar713

WINDOWS 7
 
 
Creative SBS 2.1 370 not working

My Creative SBS 2.1 370 not working
I have attached an Image. It shows speaker is not plugged in.Help me Guys.
My OS:Windows 7




My System SpecsSystem Spec
.
18 Aug 2014   #2
fireberd

Windows 10 64 bit
 
 

That speaker system is shown as not plugged in. Do you have the correct cord from the speaker system connected to the GREEN speaker jack? and the speaker system powered on?
My System SpecsSystem Spec
18 Aug 2014   #3
kumar713

WINDOWS 7
 
 

Quote   Quote: Originally Posted by fireberd View Post
Do you have the correct cord from the speaker system connected to the GREEN speaker jack?
Yeah
My System SpecsSystem Spec
.

18 Aug 2014   #4
kumar713

WINDOWS 7
 
 

I dropped my power Adaptor few times down. Does this have an effect?
My System SpecsSystem Spec
19 Aug 2014   #5
fireberd

Windows 10 64 bit
 
 

Dropping it could cause it to not work. Do you have a voltmeter to check the voltage output from the power adaptor?
My System SpecsSystem Spec
19 Aug 2014   #6
kumar713

WINDOWS 7
 
 

I don't have voltmeter to check it out the Voltage
My System SpecsSystem Spec
19 Aug 2014   #7
fireberd

Windows 10 64 bit
 
 

Are there any indicator lights that come on when you power on the speaker system?

Connect the speakers to some other device, such as an MP3 player and see if the speaker system works there.
My System SpecsSystem Spec
19 Aug 2014   #8
kumar713

WINDOWS 7
 
 

Quote   Quote: Originally Posted by fireberd View Post
Are there any indicator lights that come on when you power on the speaker system?
Yeah there is an Indicator and it is Glowing Fine
My System SpecsSystem Spec
19 Aug 2014   #9
kumar713

WINDOWS 7
 
 

Quote   Quote: Originally Posted by fireberd View Post
Connect the speakers to some other device, such as an MP3 player and see if the speaker system works there.
Will connect and check it out and Let u Know
My System SpecsSystem Spec
19 Aug 2014   #10
fireberd

Windows 10 64 bit
 
 

If it works on other devices, try plugging into the Headphone jack on the PC.
My System SpecsSystem Spec
Reply

 Creative SBS 2.1 370 not working




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Creative SB cards not working on new pc setup
Hello, i have 3 creative audio cards SB X-Fi Xtreme Gamer/Audio and SB Audigy 2 zs. Resently i have changed motherboard Asus M5A78LUSB3 with fx 6xxx CPU to Asus P8P67 LE with i7 4xxx CPU, all other components remained (they are 2 DIMM G Skill RipjawsX F3-10666CL7-4GBXH, AMD Radeon HD 5800 Series)....
Sound & Audio
[Fatal1ty Creative Headphones] Mic isn't working.
Hello! My problem is that my mic on these headphones will not pick up any of the things i'd like to say anymore. I've had these Fatal1ty Creative Headphones for a year now, and I haven't had any problems in the past. If someone could explain how i could fix this issue, that'd be great.! Oh,...
Sound & Audio
Creative HS-420 headset mic not working
I have a friend who has just purchased a Creative HS-420 headset to use with his Toshiba Satellite Laptop (running Windows 7 Home Premium). The headset cables are plugged into the correct headphone/mic sockets at the front left side of the laptop, and the headphones work fine but the microphone...
Sound & Audio
Creative Fatal1ty Gaming Headset Mic not working
Alright, so I got the Creative Fatal1ty Gaming Headset for Christmas, and because I have rather crappy luck, of course something had to go wrong. This time, it was the mic. It simply doesn't register-or at least, I don't think it does. Stats (if they will help): Windows 64-bit, Dell custom...
Hardware & Devices
Creative SB X-FI Elite Pro Not working
Hello, From the topic title, I have that sound card. I install the latest driver from Creative which is version 2.18.0013. Installs fine, reboots, then the AutoUpdate program comes up to install all the other applications for my device. However, if I try to run like Creative Audio Control...
Sound & Audio
Creative Sound Blaster Audigy LS Not Working
Hello, I've installed Windows 7 on my desktop with dual boot to Vista. Everything's been working fine but I haven't been able to properly setup my sound-card to function properly. As of now, I currently have no sound and I've been through many different drivers from the Creative website. I've...
Sound & Audio


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 15:43.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App