Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: 60~ Hum In Logitech Speakers

19 Sep 2014   #1
ColColt

Windows 7(64) Home Premium
 
 
60~ Hum In Logitech Speakers

I got some new speaker from Dell today, the Logitech Z323 than has a subwoofer and two speakers. Set up was quick and the sound was superb.

Here's the problem...very noticeable 60 cycle hum from all speakers. Not so much when music is playing, only during the silent times or if it's off with no music you can hear it. Any ideas? I tried emailing Logitech but theyr'e undeoig a transfomation with their system and no email till the 29th according to the website.

I went by the instructions and put the green male cable from the right speaker in the green port in back of the computer as shown in the directions.


My System SpecsSystem Spec
.
19 Sep 2014   #2
strollin

W10 Pro desktop, W10 laptop, W10 laptop, W10 Pro tablet (all 64-bit)
 
 

How are the speakers powered? Does the socket that the speaker's power adapter plugged into have a good ground?
My System SpecsSystem Spec
19 Sep 2014   #3
ColColt

Windows 7(64) Home Premium
 
 

Yes, and in fact the noise has went away? I unplugged and re-inserted the plug from the main speaker to the computer and now it's much better.
My System SpecsSystem Spec
.

20 Sep 2014   #4
ColColt

Windows 7(64) Home Premium
 
 

I can't seem to have much luck with these speakers. Last night when I shut down I turned off the right(main) speaker by the volume control knob on the front. This morning at boot up I turned it back on and no light on that speaker to indicate power and no sound. I let the mouse arrow hover over the speaker icon in the system tray and it showed "Speakers 18%". Maybe that's the balance that's configured. There's still no sound.
My System SpecsSystem Spec
20 Sep 2014   #5
matts6887

Windows 7 ultimate 64-bit
 
 

This almost sounds to me like there could be a small short of some sort in the power supply for the speakers. Have you tried to see if you get get a hold of and try out a different power supply? if not i would give this a shot as thats what it sounds like to me.
My System SpecsSystem Spec
20 Sep 2014   #6
ColColt

Windows 7(64) Home Premium
 
 

All I did was turn it off last night and back on his morning. I disconnected the connection between the main speaker and the computer and re-inserted....nothing. It sounded so good last night. I don't have another power supply.
My System SpecsSystem Spec
20 Sep 2014   #7
ColColt

Windows 7(64) Home Premium
 
 

Here's what I just tried. I took the lead that went into the sound card and plugged it into a portable cassette player/recorder, turned on the right main speaker and got sound. However, the power light on that speaker still didn't come on. I unplugged everything and started over and still no sound and no power light.
My System SpecsSystem Spec
20 Sep 2014   #8
ColColt

Windows 7(64) Home Premium
 
 

OK-I tried the most obvious problem an checked the outlet for power...none. I went outside and checked the breaker and none had tripped although I just reset that breaker anyway. It did no good. I decided to just plug into another outlet that was powered, turned the speaker on and no power. I had just checked that outlet and it had 121v on it. When I unplugged the speaker cable from it and rechecked it now has no reading. I don't know what's going on.
My System SpecsSystem Spec
20 Sep 2014   #9
linnemeyerhere

Microsoft Community Contributor Award Recipient

Windows 7 Ultimate 64
 
 

Well you should take a portable device and the speakers and set them up in a different room, if all's well then the issue is that outlet and that could be all sorts of problems. Could be time to replace the entire outlet and if possible go with a medical grade outlet.
My System SpecsSystem Spec
20 Sep 2014   #10
ColColt

Windows 7(64) Home Premium
 
 

There must be a short in the main speaker or the sub woofer as it keeps knocking out the outlets. I tried it in two of them and after doing so there was no power to those outlets.
My System SpecsSystem Spec
Reply

 60~ Hum In Logitech Speakers




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Logitech z506 speakers into an AOC i2757fh monitor
Hello everyone. First post on here. So I got an AOC i2757fh monitor with 2 hdmi ports. So I have my computer on one and my xbox one on the other. Then I got a pair of Logitech z506 speakers since the speakers on the monitor aren't that good. So I have the green audio cable plugged in the back...
Sound & Audio
Logitech Z205 laptop speakers
Hi everyone, was hoping for some help with my Logitech Z205 laptop speakers that have suddenly stopped working - these work directly from any USB port and normally just enhance the sound from the thin sounding laptop speakers. Recently just plugging them in produced no sound just a slight...
Sound & Audio
Logitech z-906 5.1 surround speakers
So i got this speaker along with the new computer and when I try to test the speakers in the config, only the front left and front right is working even though I set it to be 5.1 surround. Then I go ahead and play so music on iTunes and it seem like the rest of the speakers are working... Any ideas?
Sound & Audio
Windows 7 can not recognize my logitech speakers.
I have recently done a clean installation of windows 7, I have notice on my computer that only my monitor speakers are working which is hooked up to my graphics card using an hdmi. And when I look at my playback devices my Logitech speakers do not show up. Also I had to move my computer to a...
Sound & Audio
Logitech 5.1 speakers messed up
I have windows 7 and a realtek HD soundcard which supports 5.1 with dolby home theatre. I bought the logitech x530 5.1 surround sound speakers and when doing the test int he realtek control panel, the sounds for the front speakers are coming from the rear speakers and visa versa. I double...
Sound & Audio
Anyone Got The Logitech Z-2300 Speakers?
If you do, how are they, gonna probably get them tomorrow, let me know!!!
Sound & Audio


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 15:43.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App