Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Dell l502x (NVIDIA 540M) HDMI Audio issues (multiple devices)

12 Nov 2014   #1
jonnyhotchkiss

Windows 7 Ultimate 64bit
 
 
Dell l502x (NVIDIA 540M) HDMI Audio issues (multiple devices)

I have been trying to use my (win7.x64) Dell l502x laptop with my folk's new samsung lcd tv.

I finally got the sound bit working (opening nvidia control panel refreshes the audio playback devices list), but I have several erroneous devices that appear (and disappear) when connecting the TV.

I tried the same device (TV) with the same cable, with my brother's new toshiba laptop, and there were two playback devices (as expected) - speakers, and TV.

Mine looks like this



Can any l502x owners confirm (re driver install) if they did follow these instructions

ie

R300420 Video: (Do "Custom Install", Uncheck HD Audio) nVidia GeForce GT 435M, GeForce GT 420M, GeForce GT 445M, Stereoscopic 3D, GeForce GT 525M, N12E-GE-B(LP)-GT 550M, N12E-GE-B ( GT555M), GeForce GT 540M, v.8.17.12.6721, A07 (155 MB)

willing to try anything to attempt to get this configured "properly".

also having issues with nvidia display driver crashing when external is connected, despite underclocking gpu as advised





My System SpecsSystem Spec
.
12 Nov 2014   #2
fireberd

Windows 10 64 bit
 
 

I have multiple HDMI audio entries listed in the Sound Panel/Playback section. Mine are AMD HDMI audio as I have an AMD Radeon video card.

You have an NVIDIA video card so the reason for the NVIDA listings. The Toshiba may only have the basic Intel Video, for example, and the reason for only one entry.
My System SpecsSystem Spec
07 Jan 2015   #3
jonnyhotchkiss

Windows 7 Ultimate 64bit
 
 

thanks for your contribution. With the AMD devices, are they all unplugged?


(These appear when Samsung TV is connected.
Ususally they disappear after disconnecting HDMI, lately they've been sticking a bit. Disappear about a minute after unplugging HDMI)


How can they be made use of if they're "not plugged in"?
I only have one HDMI port on my l502x
My System SpecsSystem Spec
.

07 Jan 2015   #4
fireberd

Windows 10 64 bit
 
 

That is normal, unless you have an HDMI cable plugged into the PC.
My System SpecsSystem Spec
Reply

 Dell l502x (NVIDIA 540M) HDMI Audio issues (multiple devices)




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Unable to disable audio for HDMI in playback devices panel
I am using HDMI to connect from my laptop to a tv, but it is late and I have a roommate so I want to use headphones for the sound. I plug in the headphones, and go to the playback devices panel. It has an option to disable the tv sound, but it does not work. No error or anything, just does nothing....
Sound & Audio
Nvidia HDMI audio issues.
Just upgrading an old system to Windows 7 with a 9500 GT card and started having issues with a 'Static' clicking sound on Philips HDTV. Have tried to see if I can uninstall the driver but seems to always reinstall itself on boot up. Other things I have tried is disable HDMI audio settings within...
Sound & Audio
No audio through HDMI on Dell XPS 15z
Hi, I recently bought a Dynex HDMI cable. When I connect to my tv there are no issues with picture quality but there is no sound coming from my TV, just my laptop. The option to set it to default device doesn't work because it is grayed out and says not plugged in I've tried updating my...
Sound & Audio
HDMI Audio Out, Realtek + Nvidia
Hi Guys, I really need some help with this one. I purchased a new PC, with a Gigabyte GA-H61MA-D2V motherboard that has on board realtek audio, I also purchased a nvidia geforce GT630 graphics card which has a built in audio processor and hdmi connection which is going to my LG 42PL6010 tv. ...
Sound & Audio
NVidia GTX 460 Hdmi issues
Running Windows 7 Home Premium 32 bit with Nvidia 260.63 beta drivers installed with HD Audio 1.1.19 drivers. I have the hdmi cable running from the EVGA GTX 460 to my Yamaha RXV-667 hdmi 1.4a receiver which ouputs to my Mitsubishi WD65-C9 DLP TV. These latest drivers are supposed to enable...
Graphic Cards
Nvidia Geforce GTX 260 HDMI Out With Audio?
So, I got a Geforce GTX 260 with HDMI Out Via a DMI Adapter. But, in order to have sound on that HDMI output, I need to connect the card to an S/PDIF output on my motherboard. My motherboard is an Asus GA-EP45-UD3L, and I do have an S/PDIF output on it. However, I do not have the cable needed...
Graphic Cards


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 06:21.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App