Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Sound doesnt work after uninstalling SRS Premium Sound program.

02 Dec 2014   #1
alxaki

Windows 7 Home Premium
 
 
Sound doesnt work after uninstalling SRS Premium Sound program.

HP Pavilion g7, Windows 7 Home Premium, laptop with built-in speakers.

Okay so i accidentally uninstalled SRS Premium Sound and now my sound icon on the bottom right shows a red X and doesn't play sound. It could also be related to restoring my laptop, but sound still worked before i uninstalled SRS sound.

When i hover over the sound icon it reads "No speaker or headphones are plugged in." Plugging in headphones or an external speaker to the headphone jack doesn't work.

troubleshoot doesn't detect a problem. Playback devices only shows AMD HDMI Output, but no speaker option (even when i right click and both are checked). Reinstalling Realtek isn't working.

Device manager does recognize i have ATI HD Audio Device.

I'm willing to restore my computer if that's what it takes, but i don't have the CD that came with it.


My System SpecsSystem Spec
.
02 Dec 2014   #2
oscer1

win 7 64 bit
 
 

Hi welcome to 7F

go to bios and make sure the onboard sound is enabled.
My System SpecsSystem Spec
03 Dec 2014   #3
fireberd

Windows 10 64 bit
 
 

Go to HP and download the sound driver (and install it) for your specific model. SRS Premium sound is not the actual driver.

The sound driver appears to be IDT. Software & driver downloads HP Pavilion g7-1150us Notebook PC | HP® Support

You didn't do anything in the BIOS so that can be eliminated.
My System SpecsSystem Spec
.

03 Dec 2014   #4
alxaki

Windows 7 Home Premium
 
 

Fireberd you gave the right answer, thank you so much.
My System SpecsSystem Spec
Reply

 Sound doesnt work after uninstalling SRS Premium Sound program.




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
lenovo y460p touchpad sound and sound does not work
hello i wanted to report a problem i have on my PC regarding the sound..there is no sound without the headphones and my touchpad sound buttons do not work it has been a month already i tried downloading realtek drivers from this site it does not work again..i can only hear sound with my...
Sound & Audio
sound doesnt work
Recently I tried installing Mac Lion skin pack, which prompted me to install Custo pack tools too for changing the log on screen, icons, folders etc... However after restarting the PC My sound driver simply didnt work... The themes and effects were pleasant , but loss of sound was pretty...
Themes and Styles
5.1 Sound doesnt work at Realtek High Definition Audio Device
Hello, Some time ago i was tried to connect my 5.1 creative speakers to my laptop and when i wass connecting one by one the cables windows 7 asked me what speakers it will play ( Rear, Front, Center) but now i try to connect them again and it does not ask me that ... and only 2 speakers and sub is...
Sound & Audio
windows7 home premium 64bit desktop sound does not work
I just joined this forum. I recently upgraded to win 7 home premium 64 bit from xp. I have AV Lab Multimedia Desktop Theater AVL320 sound system. It worked fine with XP, never a problem. With Windows 7 I can use the headset but not the AVL320 sound system as it is not recognised. Any solutions...
Sound & Audio
sound from mic doesnt come out
having problem with my sound card Creative Blaster X-Fi Titanium. The problem is that the mic doesnt produce any sound at all. Even the windows doesnt detect Mic Jack at the sound card. When i jack the mic into my motherboard mic jack, it works. Even tried to solve by uninstall my driver. ...
Sound & Audio
Sound stutters for a second when installing/uninstalling a program
I am having a strange issue with my 2 laptops and 1 dekstop. Whenever I'm listening a song and at the same time I`m installing/uninstalling a program, I have a sound stutters for a second. Every system is with the latest drivers and the mashines are fairly new. Any ideas? :huh: The...
Sound & Audio


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 00:16.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App