Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: No sound, no sound device detected, drives installed?

04 Nov 2009   #1
Madtheos

Windows 7
 
 
No sound, no sound device detected, drives installed?

Hello there! So.. I'm in a pickle with my machine and Windows 7 after this latest update. On startup I get an error from MMDevApi.dll saying that it might not run on Windows or... something else. This also occurs anytime a program tries to use the sound card ie. WoW, Yahoo IM, Live IM, SL, etc. I've updated my sound card drivers to the newest ones. I still get an error that says the device is detected when going to "Sound Devices" in the control panel.

Trying to adjust the sounds themselves leads me to the Windows Audio thing... which won't start even from the component list.

Sound Card is a SB Audigy SE


My System SpecsSystem Spec
.

04 Dec 2009   #2
syhbur

Windows 7
 
 

I have a similar fault with SB Xtreem Music - downloading the latest driver (2.18.0013) sems to corrupt Windows Audio file and it also prevents me from accessing the Control Panel, do you have this fault? otherwise sound is ok.
syhburj@talktalk.net
My System SpecsSystem Spec
Reply

 No sound, no sound device detected, drives installed?




Thread Tools





Similar help and support threads
Thread Forum
No sound through speakers.Jack not being detected.HDMI sound only?
So I've got a problem,I changed my case 2 days ago and everything went great,all working as it should be.Up until an hour ago,when the lid got stuck in one of the little clips so after a quick bang it went in.But then I lost my picture on both monitors. So I went to investigate,I ended up...
Sound & Audio
Installed Windows 7, No Audio Device, Sound Problems
Hi Everyone, I have recently changed my OS to Windows 7 and have sound problems saying No Audio Device. When I used windows update, it installed VIA AC'97 Enhanced Audio Controller successfully, but that only works occasionally. The sound goes blank all of a sudden. I have tried other audio...
Drivers
Installed Windows 7 & im Missing video/audio/ sound drives/drivers !
Ok , i installe windows 7 on my HP laptop today & after all instllation was completed & got all the updates etc .. I noticed 3 things & it stated them in action centre also . 1) Im missing my sound card/driver , cause it says im missing it . my sound card/driver is ; CPT5910a, conexant AC -...
Drivers
Asus F5N W7 X64 No sound device installed
My specs: Microsoft Windows 7 Ultimate 6.1.7600 Build 7600 ASUSTeK Computer Inc. F5N Laptop x64-based PC AMD Athlon(tm) 64 X2 Dual-Core Processor TK-55, 1800 Mhz, 2 Core(s), 2 American Megatrends Inc. 213, 4/8/2008
Sound & Audio
'no output audio device is installed' but sound plays
As above. It says this in the icon in the tray, yet i can play songs fine. The only thing is, it also has my speakers to record, and i can't change it to front mic. any ideas? it was working perfectly fine yesterday... sound is onboard and uses Via hd audiodeck. thanks
Sound & Audio
No Audio Output device is installed! no sound! :(
Hello everyone, i have seen this posted before but my problem is a little different. I can not even find what my sound card is or where it is. I have looked and looked and there is nothing on my computer to show it has a sound card. It did indeed work before i upgraded to 7 so it has to be there....
Sound & Audio

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 10:34.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App