Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Surround Sound Problems Windows 7 64bit


05 Nov 2009   #1

Windows 7 Home Premium
 
 
Surround Sound Problems Windows 7 64bit

Hi this is my first post so if I have'nt done something correct sorry in advance.

But my problem is that I cannot get my surround sound to work on windows 7, it worked fine when i had XP. It has the option but just will not play it.

I have a Abit AB9 pro motherboard, Quad Core 6600, 8GB RAM, Nvidia GeForce 7950 GX2 graphics card, but no seperate sound card.

My sound is optical out to my amplifier (wich was working fine with XP) I have tried everything possible but to no avail I've downloaded the latest Realtek drivers, tried a friends sound card but nothing.

Can somebody please please help me as im nearly pulling my hair out



Thanks

My System SpecsSystem Spec
.

05 Nov 2009   #2

7600.20510 x86
 
 

ftp://ftp-usa.abit.com.tw/pub/downlo..._raid_ahci.zip

Use that. Extract it to a folder.

Right click on the audio device in device manager. Update driver software. Browse. Let me pick. Have disk. Browse. Now find the .inf in the extracted folder and double click on it. Hit ok and let it install.
My System SpecsSystem Spec
05 Nov 2009   #3

Windows 7 Home Premium
 
 

Thanks torrentg but the file that downloads says 0 bytes (is that meant to be?) maybe I've done something wrong? Sorry I'm not at all too good with this technical stuff
My System SpecsSystem Spec
.


05 Nov 2009   #4

7600.20510 x86
 
 

Perhaps they will fix the site or you could message customer service.

Universal abit > Motherboard, Digital Speakers, iDome, AirPace, Multimedia
My System SpecsSystem Spec
05 Nov 2009   #5

Windows 7 Home Premium
 
 

I think maybe its something to do with windows 7 itself as a lot of people are experiencing similar problems like the bass plays fine in the sound test but thats all. I hope a fix to this problem comes out soon as i've tried everything possible now and it really bugging me! but please let me know if you hear of something that'll help solve my problem

thanx
My System SpecsSystem Spec
05 Nov 2009   #6

7600.20510 x86
 
 

My System SpecsSystem Spec
06 Nov 2009   #7

Windows 7 Home Premium
 
 

thanx will try this one and let you know how it goes (fingers crossed)
My System SpecsSystem Spec
08 Nov 2009   #8

Windows 7 Home Premium
 
 

nope i tried it and i'm afraid still no joy
My System SpecsSystem Spec
Reply

 Surround Sound Problems Windows 7 64bit




Thread Tools



Similar help and support threads for2: Surround Sound Problems Windows 7 64bit
Thread Forum
Windows 7 5.1 surround problems (realtek) Sound & Audio
Windows 7 Surround Sound Issues Sound & Audio
Solved Windows 7 5.1 Surround sound help Sound & Audio
No surround sound through HDMI in Windows 7 Sound & Audio
no surround sound windows 7 Sound & Audio
5.1 surround sound problems with SoundMAX Sound & Audio
Windows 7 Sound Problems (Surround settings) Sound & Audio

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:18 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33