Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: sound problems on Thinkpad T42p

05 Nov 2009   #1
wahoobob

windows7 Professional
 
 
sound problems on Thinkpad T42p

I have a Thinkpad T42p that I have put Windows 7 on and most everything is working except for sound. I shows it has the Analog Devices AD1981A AC'97 SoundMAX Codec (Full-duplex) AC97 2.2 compatible as shown in the specs and when I ask W7 to upgrade the driver it says I have the latest driver and that the device is working, but no sound. I have removed and reinstalled the device, still no sound. It isn't muted, or anything simple like that. Also, the sound controls at the top of the keyboard don't seem to have any effect. Any ideas of what to do? Other than sound, W7 runs great on this machine. Aero, etc is enabled and it boots and closes quicker than XP... Thanks for any help.


My System SpecsSystem Spec
.

05 Nov 2009   #2
zx81

Windows 7 Home Premium x64
 
 

Quote   Quote: Originally Posted by wahoobob View Post
I have a Thinkpad T42p that I have put Windows 7 on and most everything is working except for sound. I shows it has the Analog Devices AD1981A AC'97 SoundMAX Codec (Full-duplex) AC97 2.2 compatible as shown in the specs and when I ask W7 to upgrade the driver it says I have the latest driver and that the device is working, but no sound. I have removed and reinstalled the device, still no sound. It isn't muted, or anything simple like that. Also, the sound controls at the top of the keyboard don't seem to have any effect. Any ideas of what to do? Other than sound, W7 runs great on this machine. Aero, etc is enabled and it boots and closes quicker than XP... Thanks for any help.
Hello wahoobob,

Maybe this will help you.

Start -> Device Manager
Select Sound, video and game controllers
Select Sound device, right click, uninstall
Scan for hardware changes
Reinstall driver

Have a nice day!

zx81
My System SpecsSystem Spec
05 Nov 2009   #3
wahoobob

windows7 Professional
 
 

Been there, done that. Any other suggestions?
My System SpecsSystem Spec
.


05 Nov 2009   #4
bummpr

Windows 7 x86 and x64 - RTM
 
 

Quote   Quote: Originally Posted by wahoobob View Post
Also, the sound controls at the top of the keyboard don't seem to have any effect.
Does this mean that you do not see the green volume bars on the LCD screen OR that you see the bars, but changing the volume level has no effect because you have no sound at all????

Also, have you done a Lenovo System Update run? They have a new version which works with Windows 7. You probably do not want most of their garbage programs (or drivers for that matter) but it might point out something.
My System SpecsSystem Spec
05 Nov 2009   #5
wahoobob

windows7 Professional
 
 

I do not see the green volume bars when I press the sound controls. Can you give some directions on the Lenovo system update? Can I do this if the machine came with XP?

........

Never Mind... I read the instructions and this may be the trick. I'll update later.

thanx for putting up with a non-techie.
My System SpecsSystem Spec
05 Nov 2009   #6
wahoobob

windows7 Professional
 
 

Did both suggestions and now the sound is on... Thanks to both...
My System SpecsSystem Spec
14 Nov 2009   #7
jimbrook

windows xp
 
 

I just found the Windows 7 site looking for answers to the same problem as wahoobob... I have 2 T-43's (one issued by the company I work for) & both of them have the same sound problem. - After messing around with it for 2 days, I realized that the "Mute" button on the keyboard doesn't show the green progress bar, so you don't know whether it's on or not.

I just held down the Volume increase button for about 20 seconds & the volume worked (even though it didn't show the progress bar).
My System SpecsSystem Spec
02 Dec 2009   #8
wahoobob

windows7 Professional
 
 

Quote   Quote: Originally Posted by zx81 View Post
Quote   Quote: Originally Posted by wahoobob View Post
I have a Thinkpad T42p that I have put Windows 7 on and most everything is working except for sound. I shows it has the Analog Devices AD1981A AC'97 SoundMAX Codec (Full-duplex) AC97 2.2 compatible as shown in the specs and when I ask W7 to upgrade the driver it says I have the latest driver and that the device is working, but no sound. I have removed and reinstalled the device, still no sound. It isn't muted, or anything simple like that. Also, the sound controls at the top of the keyboard don't seem to have any effect. Any ideas of what to do? Other than sound, W7 runs great on this machine. Aero, etc is enabled and it boots and closes quicker than XP... Thanks for any help.
Hello wahoobob,

Maybe this will help you.



Start -> Device Manager
Select Sound, video and game controllers
Select Sound device, right click, uninstall
Scan for hardware changes
Reinstall driver

Have a nice day!

zx81
Well, I screwed my install trying to delete the old XP partition so I had to reinstall and the sound isn't working again... This time when I to to the Device Manager there is no listing of Sound Device so nothing works, but a trip to Lenovo and download the update tool and everything works again. If you have a Thinkpad go to Lenovo's site and get the updating tools. Even the older Thinkpads are supported. Way to go Lenovo!
My System SpecsSystem Spec
03 Dec 2009   #9
wahoobob

windows7 Professional
 
 
Thanks

Thanks to all who helped me in this transition to 7 from Linux. Microsoft got it right this time.
My System SpecsSystem Spec
20 Dec 2009   #10
Pablo24k

Microsoft Windows 7 Ultimate Build 7232
 
 

hey wahoobob can u post the link for that update tool... this t42 is killin me....thnx in advance...
My System SpecsSystem Spec
Reply

 sound problems on Thinkpad T42p




Thread Tools





Similar help and support threads
Thread Forum
Sound Problems
I have an IMEDIA D2315 AIO and recently upgraded from the vista o/s that came with the comp to windows 7 ultimate. I now have no sound coming from the built in speakers in my monitor (Viseo 191ws). Packard bell download site is complete double dutch, i cant understand it at all. Plus i dont see...
Sound & Audio
5.1 sound problems.
Hi guys Well, I have motherboard Asus P5Q3 deluxe with AP with soundMAX HD. Driver is up to date (from asus website). Aslo, I have 5.1 sound system. When Im doing the test everything works just fine. All 5 speakers are working. But, when Im starting to listen to the music from my hdd, rear...
Sound & Audio
Sound problems
I'm new on this forum so Hello everyone :D Few days ago i installed my new windows seven professional x64 and i can't solve my sound problem on sistem 5.1 My motherboard is from intel => DP35DP and my sistem is Logitech X-540 i've tried to install all latest drivers from my motherboard and i...
Sound & Audio
Thinkpad T40 problems with Full screen Video
Hi there, I'm running Windows 7 Ultimate on a Thinkpad T40. I've tried two different sets of drivers, the Generic PnP drivers that Windows provides, and also finding a none WDDM driver for my specific chipset. Both times, Full screen video just becomes a mess of vertical lines flashing all over...
Drivers
sound problems with Realtek ALC 882 sound card
I have a HP Media Center PC. the Model number is a1412n I am dual booting xp and windows 7, and in windows 7 I am not getting any sound. When I went to check it out, I realized that the computer was only recognizing the front audio jack. So i plug my speakers into the front jack but it still says...
Sound & Audio
Sound Problems
Hi I just got Windows 7 installed fresh install I never thought I would have sound problems. I have an on board sound also a PCI SoundBlaster Live CT 4670. I removed the PCI SoundBlaster Live due to could not find any drivers for it so. I enabled in my bios the on board sound it is a Realtek...
Sound & Audio

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:11.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App