Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: No Audio via HDMI to TV

05 Nov 2009   #1

Windows 7: Home Premium (32bit)
No Audio via HDMI to TV

Hello all,

Okay, so I have seen this thread posted a few times but after trying out all of the methods posted with no luck I thought it was time for me to ask for some help.

The problem:

Sound is working fine through my laptop speakers but when I connect it to the TV via HDMI cable the sound still comes through the laptop.

I was previously running Windows Vista Home Premium and it worked absolutely fine. As in, the sound came out of the television speakers when I connected the notebook to the TV. I recently upgraded to Windows 7 Home Premium and since then it does not work. I would appreciate if anyone could help me.

Right now the default sound output device is: Speakers/Headphones - SigmaTel High Definition Audio CODEC. The other two listed are Realtek Digital Output (Optical) - Realtek High Definition Audio and Digital Output Device (HDMI) - SigmaTel High Definition Audio CODEC.

When I try either of the other two sound does not work at all. With the Realtek one it seems to recognize the sound but I don't hear it anywhere and with the HDMI one, it doesn't work at all i.e. Fails to play test tone. I have installed all the latest drivers according to manufacturers.

Thanks in advance,


A more comprehensive computer spec:

Sony Vaio VGN-AR71M
  • Platform Technology Intel Centrino
  • System Type Notebook
  • Built-in Devices Stereo speakers, wireless LAN aerial
  • Width 41.6 cm
  • Depth 30 cm
  • Height 3.5 cm
  • Weight 3.8 kg
  • Processor Intel Core 2 Duo T8100 / 2.1 GHz
  • Multi-Core Technology Dual-Core
  • 64-bit Computing Yes
  • Data Bus Speed 800 MHz
  • Features Enhanced SpeedStep technology
  • Chipset Type Mobile Intel PM965 Express
  • Cache Memory
  • Type L2 Cache
  • Installed Size 3 MB
  • RAM
  • Installed Size 4 GB / 4 GB (max)
  • Technology DDR2 SDRAM - 667 MHz
  • Configuration Features 2 x 2 GB
  • Storage Controller
  • Type Serial ATA
  • Serial ATA Interface Serial ATA-150
  • Storage
  • Hard Drive 300 GB - Serial ATA-150 - 4200 rpm
  • Optical Storage
  • Type DVD±RW (±R DL) / DVD-RAM / BD-ROM - integrated
  • Read Speed 24x (CD) / 8x (DVD) / 2x (BD)
  • Write Speed 8x (CD) / 8x (DVD±R) / 2x (DVD-R DL) / 4x (DVD+R DL)
  • CD / DVD Rewrite Speed 8x (CD) / 4x (DVD±RW) / 5x (DVD-RAM)
  • Card Reader
  • Type Card reader
  • Supported Flash Memory Cards SD Memory Card, Memory Stick, Memory Stick PRO, Memory Stick Duo, Memory Stick PRO Duo
  • Display
  • Display Type 17" TFT
  • Max Resolution 1440 x 900 ( WXGA+ )
  • Widescreen Display Yes
  • Features X-black
  • Video
  • Graphics Processor / Vendor NVIDIA GeForce 8400M GT
  • Video Memory 256 MB
  • Audio
  • Audio Output Sound card
  • Compliant Standards Microsoft WSS 1.0/2.0, High Definition Audio
  • Features Sound Reality technology
  • Audio Input Microphone
  • Notebook Camera
  • Camera Type Integrated
  • Sensor Resolution 1.3 Megapixel
  • Capture Resolutions 1280 x 1024
  • Input Device(s)
  • Type Keyboard, touchpad
  • Telecom
  • Modem Fax / modem
  • Max Transfer Rate 56 Kbps
  • Protocols & Specifications ITU V.90, k56Flex, ITU V.92
  • Networking
  • Networking Network adapter
  • Wireless LAN Supported Yes
  • Data Link Protocol Ethernet, Fast Ethernet, Gigabit Ethernet, IEEE 802.11b, IEEE 802.11a, IEEE 802.11g, IEEE 802.11n (draft)
  • Compliant Standards IEEE 802.11b, IEEE 802.11a, IEEE 802.11g, IEEE 802.11n (draft)
  • Expansion / Connectivity
  • Expansion Slots Total (Free) 2 ( 0 ) x memory ¦ 1 ( 1 ) x CardBus - type I/II ¦ 1 ( 1 ) x ExpressCard/54
  • Interfaces 1 x IEEE 1394 (FireWire) - 4 PIN FireWire ¦ 3 x Hi-Speed USB - 4 PIN USB Type A ¦ 1 x headphones - output - mini-phone stereo 3.5 mm ¦ 1 x microphone - input - mini-phone 3.5mm ¦ 1 x audio - SPDIF output ¦ 1 x audio / video - HDMI - 19 pin HDMI Type A ¦ 1 x display / video - S-video output ¦ 1 x display / video - VGA - 15 pin HD D-Sub (HD-15) ¦ 1 x network - Ethernet 10Base-T/100Base-TX/1000Base-T - RJ-45 ¦ 1 x modem - phone line - RJ-11
  • Miscellaneous
  • Features Security lock slot (cable lock sold separately)
  • Power
  • Power Device External
  • Battery
  • Technology Lithium Ion
  • Installed Qty 1
  • Run Time (Up To) 1.5 hour(s)
  • Operating System / Software
  • OS Windows 7 Home Premium
  • Major Software Microsoft Office 2007 Ultimate, Adobe CS4 Master Collection, Command & Conquer Red Alert 3, The Sims 3, Zoom Player and iTunes.

My System SpecsSystem Spec
05 Nov 2009   #2

Windows 7: Home Premium (32bit)

I don't know if this might help as well. Thanks. =)
My System SpecsSystem Spec
06 Nov 2009   #3

Windows 7: Home Premium (32bit)

I tried to update the latest NVIDIA driver using the modified inf but I still had no luck with the sound. Also installed the latest REALTEK drivers. Can anybody help?? It would be greatly appreciated.
My System SpecsSystem Spec

06 Nov 2009   #4

Windows 7 64Bit

Hi Imran5, I presume you did select xxxxxxxxx(HDMI) as the default device whilst the cable was connected?
My System SpecsSystem Spec
06 Nov 2009   #5

Windows 7: Home Premium (32bit)

Yep. Tried all three in fact! To no avail! :-(

Thanks for the reply
My System SpecsSystem Spec
06 Nov 2009   #6

Windows 7 64Bit

My System SpecsSystem Spec
06 Nov 2009   #7

Windows 7: Home Premium (32bit)

I'm on 32bit.. So I'll have a go at that one instead! Thanks =)
My System SpecsSystem Spec
06 Nov 2009   #8

Windows 7 64Bit

Ok...Best of luck...
My System SpecsSystem Spec
06 Nov 2009   #9

Windows 7: Home Premium (32bit)

An epic fail! lol.. I'm close to calling it quits

Thanks for the help though!!
My System SpecsSystem Spec
06 Nov 2009   #10

Windows 7 64Bit

Thats ok....have you the latest Audio drivers installed for windows 7 too?...if not try that...Also in Device Manager is all ok with the devices?
My System SpecsSystem Spec

 No Audio via HDMI to TV

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
Realtek HDMI Output ATI HDMI Audio -Not Plugged In-
I'm trying to hook up my TV with my computer, and for the most part it's working. The video goes through and I get how to control it and everything. The only thing not working is the sound. I'm using an HDMI to HDMI cable, and like I said the video is fine. Also, when the cable is plugged into...
Sound & Audio
No HDMI audio after running Win 7 audio trouble shooter
I have an Acer Aspire Laptop 57362-4790 running Win 7 with all the latest updates. Audio is an Intel(R) High Definition Audio HDMI, and Realteck HDMI. Because I had no headphone output with the computer connected to my TV via the HDMI out I ran the Windows audio trouble shooter. I got a...
Sound & Audio
No Audio, HDMI (unplugged), No Audio device listed
Hi, I just got a new (cascaded) computer with seemingly no standard audio. The audio icon is a speaker with and X through it and the only audio device that populates the Playback Devices list is the HDMI digital audio. I have audio on the motherboard (think I can find it?? nope) and...
Sound & Audio
HDMI audio problem when connecting LCD TV to PC via HDMI
hi all, I have my media center PC connected to a Sansung LCD TV through an HDMI cable. Everything works fine; the PC detects TV and both audio and video travel through the HDMI cable from PC to TV The problem happens when I turn the TV OFF and ON. In this case, the video is back but not the...
Sound & Audio
No audio from rear jack & no hdmi audio
hi guys pretty new here so take it easy plz (lol) i have 2 problems regarding audio. 1. when i upgraded my pc i added a okish motherboard but i wanted sound from my front panel so i took the jumper cap off the prongs for audio but now i have added some desktop speakers and want to plug them...
Graphic Cards
Windows 7 - HDMI out no audio - Intel HDMI audio
Hey everyone, I recently upgraded to Windows 7 (Build 7100) from Vista (32 bit) and am having trouble getting audio from my HDMI out port. I am using the Mobile Intel 965 Express Chipset and have upgraded to the latest available driver but still no luck. I have attached a screen shot of my...
Sound & Audio

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 17:03.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App