Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Sound Blaster X-Fi USB, Entertainment Console Not Working

14 Jan 2015   #1
erics1one

Win 7 64bit
 
 
Sound Blaster X-Fi USB, Entertainment Console Not Working

I'm currently having an installation issue with the Sound Blaster X-Fi External USB, after reinstalling Windows 7 OS. Before I reformatted and reinstalled Win 7, everything was working perfectly.

After I reinstalled Win 7, I downloaded all windows drivers and updates.

After all updates were installed, I used the CD that came with the sound card, and installed all components of the CD.

With everything installed, I opened up the Entertainment Console to test the individual speaker volume levels, but nothing works. The individual speaker volume levels donít work and the master volume level doesn't even work. When I conduct a channel test however, "Front Right, Front Left," will emit from the speakers, but that's about it.

With 5.1 setup selected in the Creative Entertainment Console, only the front two speakers are working.

The Windows Audio settings do seem to be working, but obviously this doesn't let me control the speaker levels, or anything else that the Creative Software has to offer.

I attempted to uninstall all the audio drivers, then download the latest driver from the Creative site, but received the message, "No Creative products have been detected."

Any suggestions?


My System SpecsSystem Spec
.
15 Jan 2015   #2
fireberd

Windows 10 64 bit
 
 

Do you have the integrated audio (On the motherboard audio) disabled, preferably in the BIOS so there are no conflicts?

Also, if you have an Intel CPU based system, reinstall the Intel motherboard chipset drivers.

Please fill in the "My System Specs". Helps us to try and help you.
My System SpecsSystem Spec
16 Jan 2015   #3
erics1one

Win 7 64bit
 
 

I have not disable the integrated audio via the BIOS. I didn't think this would be an issue given that I do not have the onboard audio selected, and no sound is coming from the laptop's speakers. I'm actually getting sound out of my receiver's speakers from the Sound Blaster X-Fi USB.

After reformatting and reinstalling Win 7, part of the updates I installed were the intel chipset drivers, along with any other Windows and ASUS updates.

Should have also mentioned that I'm using a digital optical cable for my audio receiver.

Appreciate you taking the time to help. Thanks.



Here are the specs for the ASUS laptop:
ASUS Republic of Gamers G51JX-A1


Screen Size15.6 inches Screen Resolution1920 x 1080 Max Screen Resolution1920 x 1080 pixels Processor2.8 GHz Intel Core i7 RAM6 GB DDR3 Memory Speed 1066 MHz Hard Drive500 GB Graphics CoprocessorNVIDIA GeForce GTS 360M Chipset BrandNVIDIA Expand
Other Technical Details

Brand NameAsus SeriesG51JX-A1 Item model numberG51JX-A1 Hardware PlatformPC Operating SystemWindows 7 Home Premium Item Weight7.3 pounds Item Dimensions L x W x H14.60 x 10.30 x 1.60 inches Color Blue Processor BrandIntel Processor Count4 Computer Memory TypeDDR3 SDRAM Hard Drive InterfaceSerial ATA Hard Drive Rotational Speed7200 RPM

My System SpecsSystem Spec
.

20 Jan 2015   #4
erics1one

Win 7 64bit
 
 

There is no onboard audio setting in the BIOS.

(These are not actual screenshot, just examples of what setting screens are actually working)

To clarify, the audio settings from here are NOT working:


These settings in the Windows dialog box are working:

My System SpecsSystem Spec
Reply

 Sound Blaster X-Fi USB, Entertainment Console Not Working




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Sound Blaster Audigy Rx Microphone Not Working
Hello!I am using the turtle beaches X12 headset. I have just recently installed the Sound Blaster Audigy Rx to my PCs motherboard. And stoped using Realtek Audio Manager and using the Creative SB drivers. After a week, the microphone stoped working(Sound still works) and said "Currently Unavalable"...
Sound & Audio
Front Panel Mic not working with Sound Blaster Z
Hello everyone, today I got my new Soundcard, a Soundblaster Zx and I must say that I really love the quality. However, I have a problem and I don't know how to fix it. My PC is a custom build. Case is a Bitfenix Ghost, Mainboard Gigabyte 970A-UD3. I installed the Soundcard in my PC and...
Sound & Audio
Old Sound Blaster Live Resurrected & Working in Win7!!! NO REVERB!!!
For anyone who has an old Sound Blaster Live or similar soundcards laying around, I found a developement project for drivers for these older cards and many others that Creative has chosen to drop support of long ago (2003). I was tearing apart an old PIII dinosaur I built in 1999, and decided...
Sound & Audio
Garbled sound NF4/Sound Blaster XFi Gamer with over 4GB memory
This seems to be a problem that Creative has not been able to fix with new drivers. The work around is to limit the computer to below 4GB of memory. Has anyone come up with drivers that work so I can use all my memory?
Drivers
Creative Sound Blaster Audigy 24bit Sound Card
I installed windows 7 a little while ago but i cant seem to get a driver that will recognize my sound card. the computer doesnt think its installed correctly but when i was using Xp it was just fine. ive tried another PCI slot but no such luck. all of the drivers i have tried tell me that they dont...
Drivers
Creative Sound Blaster Audigy LS Not Working
Hello, I've installed Windows 7 on my desktop with dual boot to Vista. Everything's been working fine but I haven't been able to properly setup my sound-card to function properly. As of now, I currently have no sound and I've been through many different drivers from the Creative website. I've...
Sound & Audio


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 01:34.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App