Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Realtek HD Audio - No Sound through speakers \ headphones

21 Jan 2015   #11
Daphne

Windows 7, 64 bit
 
 

such weird thing happened on my computer too, after I installed the virtual sound card to my computer, I can not hear the audio through headset.


My System SpecsSystem Spec
.
23 Jan 2015   #12
alaud

Windows 7 64bit Home
 
 

Ive just tried a 2 ($3) ebay usb sound card and working fine. Not sure what could be causing the onboard sound to fail. The usb soundcard sounds fine with headphones, if its ok with speakers i might have to leave it like this.
My System SpecsSystem Spec
10 Feb 2015   #13
Thonk98

Windows 7 64bit
 
 
Audio Issues

I recently installed a second video card with HDMI output. So I have one PCIe video card and one PCI video card. Each running two monitors. I found that after installing the drivers for the second video card my onboard Realtek audio was removed from the playback options. Only listing the HDMI audio. I'm using the VGA and DVI connectors (no HDMI) on my vid cards so the PC had no sound. Volume in system tray had the red circle with a line through it. No sound period. After removing the second vid card and rebooting the Realtek option was there to select under Sound/Playback. Re-installing the video card would produce the same no sound issue. After reading and re-reading some posts I found online I went into the BIOS and found that Realtek Audio was set to 'Auto', continuing with boot but no Realtek to select in Sound/Playback. Only HDMI audio. I finally went back into the BIOS and set the Realtek to "Enabled' continued with boot and Realtek was then available to select under Sound/Playback. Problem solved, still have my 4 monitors and my onboard sound.

Different than the problem the OP is reporting but I thought this might help someone struggling with Realtek issues.

Thonk
My System SpecsSystem Spec
.

11 Aug 2015   #14
naxcissique

Windows 7 Ultimate x64
 
 

What resolved the headphone/audio not working problem for me:
  1. Open Realtek Audio Manager - Options
  2. On the Connector Settings, switch to AC97 front panel.
  3. Test music - in my case, I was already using Spotify and it worked immediately.

This enabled Speaker to be the default audio device instead of the Realtek one. If there's no AC97 option, just switch it to a different option than what you're currently using.
My System SpecsSystem Spec
13 Aug 2015   #15
SpatchTadley

Windows 10 64 bit
 
 

I had this issue and this is how I resolved it...

  • Open Realtek HD Audio Manager from the Start menu
  • Click Device advanced settings (top right)
  • Change the radio button 'Mute the rear output device, when a front headphone plugged in' to 'Make front and rear output devices playback two different audio streams simultaneously
Thanks to naxcissique for pointing me in the right direction
My System SpecsSystem Spec
01 Apr 2016   #16
jarfer

Windows 7 SP1 (x64)
 
 

Hi All,

I'm experiencing the same thing! I posted here a couple of hours ago quite frustrated why Realtek would make something so unusable.

I had already had to negotiate a few new hoops because Windows 7 had detected the HDMI and had set this as it's default output device (check this by right clicking your speaker and clicking 'output devices') before following the next steps to get sound from the jacks:

Then I had to do both two steps as others have posted above:
  • I made sure I had turned on "AC97 Front Panel" option (without this the jacks will never get used at all)
  • I then had to unticked "Mute the rear output device when.." (option - and tick the other about making "two independent streams for the audio - otherwise in theory it would use the jack, except the HDMI is always present and will be the only thing that gets any sound.

This still didn't give me and I actually gave up and began playing, assuming it was something dodgy with the card, the driver, whatever. Anyway, unlike all my other machines since the 90's I'd actually bought this one from a shop as a complete machine- and they'd taken the trouble to wire up the audio jack from the motherboard to the front jack (not something I've ever done - nor understood why people seem to want to do this since all the computers cables are at the back (including my amp and big speakers are behind the computer which was what I actually wanted to use!).

Anyway, it turns out if you do this all the jacks at the back are disabled all of the time and will never give you any output at all, so I can use the front jack, but I fail to see how this is a helpful feature.

Why does it not just all work? I think someone needs to look at the usability and how feasible it actually is for the end user to actually get any sound at all.

My first sound card was a Soundblaster 16 sometime in the early 90s - I have never before or since experienced anything so perplexing and unnecessarily awkward. Well done, Realtek
My System SpecsSystem Spec
Reply

 Realtek HD Audio - No Sound through speakers \ headphones




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Realtek AC'97 Audio - Cant hear any sound from headphones or speakers.
I just bought a pc, windows 7 32bit. I tried to use my headphones but couldnt hear any sound, also tried speakers still no sounds. The green bar goes up on the volume control tho. I have tried downloading some drivers, but they didnt work. Im a novice when it comes to things like this, can...
Sound & Audio
Realtek HD audio recognizes my headphones as speakers
Hello When I plug in my headphones to the back of my computer where my onboard soundcard is located, it seems that realtek detects my headphones as speakers, and as a consequence, the volume is way too low. When connected to the front of my computer however, realtek detects my headphones...
Sound & Audio
Realtek HD Audio Problem: Headphones appear as "Speakers"
Dear all, my speakers do work. When i plug in my headphone at front the speakers get replaced, means I head everything through the headphone. Headphones themselves aint shown under "Sound": It appears that both, speakers and headphones are used as one source for audio-out. However, I...
Sound & Audio
realtek audio not detecting speakers or headphones.
I have an Asus M4A89TD pro / usb3 that has Realtek audio onboard. I have just finished my build and have never been able to get any sound from any of my IO ports. None of the ports recognize anything that I plug in (i only have 2 sets of 2.1 speakers, one uses a single light green jack and the...
Sound & Audio
Audio Service Not Running/No sound/No speakers/Realtek problem
I'm hoping someone can help me.I'm working on a custom pc that my brother built for me. The specs are in my signature. I recently upgraded from 32 bit to 64 bit Windows 7 home premium (I know it's not the best, but it's what I could afford). I did a drive reformat also. Initially, everything...
Sound & Audio
Audio devices undetected. Headphones or Speakers give no sound
Hi, I recently went into my computer to install a Corsair H80 Water pump for the GPU. Anyhow, after i connected all the cables and turned on the computer again i did not have any sound. Even though im not an expert with computers, i'm pretty sure all the cables are connected right (but there is...
Sound & Audio


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 00:57.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App