Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: No sound on HP n6101n Desktop

09 Apr 2015   #1
oceanboy

Windows 7 Home Premium
 
 
No sound on HP n6101n Desktop

Hello

I just installed windows 7 Pro 64 bit on an HP Pavilion a6010N. Even though the driver looks good in device manager, the settings show a red x over the speaker icon. When I open the sound control it states that a speaker is not plugged in. I use this speaker all the time but also tried another one just to make sure. Still no sound

The Sound card is a Realtek ATI HD

I've been at this for 2 days, so now in search of some help!

Thank you in advance for any ideas!!!


My System SpecsSystem Spec
.
09 Apr 2015   #2
fireberd

Windows 10 64 bit
 
 

The sound card is most likely Realtek. ATI HD would be HDMI audio.


what is shown in the Device Manager for the Realtek? Does it show as "working OK" or does it have an error code? What other devices are listed in the Device Manager, Sounds section?

HP shows this as a 2007 machine thus it was originally a Windows XP machine. If it has Realtek its not the current version of Realtek. When you first installed and before you installed Realtek drivers, if the sound is Win 7 compatible Windows would have installed the generic, basic function, High Definition Audio Drivers (Codec). Did Windows install this?
My System SpecsSystem Spec
09 Apr 2015   #3
oceanboy

Windows 7 Home Premium
 
 

Hi

Thank you for relying!!!!

I don't much about sound cards but it does say HD when I used SIW to see what the hardware was called

Device manager lists it as... ATI High Definition Audio Device

Yes, Win 7 did install a driver but the speaker icon still had a red X over the top. When I tried to let windows fix it, it did acknowledge there was a problem but didn't repair it or offer any viable options. This is when I went in a mission to find a different driver. In the past...Windows will partially instal a driver or instal the wrong driver. Sometimes the speaker icon looks good as well as the device manager but NO SOUND. After installing the listed driver from the manufactures site...everything works. I thought this may be a case like that so I installed what I thought was the proper driver from the ATI Realtek site.

BTW...this was a windows Vista machine from the factory, thus the treason I'm a but miffed why the driver isn't working

Any thoughts?
My System SpecsSystem Spec
.

09 Apr 2015   #4
oceanboy

Windows 7 Home Premium
 
 

WHOOPS> Also says this device is working properly
My System SpecsSystem Spec
09 Apr 2015   #5
fireberd

Windows 10 64 bit
 
 

ATI High Definition is NOT the PC sound device. That is ONLY for HDMI audio.

If this is an Intel machine, install the Intel motherboard chipset drivers and see if that has any affect.

After the chipset driver install, and PC reboot, if it still does not work, uninstall the RealTek in the Device Manager and also uninstall the drivers. Restart the PC and Windows should install the generic HD Audio Driver.

If the HD Audio Driver installs and works OK, if you have the original Vista driver from HP install that. The Vista sound driver is Win 7 compatible. But, if its a Win XP driver it is NOT compatible.
My System SpecsSystem Spec
09 Apr 2015   #6
oceanboy

Windows 7 Home Premium
 
 

Hi

Well, that didn't work so I decided to pull the external video card out and see if I could load the graphics driver that way. BINGO! Sound now works. However, as soon as I place the external video card back in...no sound. This card does have an HDMI port. Do you think this could have something to do with it.

It's a ....
MSI R6570-MD1G/LP
My System SpecsSystem Spec
10 Apr 2015   #7
fireberd

Windows 10 64 bit
 
 

Since the sound apparently works OK with the Video card removed (and whatever you are using as Video) I wonder if this current technology video card is 100% compatible with the old hardware PC. Or if there is some type of hardware problem with the card.
My System SpecsSystem Spec
10 Apr 2015   #8
oceanboy

Windows 7 Home Premium
 
 

Hi

The card did work when I got the machine and it had Vista on it. So, I went into the bios and forced the sound to only choose the on-board audio instead of "auto" mode. BINGO!

Thanks for all your help!!!
My System SpecsSystem Spec
10 Apr 2015   #9
fireberd

Windows 10 64 bit
 
 

Strange, but glad to hear its sorted out. Please mark this solved.
My System SpecsSystem Spec
Reply

 No sound on HP n6101n Desktop




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
No sound on my desktop
I have a desktop running Win 7 home premium, 64 bit. Recently my sound stopped working. I have a pair of external speakers that are turned on with the volume turned up. I haven't made any changes to the settings. I checked the speaker icon in the task bar and it shows the volume turned to max and...
Sound & Audio
Sound will play from headphones but not speakers. (Desktop)
I was having some issues with my harddrive having a memory leak and it was running out of space. I tried to install a Nvidia driver and everything got screwed up on my computer. I use a sli system with two video cards. I didn't realize at first it was my harddrive, so I switched the cards ports and...
Sound & Audio
No sound on Remote Desktop for Win XPe client with Win 7 host
I have a desktop computer running Win7 and a thin client (Wyse V90L) running Win XP Embedded. I am using Remote Desktop to log into my desktop computer running Win7. The problem is that despite having set up Remote Desktop on the client to 'Play on this Computer', no audio plays. When I click on...
Network & Sharing
Sound problems from Desktop
Okay, this happerned when we first got this thing back in 1/1/10, but after a quick restart, it didn't happen again until it occured once more 2-3 weeks later. It wasn't really a problem (unless you were in the middle of something), but recently, I had to restart twice in the same day (though, the...
Sound & Audio
Sound scheme changed by Desktop Themes
It appears that, every time you change a desktop theme, the sound scheme is changed and any custom sounds selected previously are lost. I use Microsoft Money which installs with about 20 different unique sounds. Installing a new desktop theme wipes out all the Microsoft Money sounds as well and...
Themes and Styles
No Sound on TV but on Desktop
Hello everyone! I installed Windows 7 - 64 bit on my second PC. Everything seems fine up until the point when I wanted to watch something on my TV (Philips , which worked fine yesterday with XP). I don't have any sound on the TV but I do have sound on the PC. I use a Audigy 2 ZS and a chinc...
Sound & Audio


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 15:12.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App