Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Lost 5.1 Sound. Laptop. Win 7 Ult x64. Logitech Z506 Speakers.

06 Jul 2015   #1
sferg410

Windows 7 Ultimate x64
 
 
Lost 5.1 Sound. Laptop. Win 7 Ult x64. Logitech Z506 Speakers.

Hi,I can't work out why my 5.1 system no longer works.
I was running Win 8.1 and my surround sound worked fine, but since I have started studying for the Windows 7 Microsoft exam I thought I should go back to Win 7.
So installed Win 7 Ultimate x64, everything is up to date and everything is working fine except now the surround sound does not work.
When i go into Control Panel and then Sound, select 5.1 and test each speaker, the center, sub, left and right rear speaker sound just comes out of either the front left or right speaker. Nothing I do seems to fix it.

I have removed all sound drivers and let them re-install one by one but the result is always the same.
On Win 8.1 the system had the Realtek High Definition Driver, so installed that and still does not work.

The laptop is a HP Elitebook 8540w and have tried the driver from HP download site which is an IDT High Def driver but the result is still the same.

My speakers 3 outputs connect to a little external sound card, which in turn connects to the laptop via USB. I know this system works as it had been working fine for many months on Win 8.1.

You can see the external sound card/box here...

USB External 6 Channel 5.1 S/PDIF Optical Sound Card Audio For PC Laptop Netbook | eBay

I am at the end of my patience as to why this does not work as it should when it did without any problems on Win 8/8.1. Does anyone have any idea???????

Really need your help.
Thanks.

Nearly forgot - a driver called 'USB multi-channel audio device' by C-Media Inc also installs itself. I assume this is the drive for the sound card/box.

Have now found out that the box is a 'CM6206LX' - doesn't seem to be any Windows 7 software and saw one bit saying it might only support x32. Why would it only support Win 7 x32 when it supports Win 8 x32 and x64??


My System SpecsSystem Spec
.
06 Jul 2015   #2
fireberd

Windows 10 64 bit
 
 

If you are using the external sound "box" that has to be set as the Default playback device. The PC sound, whether its Realtek, IDT or whatever is not used.

First step, set the USB sound "box" as the default Audio Playback Device.
My System SpecsSystem Spec
06 Jul 2015   #3
sferg410

Windows 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by fireberd View Post
If you are using the external sound "box" that has to be set as the Default playback device. The PC sound, whether its Realtek, IDT or whatever is not used.

First step, set the USB sound "box" as the default Audio Playback Device.

Thanks for reply but it makes no difference to the sound only coming out of the front left and right speakers only when tested if the box is selected as default or the speakers.
My System SpecsSystem Spec
.

06 Jul 2015   #4
fireberd

Windows 10 64 bit
 
 

Do a "reset" on the USB sound box. Go to the Device Manager, RIGHT click on the entry for the sound box (or C-Media?) to highlight it and then LEFT click "Uninstall". DO NOT uninstall any drivers. Disconnect the USB sound box from the PC and restart the PC. After Windows has started connect the USB box and Windows should detect and reinstall it.

If there were any Corruptions between Windows and the device this will fix that.
My System SpecsSystem Spec
06 Jul 2015   #5
sferg410

Windows 7 Ultimate x64
 
 

Somehow I have managed to fix this problem now using USB Multi-channel audio device (32bit) software, so no further help is needed. Thanks
My System SpecsSystem Spec
Reply

 Lost 5.1 Sound. Laptop. Win 7 Ult x64. Logitech Z506 Speakers.




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Logitech z506 with Xbox one Setup help
Hello everyone i have this idea i just wanted to make sure this works basically i want to have the Xbox one with an Optical cable going into a receiver and have the RCA from the other end of the receiver going into the Sub-woofer and then of course have an HDMI for Audio i should also note i want...
Gaming
Logitech z506 speakers into an AOC i2757fh monitor
Hello everyone. First post on here. So I got an AOC i2757fh monitor with 2 hdmi ports. So I have my computer on one and my xbox one on the other. Then I got a pair of Logitech z506 speakers since the speakers on the monitor aren't that good. So I have the green audio cable plugged in the back...
Sound & Audio
No Sound from Laptop Speakers
I have Dell inspiron N4010 in which i facing problem regarding Sound. No sound coming from my laptop's internal speakers but during Hardware testing ( Dell diagnostics enable pressing F12 during booting) test sounds comming from speakers correctly. Sound also properly in Headphone, No any problem...
Sound & Audio
Logitech Z205 laptop speakers
Hi everyone, was hoping for some help with my Logitech Z205 laptop speakers that have suddenly stopped working - these work directly from any USB port and normally just enhance the sound from the thin sounding laptop speakers. Recently just plugging them in produced no sound just a slight...
Sound & Audio
no sound through tv via hdmi, sound plays through laptop speakers (idt
Yesterday I installed a new external hard drive - following the installation - my sound no longer played through my television (video is fine, HDMI connection) and sound now comes ONLY through the laptop speakers. The option for HDMI Audio doesn't appear in the 'sound' menus. I have 'checked'...
Sound & Audio
Diamond XS51 + Logitech Z506 not working properly
I have Windows 7 Professional x64, a Diamond Multimedia XS51 5.1 Soundcard and a Logitech Z506 speaker set up (used set up from liquidator). For some reason, I am having trouble installing sound card drivers and I'm not getting sound to the center and rear speakers. Also, the speaker doesn't...
Sound & Audio


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 22:13.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App