Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Computer detects my headset but sound doesn't play through it?!

18 Jul 2015   #1
JollyJed

windows 7
 
 
Computer detects my headset but sound doesn't play through it?!

Hey guys,

I recently had a BSOD problem which was resolved by removing my GPU's device driver and removing the GPU itself to give it a clean and refit it. Since then i don't get sound through my headset/speakers and i have no idea why! my realtek audio recognizes when the jacks are being used and even gives me a message in the bottom right. When i go on playback devices it shows that sound is being played through the device (green bar goes up and down) but i literally hear nothing! I honestly have no idea whats wrong as it seems the jacks are fine considering my computer knows when they are being used, i also have realtek audio still working and it also recognizes when something is plugged in :/

BSOD thread for some background - BSOD playing CS:GO, error 0x00000116

Any ideas what could be happening and what i could do to fix it guys? much appreciated!


My System SpecsSystem Spec
.
18 Jul 2015   #2
fireberd

Windows 10 64 bit
 
 

Do a "refresh" of the Realtek audio. Go to the Device Manager, RIGHT click on the Realtek audio entry and then LEFT click "Uninstall". DO NOT uninstall the drivers. Restart the PC and when Windows starts it will detect and reinstall the sound. Any Windows/Sound corruptions will be fixed.
My System SpecsSystem Spec
18 Jul 2015   #3
JollyJed

windows 7
 
 

I did it and nothing has changed unfortunately :/ any other ideas mate?
My System SpecsSystem Spec
.

18 Jul 2015   #4
fireberd

Windows 10 64 bit
 
 

Does the PC's speakers work OK? or are they not working like the headset?

If the speakers work OK, plug the headset into the GREEN speaker jack on the rear and see if you hear audio through the headset. That will determine if the headset is OK or if something has happened to it.
My System SpecsSystem Spec
18 Jul 2015   #5
JollyJed

windows 7
 
 

I built the pc myself and it doesn't have its own speakers, i have tried two headsets in it but nothing, the computer is telling me that someone has connected to the jack so it must know a headset is connected :/
My System SpecsSystem Spec
18 Jul 2015   #6
JollyJed

windows 7
 
 

i have a feeling a might of broken something when cleaning the GPU, is there anyway to sort the sound if this is the came?
My System SpecsSystem Spec
18 Jul 2015   #7
fireberd

Windows 10 64 bit
 
 

If you plug the headset into the rear GREEN speaker jack does it work OK?
My System SpecsSystem Spec
18 Jul 2015   #8
JollyJed

windows 7
 
 

Before i plugged the headset in the green jack - Gyazo - c07bb32e13d28554c30584398c4b32a8.png

After - Gyazo - 95b698bee9eb261fbcd4f173be18d3bf.png

So its accepting that something is plugged in but still wont put sound through the headset mate
My System SpecsSystem Spec
18 Jul 2015   #9
fireberd

Windows 10 64 bit
 
 

Are you sure its not the headset? Can you try it on some other device or a friends PC?
My System SpecsSystem Spec
18 Jul 2015   #10
JollyJed

windows 7
 
 

Its definitely not mate, another headset and a pair of speakers both have the same problem - all of them work perfectly fine on my laptop :/

This all occured after i had uninstalled my graphics card, turned my PC off and took the GPU out to check there was no dust build up etc, i then reconnected it - turned the pc back on and reinstalled the GPU. The sound worked fine before i did all of this
My System SpecsSystem Spec
Reply

 Computer detects my headset but sound doesn't play through it?!




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Windows 7 doesn't play Startup Sound?
I'm running Windows 7 Home Premium and it doesn't play Windows Startup Sound even though the option to play startup sound in Control Panel > Sounds is already checked. When my laptop boots up, it takes a couple of seconds flashing "Please wait..." before the logon screen appears. How do I fix this?...
General Discussion
Turtle Beach Z60 Headset Refuses to Play Surround Sound
Currently I have just gotten the Turtle Beach Z60 Surround Sound Headset for Christmas. I have plugged the USB into the front of the PC Tower and have configured it correctly. However, when it told me to configure the headset's speakers for surround sound, it wouldn't play any of the test sounds....
Sound & Audio
Headset speakers play whatever sound the microphone picks up
I got a new headset yesterday, and it works great for the most part. However, when NVIDIA ShadowPlay is running, when I'm in a Skype call, or when I'm connected to a TeamSpeak 3 server, whatever my microphone picks up (i.e. my voice) is played through the headset's speakers. It's really annoying...
Sound & Audio
Play sound through speakers while talking on headset mic
Hi there! its been a while So i purchased a microsoft lx-3000 usb headset with a mic and its great! however there is 1 problem. I want to play sound through my 5.1 speakers while using the mic on the headset HOWEVER When i plug the headset in the sound automatically switches to the...
Sound & Audio
Headset Fatal1ty doesn't record sound
Hello everyone, I'm having a bit of a problem. I can hear myself speak in to the mic, so the mic 'reads' my words and my speakers play them back at me. But for some odd reason I can't get it to record my words with any kind of program. Please, I need help!
Sound & Audio
Windows detects surround sound, but music doesn't use
Windows detected my surround sound system just fine and I hear a noise from each speaker when I click the test button, but in WMP or another player it only plays from the two front speakers. I thought this was solved but apparently it's not. Any idea how I can fix it? It's onboard surround...
Sound & Audio


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:15.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App