Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: "No audio device is installed" need expert help

25 Sep 2015   #1
NeSsQQuiCk

 
 
"No audio device is installed" need expert help

I've had problems with backgroundcontainer.dll and resolved them by following these steps:

To resolve this, download AutoRuns and save it to your Desktop.
Create a new folder on your hard drive called AutoRuns (C:\AutoRuns) and extract (unzip) the file there.
Open the folder and double-click on autoruns.exe to launch it.
Vista/Windows 7/8 users right-click and select Run As Administrator.
Please be patient as it scans and populates the entries.
When finished scanning, it will say Ready at the at the bottom and list all entries under the Everythingtab.
In the top menu, click File > Find... and type the file name (backgroundcontainer.dll) related to the error message, then click Find Next.
Alternatively, you can scroll through the list and look for any entry related to backgroundcontainer.dll and conduit.
If found, right-click on the entry and choose delete.
Exit Autoruns and reboot your computer when done.

After I finished and rebooted pc, my audio wasn't working. I tried to reinstall drivers and it didn't work. Is there any way to revert changes I did in AutoRuns.exe? please help me...
I tried to restore too but it says there is no restore point made, stupid move by me...

If you need more info about my pc I wrote everything I know on my profile, if you need something aditional please tell me in comments + where to get that info

Screenshot by Lightshot screenshot of Device Manager


My System SpecsSystem Spec
.
25 Sep 2015   #2
fireberd

Windows 10 64 bit
 
 

I would start by running SFC /Scannow and see if there are any missing or corrupted system files.

You listed the PC as Dell, but not the specific model. Such as OptiPlex 764, Insprion 530, Dimenson 5150, etc.
My System SpecsSystem Spec
25 Sep 2015   #3
NeSsQQuiCk

 
 

How to do scf?
Where can I check the model? This pc is few years old so I can't remember details
My System SpecsSystem Spec
.

25 Sep 2015   #4
fireberd

Windows 10 64 bit
 
 

Click Start then Run. Enter sfc /scannow (space between c and /).

See this screen shot. Its from Windows 10, but Win 7 will be similar.


Attached Images
"No audio device is installed" need expert help-capture.png 
My System SpecsSystem Spec
25 Sep 2015   #5
NeSsQQuiCk

 
 

Alright I scanned and got text file on my desktop, sorry for being "stupid" but I really appriciate the help
My System SpecsSystem Spec
27 Sep 2015   #6
NeSsQQuiCk

 
 

Help please...
My System SpecsSystem Spec
Reply

 "No audio device is installed" need expert help




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
How do I resolve "no audio device installed" issue in Windows 7
ok...this is super super weird. I upgraded a 2005 compaq presario from XP to Win 7. Everything is fine except sound. I receive the no audio device installed message. I've done all the fixes in windows...uninstalling drivers, updating drivers EVERYTHING. Nothing works. I've even reinstalled the...
Sound & Audio
Sony VAIO laptop "No Audio Output Device Installed"
Warning, I am NOT a computer person at all, but have spoken to some and tried several repairs. I have a Sony VAIO VPCEA24FM laptop, running windows 7 64-bit and the sound has randomly stopped working (made no changes to anything that I know of). There is a red circle with an x in it on the volume...
Sound & Audio
Sound error "no audio output device is installed"
Recently when I was trying to enable my sound card so I could make YouTube videos, I managed to somehow break my sound. I have a windows 7 64bit computer that runs realtek hd audio and nvidia hd audio. I have tried reinstalling windows and that does not work, as it comes up with an error message...
Sound & Audio
Red X on Volume Icon, "No Audio Output Device is installed."
Hey, guys. I've been having that problem for a while now, but I could always just system restore back to a previous state and my sound comes back. But now, it seems that when I tried to do a system restore, one wasn't available. I've done everything that I've searched on, like...
Sound & Audio
Sony VGN-FZ21Z "no audio output device installed"
Hello All, I am sorry if this has been addressed but I have been looking everywhere and have tried so many things to resolve this issue to no avail. My Sony laptop VGN-FZ21Z VISTA home premium 32 bit has a little red x next to the audio on the bottom right toolbar. No Audio output device is...
Drivers
Audio stops working, "No Audio Output Device Installed"
I'm running a Dell XPS 420, which came with Windows Vista. I decided this morning that I was going to give Windows 7 a try, backed up some media on another PC, and did a completely fresh install. Everything worked perfectly, I didn't even have to install any drivers. My native resolution was...
Sound & Audio


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 13:51.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App