Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Sound Blaster Audigy 2 isn't nearly as loud in Win 7

16 Nov 2009   #11

Windows 7 Ult, Windows 8.1 Pro,

Glad you have it up and running icebeam.

The so called Vista drivers I downloaded with that torrent have worked perfectly for me on two different machines running the Audigy 2zs on Windows 7 Ultimate so I figured those drivers might work for icebeam.

They also work with the other Audigy series cards 1-4's on Vista and Windows 7, but they still have all the bells whistles included. Some of the Audiophiles might appreciate that sort of thing.

I fear they are the same driver but with all the useful feature's taken out.

The Creative version is 60mb compared to mine with 700mb of useful features.

I've been using those drivers successfully for so long with Windows 7 that I never felt the need to look around for others. Not to mention the fact that Creative is the last place I look for support for the very reasons just mentioned. Creative tends to strip out feature's on older drivers and sometime's those features can come in handy.

What's interesting is that the Creative version of this driver does not work properly on either of my Audigy 2zs systems. Only the Daniel K version I linked too seem to work properly and had all the sound control feature's left in.

I'll post the link to the torrent version with all the bells and whistles since it works perfectly for me.

Click where it says torrent if you want a working Windows 7 Creative Audigy driver for Audigy 1-4 with all the bells and whistles.

Also I have found that someone is hosting the SB Audigy Series Support Pack 3.6 (11/09/2009) Creative driver file on a much faster server, working in Windows 7 but without the bells and whistles.> SimpleCDN Mirror

So no need to wait around for Rapid Share's slowness.

My System SpecsSystem Spec
23 Nov 2009   #12

Windows 7
new problem please help

I now have another problem please check this link and help. Sound blaster drivers after restart it's related to this all.
My System SpecsSystem Spec

 Sound Blaster Audigy 2 isn't nearly as loud in Win 7

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
Sound Blaster Audigy 2 Platinum ex does not sound in Win7x64
Hello; I'm trying to make my "Sound Blaster Audigy 2 Platinum ex" works on Windows 7 64 bits, I did install the most new version of the drivers provided by Creative Labs, it seems like it is installed without any problems....the Device Manager shows all drivers are installed correctly...when I...
Sound & Audio
Creative Sound Blaster Audigy 24bit Sound Card
I installed windows 7 a little while ago but i cant seem to get a driver that will recognize my sound card. the computer doesnt think its installed correctly but when i was using Xp it was just fine. ive tried another PCI slot but no such luck. all of the drivers i have tried tell me that they dont...
Sound Blaster audigy 2 Value malfunction
Hi. First of all, i would like to say, that i am from central europe, non-english speaking country so be tolerant to my language mistakes, please. Thanks. I didn't find here, or anywhere else, someone with similar problem, so that im asking you for help. Some time ago my sound card just stop...
Sound & Audio
Sound Blaster Audigy
seems a lot of people are having issues with the sound blaster audigy cards, me included. Im dual bootin windows 7 and XP, on windows XP my sound card works and everything, when i boot in windows 7, dosnt even detect my card. I have the driver i need to get it to work, its just not detecting it to...
Sound & Audio
Sound Blaster Audigy 2 isn't nearly as loud in Win 7
my sound card is the SB audigy 2 zs platinum. Back in XP the drivers usually worked fine and produced the right 'loudness' of sound. in vista i had to try a few different sets of drivers but got it working correct. however in windows 7 the drivers that were automatically installed upon the OS...
Sound & Audio
sound blaster audigy giving errors
Win 7 x64 build 7100 I cleaned the dust from the comp & since then I am getting this error, sound is only working on front 2 speakers. i ensured the card is properly installed, which it is. Last 4 months its been working fine with 4.1 speakers. Now I cant start the EAX control setting. I...
Sound & Audio

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 13:29.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App