Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Mobile headphones not detected when plugged in

02 Jan 2016   #1
Iwitrag

Windows 7 Ultimate x64
 
 
Mobile headphones not detected when plugged in

Hello, I have some problems with my huawei mobile headphones, when used in Win 7 (laptop).

When I plug in them when windows is already booted, I need to rotate jack and plug in and out several times, to let win 7 detect them... its pure random and sometimes they are not detected even after 5 minutes of manipulation.

What is strange, that when they are plugged in BEFORE win 7 starts to boot, they are detected instantly (but must be plugged in BEFORE booting).

I thought its HW problem, but they works well in Linux - only Win 7 has some problems detecting them.
I have tried to uninstall audio driver in order to let windows install it back automatically, no change.


Win 7 ultimate x64 - laptop
Lenovo Z50 (not realtek HD audio)


My System SpecsSystem Spec
.
07 Jan 2016   #2
ICIT2LOL

Desk1 7 Home Prem / Desk2 10 Pro / Main lap Asus ROG 10 Pro 2 laptop Toshiba 7 Pro Asus P2520 7 & 10
 
 

Hello and welcome Iwitrag personally I would do a sfc and then a chkdsk before I did anything else.

SFC /SCANNOW Command - System File Checker
Disk Check - use Option 2 and if needed the /f and /r switches


Now did the headphones come with any form of software?? that may have included a driver for them.
My System SpecsSystem Spec
15 Jan 2016   #3
Iwitrag

Windows 7 Ultimate x64
 
 

I have found out where the problem is, but its weird that its only happening on win 7...

The problem was, that jack was too long. When I plug it only in 2/3 - windows detects them. When plugged deeper, it doesnt work.

Strange
My System SpecsSystem Spec
.

15 Jan 2016   #4
ICIT2LOL

Desk1 7 Home Prem / Desk2 10 Pro / Main lap Asus ROG 10 Pro 2 laptop Toshiba 7 Pro Asus P2520 7 & 10
 
 

Hmm sounds like a manufacturing fault mate. But as long as it is fixed eh?
My System SpecsSystem Spec
16 Jan 2016   #5
Iwitrag

Windows 7 Ultimate x64
 
 

I don't think its manufacturing fault.
It works in Linux.

My friend told me, that 2 thirds of jack is used for headphones, and the last third is microphone.
In order to force windows load it, I need to first put in two thirds - and let windows load headphones, and then put last third and it loads fully.

It works. Well, man learns something new every day
My System SpecsSystem Spec
16 Jan 2016   #6
ICIT2LOL

Desk1 7 Home Prem / Desk2 10 Pro / Main lap Asus ROG 10 Pro 2 laptop Toshiba 7 Pro Asus P2520 7 & 10
 
 

Well Iwitrag I can't say I agree with your friend mate to the best of my knowledge headphones have three connections on the jack plug the two at the tip of the plug and usually the smallest are the right and left channels and the third and usually the largest the ground for both of the channels. Again the sets I have used for head/microphone sets usually have a separate jack for the microphone.

Now you might just have something I have not seen before or it is an unusual design in that it is longer than a normal 3.5mm jack setup or that the internal socket on the machine has unusual lengths on it's contacts


Attached Images
Mobile headphones not detected when plugged in-plug.png 
My System SpecsSystem Spec
Reply

 Mobile headphones not detected when plugged in




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
'No Speakers or headphones are plugged in' but they are!
Hi there, I have read through the forums on this issue that I can see others are also having. I have uninstalled and re-installed drivers, checked that the audio is enabled in the BIOS (Only options are Disabled or Auto) Tried both green jack outputs (front panel and back) and have tested the...
Sound & Audio
no speakers or headphones are plugged in
OMG!!! I just installed windows 7 and I cant hear nothing, I have this problem "no speakers or headphones are plugged in" I tried 1000000 type of drivers, and nothing I wonder what is the problem??? I never had this probleem with my old vista :mad::mad::devil: Help???:huh:
Sound & Audio
No speakers or headphones are plugged in
I have checked all my cables and updated all the drivers, and still get this error "No speakers or ha screen shot with some more details.eadphones are plugged in" I am including a screen shot with some more details.
Sound & Audio
No Speakers or headphones are plugged in
Hi iv had this problem for about a month now every time i want to use my sound it just says 'No Speakers or headphones are plugged in' I have tried everything - system restore - plug my headphones in but it does nothing - uninstalling it/ re installing it - keeping it up to date and i tried...
Sound & Audio
No headphones or speakers plugged in.
Just finished building a new computer and my sound will not work. I have installed and uninstalled drivers several times now.
Drivers
No speakers or headphones are plugged in. PLEASE HELP!
I recently took my computer to get a new graphics card GeForce GT 240 and I came back plugged in everything and my speakers didn't work. It worked before I got my new graphics card, Please help this is extremely annoying, I've tried so many other ways.:cry::cry::cry::cry::cry:
Sound & Audio


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 04:09.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App