Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Realtek AC 97 drivers, no sound

16 Jan 2016   #1
IcyLava

Windows 7 Ultimate x64
 
 
Realtek AC 97 drivers, no sound

Well, I don't think any drivers are compatible with it for some reason. I'll settle for that. Thank you to everyone who tried to help me with this! It's an oooold dino anyway. Now, I have heard about "external audio cards"; would any of that be of help to me? If anybody can comment about that, I'd be willing to add it on there. Thanks again everyone to tried helping me!
---------
I did download some Realtek AC 97 drivers for an ooooold laptop I updated to Windows 7. Looks like the mic works on the laptop, but there is no sound at all from the speaker. In audio settings, Windows tells me, "In line not ready". Windows seems to think those are the right drivers though, I just can't get any sound. I have looked in many places for these drivers, most are defunct...But I did find some. Thing is I still can't get sound. If anyone knows of any sure fire way to get them working again, I'd be grateful. They worked on Windows XP..haven't worked on VISTA or 7. 32 bit operating system. Hp Pavillion ZE4560us. I don't expect too much out of the old laptop, seeing as it only supports modern firefox, but sound working would be nice.
Thanks to anyone who responds. Any information extra that's needed...I can give it.




Attached Thumbnails
Realtek AC 97 drivers, no sound-image.jpg  
My System SpecsSystem Spec
.
16 Jan 2016   #2
AddRAM

Windows 7 Pro x64 Windows 10 Pro x64
 
 

Post a snip of Device Manager.
My System SpecsSystem Spec
16 Jan 2016   #3
IcyLava

Windows 7 Ultimate x64
 
 

Alright. It's booting a little slowly today. I'll show you when I can.
My System SpecsSystem Spec
.

16 Jan 2016   #4
IcyLava

Windows 7 Ultimate x64
 
 

Kk. I've just got to upload these pictures.
My System SpecsSystem Spec
16 Jan 2016   #5
IcyLava

Windows 7 Ultimate x64
 
 

Another image


Attached Thumbnails
Realtek AC 97 drivers, no sound-image.jpg  
My System SpecsSystem Spec
16 Jan 2016   #6
IcyLava

Windows 7 Ultimate x64
 
 

Another


Attached Thumbnails
Realtek AC 97 drivers, no sound-image.jpg  
My System SpecsSystem Spec
20 Jan 2016   #7
erpster4

Windows 7 SP1 Home Premium 64bit [x64]
 
 

Quote   Quote: Originally Posted by IcyLava View Post
Another
those drivers (5.10.0.5890) are SO outdated for Windows 7 that they're really for use under Win2000/XP only.

you need to obtain Windows 7 based Realtek AC97 audio drivers from the Realtek web site [look for "Vista/Win7 (32/64 bits) Driver only (ZIP file)" on the downloads page].
The latest version for Vista/Win7 is 6.0.1.6305 (released 9/7/2009). uninstall the old AC97 audio drivers first, reboot and then install the new audio drivers [and click Continue Anyway or click YES or OK to accept unsigned drivers if necessary].
My System SpecsSystem Spec
22 Jan 2016   #8
IcyLava

Windows 7 Ultimate x64
 
 

Ohh, thank you erpster! ..Yeah, I suppose those must be too old... Those should work better. I'll have to try those tomorrow, and I'll post back.
My System SpecsSystem Spec
23 Jan 2016   #9
IcyLava

Windows 7 Ultimate x64
 
 

The driver installs but it tells me "device unable to start", error 10. It seems like the drivers themselves would work...but something is wrong, I suppose. The sound worked fine before I jumped to vista to 7. Hasn't worked since XP.
My System SpecsSystem Spec
23 Jan 2016   #10
IcyLava

Windows 7 Ultimate x64
 
 

Alright...on a restart, Windows says that "there's a problem with the driver"


Attached Thumbnails
Realtek AC 97 drivers, no sound-image.jpg  
My System SpecsSystem Spec
Reply

 Realtek AC 97 drivers, no sound




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Updated drivers (including Realtek) - now no sound
Hello! As the title says, I updated the drivers (using DriverScanner) and my computer now has no sound. I wanted to play the remastered Grim Fandango, which wouldn't work because it needed Open GL to run, and was told that DriverScanner would solve the problem. It did - partly. The game is...
Sound & Audio
Quadraphonic Sound with Realtek Drivers
I am trying to obtain quadraphonic sound using front and rear speakers attached to my motherboard. The four speakers work fine in the control panel, but I cannot get the rear speakers to work in any audio program. I want to get surround sound with separate audio files coming from each of the...
Sound & Audio
Nvidia sound drivers, realtek drivers, or both?
Hello. I have a MSI NF750-G55 motherboard which came with Nvidia sound drivers. Windows update even provided an update for the nvidia drivers once I connected to the internet. However, I also know that there are Realtek sound drivers. Will my system be more stable if I just install the nvidia...
Drivers
Realtek drivers no sound present
I have tried many solutions and nothing works,i'm using windows 7,Procesor DualCore AMD Athlon 64 X2, 2000 MHz (10 x 200) 3800+, ASRock ALiveSATA2-GLAN (3 PCI, 2 PCI-E x1, 1 PCI-E x16, 4 DDR2 DIMM, Audio, Gigabit LAN),but my VT8237A High Definition Audio Controller doe's not work. In bottom...
Sound & Audio
I installed realtek drivers, but still no sound
i installed windows 7 and after that everything works fine except that there is no sound. the device manager says that the HD audio is working fine. the driver is the updated version. I don't know what to do. both the internal speakers and the headphones are not working. but the symbol for...
Sound & Audio
Realtek Sound Drivers
Hi, I am trying to install Realtek HD Sound drivers; I have been unable to find any drivers that are written for Windows 7. So I have been downloading the Vista ones without success. I have tried loading them in compatibility mode and under windows vista and xp but each time it just says error...
Drivers


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 17:50.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App