Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: No sound z170 sabertooth and realtek

19 Jan 2016   #1
chocky

windows 7 Professional x64
 
 
No sound z170 sabertooth and realtek

I have been going round in circles for 24 hours to fix this issue to no avail so was hoping somone with more knowledge and experience can light the way.
This is a new build and the sound has never worked.

Symptoms:
Red cross next to speaker icon-no audio output device is installed
Control panel-sound-no audio devices are installed
Device manager- Sound- Realtek HD audio- yellow exclamation mark
Realtek HD audio listed in sys tray but no icon present
No sound..

Attempted remedies:
I have installed the chipset and realtek drivers that came with the mobo.
Checked hd audio is enabled in bios.
Enabled/ disabled in bios- no change.
Installed latest chipset and realtek drivers from asus- no change.
Installed from realtek and intel- no change
Uninstalled/reinstall from device manager- no change
Update driver- have the latest driver
Uninstalled all audio drivers-reboot-windows installs realtek driver-no change
Troubleshoot- couldn't identify the problem

In Speccy, Realtek high definition audio is listed under audio.

I don't have much knowledge in repspect of driver certificates but under properties for the realtek in device manager I have this:
Windows cannot verify the digital signature for the drivers required for this device. A recent hardware or software change might have installed a file that is signed incorrectly or damaged, or that might be malicious software from an unknown source. (Code 52)

If I uninstall that driver it gets replaced with the same with the same message.
Hoping this isn't the motherboard but not sure where else to look at this point.

All suggestions greatfully received..


My System SpecsSystem Spec
.
19 Jan 2016   #2
fireberd

Windows 10 64 bit
 
 

What is the error code in the Device Manager for the Realtek?

If you uninstall the Realtek and drivers in the device manager and restart the PC, does Windows install the generic High Definition audio device (drivers) and does it work?
My System SpecsSystem Spec
19 Jan 2016   #3
chocky

windows 7 Professional x64
 
 

Thanks for the reply. Yes I have tried uninstalling the realtek drivers in device manager a few times. When I do, the realtek driver goes and windows replaces with:
High Definition audio Device
Microsoft Trusted Audio Drivers

Both of these have the yellow exclamation mark

properties- device status- Windows cannot verify the digital signature for the drivers required for this device. A recent hardware or software change might have installed a file that is signed incorrectly or damaged, or that might be malicious software from an unknown source. (Code 52)
My System SpecsSystem Spec
.

19 Jan 2016   #4
ThrashZone

Win-7-Pro64bit 7-H-Prem-64bit
 
 

Hi and welcome to SevenForums,
What type of speakers do you have ?

I had a slight issue on a x99 sabertooth turned out not a big deal the default speakers were not chosen correctly.

There was some issues with z170's but it was something different,
Intel Skylake bug causes PCs to freeze during complex workloads
My System SpecsSystem Spec
19 Jan 2016   #5
AddRAM

Windows 7 Pro x64 Windows 10 Pro x64
 
 

Not 1 issue with mine yet.

Everything you need is on that disc.

Plug in a simple set of working headphones and start troubleshooting.

Post your Device Manager shot.


Attached Thumbnails
No sound z170 sabertooth and realtek-capture.jpg   No sound z170 sabertooth and realtek-black-mbas.png  
My System SpecsSystem Spec
19 Jan 2016   #6
ThrashZone

Win-7-Pro64bit 7-H-Prem-64bit
 
 

lol I was about to message you
My System SpecsSystem Spec
19 Jan 2016   #7
chocky

windows 7 Professional x64
 
 

Thanks for the replies. I have reinstalled the Realtek drivers for the fifteenth time and tried with various headphones known to be working. This is the device manager after the latest reinstallation of the driver and the device properties for the Realtek driver..

I have tried both the drivers from the mobo disc and the latest drivers from both Asus and Realtek with the same results.


Attached Thumbnails
No sound z170 sabertooth and realtek-devmgr.png  
Attached Images
No sound z170 sabertooth and realtek-devmgrprop.png 
My System SpecsSystem Spec
19 Jan 2016   #8
ThrashZone

Win-7-Pro64bit 7-H-Prem-64bit
 
 

Where are you connected front panel or rear panel ?
Switch and see what happens.
My System SpecsSystem Spec
19 Jan 2016   #9
chocky

windows 7 Professional x64
 
 

Hi, I'm afraid the back ports are the same as the front- no sound..
My System SpecsSystem Spec
19 Jan 2016   #10
ThrashZone

Win-7-Pro64bit 7-H-Prem-64bit
 
 

Open realtek and make sure you're set for the default speakers
Realtek should open when you connect your speakers or headphones in your case
My System SpecsSystem Spec
Reply

 No sound z170 sabertooth and realtek




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Asus Exhibits Glorious TUF Sabertooth Z170 Symbol 1 Motherboard
Together with its Z170 lineup, Asus unveiled its TUF Sabertooth Z170 Symbol 1 motherboard. Asus's TUF lineup of motherboards are built to be as tough as they can. "TUF" is a play to the word "tough, " but it surely actually stands for "The Quintessential Force, " with the plan behind the boards...
Hardware & Devices
Distortion sound using onboard realtek sound card on windows 7ultimate
Hello,i recently upgrade my system from xp to windows7,i use the same realtek driver and get distortions!I try severall drivers,disable all enhancements/levels on speakers properties with no result(2.1speakers-),i configure them in stereo mode,i reduce the default format to 44100 16bits(cd...
Sound & Audio
No sound, Realtek sound inputs assigned randomly
The realtek audio managers shows that the front two inputs, front mic and headphones, are always plugged in when there is nothing in them at all. When I plug in my speakers to the back green input for sound it inputs both the green one, front speakers out, and the blue input, line in. Now I get...
Sound & Audio
RealTek OnBoard Sound Issue - No Sound
Hello everyone, My audio has seem to quit on me. I updated to the newest drivers for my mobo (biostar A870U3) from their download page and now I get no sound whatsoever from my speakers. I have tried uninstalling all of the sound devices from the device manager and letting windows reinstall...
Sound & Audio
Asus Sabertooth X58 sound driver
Sabertooth X58 motherboard- When I install the latest sound driver for my motherboard from Asus, the sound quality deteriorates, and the recording has a loud fuzzy ghosting sound in the background. Anyone else experience this problem?
Sound & Audio
sound problems with Realtek ALC 882 sound card
I have a HP Media Center PC. the Model number is a1412n I am dual booting xp and windows 7, and in windows 7 I am not getting any sound. When I went to check it out, I realized that the computer was only recognizing the front audio jack. So i plug my speakers into the front jack but it still says...
Sound & Audio


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 15:12.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App