Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Puzzled by Sound(?) Issues

24 Mar 2016   #1
Wuhb

Windows 7 Home 64bit
 
 
Puzzled by Sound(?) Issues

I'll do my best to describe and list off the issues I've encountered.

As of this second my sound is "Working" except for HTML5(youtube, etc.), VLC/Media player, and Windows sounds. My skype and a couple of game applications are working, which is what I have found weird. I've doubled and tripled checked to make sure no app has gained exclusive control settings, etc through windows. This was a random occurrence that just started today.

I switch between my speakers and headset quite a bit -- Usually just toggling between setting whichever one I want to default inside of 'Playback devices' via right clicking the taskbar.

This is when another fun part starts happening -- At random the audio will constantly switch between the two non stop until I unplug or disable one for a few moments. (Inside of windows it will just change back and forth constantly between the two devices)

[I use a creative audigy sb soundcard for my seakers and a logitech g35 headset(USB)]
I have made sure all my drivers are up to date and done all of the 'obvious' troubleshooting I can think of, but am at a loss of where to go from here.


My System SpecsSystem Spec
.
24 Mar 2016   #2
fireberd

Windows 10 64 bit
 
 

My first thought, since the headset is USB, that the headset or the USB port in the PC is flakey and connecting then not connecting.

When you have a USB audio device, such as the Headset, it does not use the PC's sound card, it basically has its own "sound card" built into the device.
My System SpecsSystem Spec
24 Mar 2016   #3
Wuhb

Windows 7 Home 64bit
 
 

Thanks for reply, I'm aware of USB devices not going from the sound card.

I have ruled the USB ports to be a contributing factor but what threw me off was some of the sound problems persisted even when I was using my speakers.

Still searching for a fix hopefully
My System SpecsSystem Spec
.

24 Mar 2016   #4
fireberd

Windows 10 64 bit
 
 

As you are using a separate sound card (the SoundBlaster) if you don't have it disabled, disable the integrated (on the motherboard audio) in the BIOS to avoid any potential conflicts.

Another thing to try, a reseat of the SB card (with the PC powered off, remove the SB card and then reinstall). I've seen several problems related to seating problems with the SB cards.

Another thought, for testing, remove the SB and go back to the Integrated audio and see if it does it with the integrated audio.
My System SpecsSystem Spec
25 Mar 2016   #5
Wuhb

Windows 7 Home 64bit
 
 

New revelation/update that occurred just now: If I open my C:/ Folder to browse it will trigger the constant switching of audio devices. This is really starting to drive me insane.
My System SpecsSystem Spec
25 Mar 2016   #6
fireberd

Windows 10 64 bit
 
 

I would still try both options I presented.
My System SpecsSystem Spec
25 Mar 2016   #7
Wuhb

Windows 7 Home 64bit
 
 

Unfortunately I won't really have a ton of time to use this PC in the next few days, however I did remove the soundcard. So right now its just on-board and the headset. I'll report back in a couple of days but in the meantime still open to suggestions. Edit: It already happened with the sound card disconnected. Did some further tests: I tested a separate USB headset and it happened as well. Tried about every single USB port on the machine (front and rear) and still happened. I've had no other problems with any other USB devices so I still believe it is a windows issue.
My System SpecsSystem Spec
26 Mar 2016   #8
Wuhb

Windows 7 Home 64bit
 
 

Sorry for the double post but after browsing a bit more there have been a lot of of this happening (with usb headsets) - and it isn't limited to the g35 or a specific mobo. I've gone ahead and purged all audio drivers and updates from my system as a final check. If it still occurs I can safely say I'm done with USB headsets for my lifetime and will just dual my soundcard and onboard with my speakers with 3.5mm headset
My System SpecsSystem Spec
26 Mar 2016   #9
fireberd

Windows 10 64 bit
 
 

You can only have one default audio playback device, either the on-board or SoundBlaster but not both. That is a Windows limitation. Having two sound "cards" enabled at the same time can also develop conflicts and neither work correctly. If you are going to use the SoundBlaster, disable the on-board in the BIOS. Most SoundBlasters have the connection for the front panel sound (unless you have some proprietary PC such as a Dell) and you can connect the front panel jacks to that.
My System SpecsSystem Spec
14 Apr 2016   #10
anwaypasible

windows 7 home premium 64bit
 
 

sounds as if malware to me.
you could try doing a scan to repair|replace broken operating system files, but if there's some sort of virus doing it then really those files aren't broken at all & won't be fixed since they aren't the problem.

haven't heard of this issue before & it simply can't be a quality assurance issue because then there'd be more people complaining about it & i would of seen it by now.

plus, if your usb device had a problem with the port being loose - you'd hear windows play a sound every time it plugs in & unplugs.
even if the port was tight & there was a problem with the headset causing a disconnect of the software type, you'd still hear windows play a sound that it was unplugged.
My System SpecsSystem Spec
Reply

 Puzzled by Sound(?) Issues




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Puzzled by the amount of space Win 7 is using on my SSD
Recently installed 7 on my new 240GB SSD. I went in to Computer Management to shrink the partition holding 7. I was amazed to see that the install is taking up 137GB+/-of space leaving me with a paltry 30GB or so out of 240! I did extend the partition a bit to make it the 193GB you see in the...
General Discussion
Recording issues with recorders (fraps hypercam etc) sound issues
Hey guys, ive lately been making lets play and walkthroughs on youtube and im having a couple of problems. With my headset, in the background while recording thats like a static noise and i cant seem to make it go away, ive tried multiple recording programs like fraps and hypercam but its still...
Gaming
Network problem has me puzzled
I'm running Windows 7 Pro on my PC and gf runs Windows 7 home on her laptop. Did not have any problems for the past year until recently. I have an external shared drive (e) attached to the PC. Both of us had users on each others computer and both as administrators. Add 2 regular users on the...
Network & Sharing
Puzzled. Shared or not?
Hi, I recently had to rebuild my main PC. Consequences seem to have arisen. I watch all TV, videos music everything through my TV. It is fed by my laptop using Win 7 64 Media Centre. (Through HDMI) My main PC, with VERY ample storage is in my home office. So my setup is: Main PC used to...
Media Center
Puzzled, puzzled, puzzled
I have a Toshiba Satellite laptop. It ran well for 9-10 months. I had a problem w/ the led/backlit screen and sent it in for repair. Since it has come back it has had it's quirks:devil:. One of which is the built in wifi. Prior to "repair" my wifi was excellent, no doubt during so said "repair" the...
Performance & Maintenance
I am puzzled
I was merrily surfing along going about my business when I suddenly discovered that my Data Partition had disappeared. It was completely gone - no trace of it in Computer or Disk Management. The system had just added it to the freespace that is adjacent to it. I keep that freespace in case I need...
General Discussion


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:32.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App