Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Mbox 2 + Windows 7 Default Sound Device


16 Nov 2009   #1

Windows 7
 
 
Mbox 2 + Windows 7 Default Sound Device

Hey everybody,

So i was just wondering if anybody here could help me with this problem.

I have a Digidesign Mbox 2 which i use as my external sound card for music production, i just upgraded from XP to Windows 7 64 bit and while the external sound card works for Pro-tools and my other audio software i cannot set it up as a default playback device. Does anybody know if i can have this as my default playback device (so it windows media player etc. will play sound through it)?

Thanks

My System SpecsSystem Spec
.

17 Dec 2009   #2

Windows 7
 
 

Hey, I dont have an answer for you but I was wondering if you might be able to help me out. You seem to be the only person I can find on the net that has been able to get the mbox 2 to work with Windows 7..

So... Firstly the lights dont turn on. So I look at device manager and some of the mbox 2 drivers have exclamations on them(!). Would you be able to let me know where to get a driver that works with Windows 7??

It would be a great help!

Thanks
My System SpecsSystem Spec
17 Dec 2009   #3

Windows 7, 64 bit Home SP1, Win 8.1.1 Pro 64 bit
 
 

If it's not showing up in the Control Panel/Hardware and Sound/Sound as a "Playback Device" it probably can't be set. I have a Focusrite Saffire Pro 40 firewire recording interface unit on my Sonar DAW and it works great with Sonar but I can't get it to be recognized or used by anything except Sonar (this is in Win 7 and previously in Vista).
My System SpecsSystem Spec
.


18 Dec 2009   #4

Windows 7
 
 

This was just released today, maybe it will help Pro Tools 8.0.3 ? Downloads & Details

As far as i know there were issues with the mbox and windows 7 if you are using the firewire interface but usb seems to work. You can get all the proper drivers off of the digidesign website.
My System SpecsSystem Spec
17 Apr 2010   #5
MRW

Windows 7
 
 

I found out that if you let windows automaticly look for updates for ur driver, in machine control, you will solve your problems
My System SpecsSystem Spec
04 May 2010   #6

Win 7
 
 
Mbox 2

If you download the Digidesign "Audio Drivers setup (x64)" everything will work perfectly.
My System SpecsSystem Spec
21 Jun 2010   #7

Windows 7 64-Bit
 
 

I have installed the new drivers and still get nothing.

If the mbox is plugged in when I restart then i get a blue screen or a black screen. If I plug it in after then it simply does not work.

Any ideas. i read about disabling DEp and I am going to try that.
My System SpecsSystem Spec
21 Jun 2010   #8

Windows 7 64-Bit
 
 

Quote   Quote: Originally Posted by tnahas View Post
I have installed the new drivers and still get nothing.

If the mbox is plugged in when I restart then i get a blue screen or a black screen. If I plug it in after then it simply does not work.

Any ideas. i read about disabling DEp and I am going to try that.
No blue screen but now the Welcome screen just spins and spins....
My System SpecsSystem Spec
05 Apr 2011   #9

Windows 7 Ultimate x64
 
 
Mbox2 Drivers Win7

Mbox2 "SECOND GENERATION" Drivers....

For Mbox2 Family: Mbox 2 - Mbox 2 Mini - Mbox 2 Pro.

Works great on Windows 7 64bit ------------->Downloads




For Win XP ----------------> http://archive.digidesign.com/download/audiodrivers/xp/
My System SpecsSystem Spec
15 Jun 2013   #10

Windows 7 Ultimate x64
 
 

I had this problem also. This is how I fixed it. I uninstalled all devices, checked "delete driver" in prompt. Restart. Installed the 64 bit beta driver. Restart. Installed latest release of the Mbox drivers over the beta. Restart.
My System SpecsSystem Spec
Reply

 Mbox 2 + Windows 7 Default Sound Device




Thread Tools



Similar help and support threads for2: Mbox 2 + Windows 7 Default Sound Device
Thread Forum
Solved default sound device is disable Sound & Audio
can't change default sound device Sound & Audio
Changing default sound device with a macro? Sound & Audio
How to set default sound playback device Sound & Audio
change default device sound with a bat file? Sound & Audio
Change default sound device? Media Center
Changing default Sound Device Sound & Audio

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:21 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33