Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Sound Card for Win 7 in General, and Audigy 2 in Specific?

27 May 2016   #11
TDKMate

Win 7 Pro 64 SP1
 
 

I figured out the reverb problem. At least partially. First, I noticed the effect would increase as I tuned up the volume, as in duration of the echo, not just the volume. Then I remembered that the only recent change was adding Stereo Mix. So I turn the volume slider down just in Stereo Mix, and the problem went away while playing videos.

But now recording volume in Audacity is very low. I turn up Stereo Mix, and Audacity's recording volume also goes up to where it should be, but the reverb effect is like doubled.

Any work around? I have to be missing something


My System SpecsSystem Spec
.
28 May 2016   #12
fireberd

Windows 10 64 bit
 
 

Turning the volume down in Stereo Mix is just "masking" the problem, not fixing it.

You are going to have to get rid of Nahimic so you can disable any sound enhancements (if that is the problem) in the Realtek HD Audio Manager. Get back to "basics".
My System SpecsSystem Spec
28 May 2016   #13
TDKMate

Win 7 Pro 64 SP1
 
 

I'd love to get rid of Nahimic, but so far I've been unable to. In fact, trying to get rid of it is what started this whole mess anyway. Nahimic itself has not responded to my email. And MSI's own forum has not been able to help.

So I guess I'll try the reinstall Nahimic with Revo, then uninstall with Revo trick and see what happens. Now all I have to do is find my motherboard's driver disk (I think it's out in storage already...) so I can reinstall the same version of Nahimic. I do have the new version of it downloaded from MSI's site for a 'just in case.'
My System SpecsSystem Spec
.

28 May 2016   #14
fireberd

Windows 10 64 bit
 
 

I would install Nahimic, then uninstall both Nahimic and Realtek with Revo Uninstaller (use the "Advanced" search mode to scan the registry and hunt for left over files). Reboot the PC and run CCleaner's Registry scan. Finally do a fresh install of Realtek using the driver direct from Realtek.
My System SpecsSystem Spec
06 Jun 2016   #15
TDKMate

Win 7 Pro 64 SP1
 
 

Quote   Quote: Originally Posted by fireberd View Post
I would install Nahimic, then uninstall both Nahimic and Realtek with Revo Uninstaller (use the "Advanced" search mode to scan the registry and hunt for left over files). Reboot the PC and run CCleaner's Registry scan. Finally do a fresh install of Realtek using the driver direct from Realtek.
Sorry for the delay in replying, things have been crazy around here and I'm just now getting back to this.

My new confusion is which Realtek driver do I install? (Yes, I thought it would be a no-brainer, too)

There's a Win 7 64 version, and a 32/64 bit combo version. Do I need the 32 bit drivers on a 64 bit system?

Also, there's both .exe and .zip versions. The scary part here is that in looking in the .zip version, there are Nahimic components in it!!!!!!!

So I have to assume they are in the .exe version, too.

I spent about two hours this morning alone trying to get rid of Nahimic, so I sure would hate to have the problem pop up again because it's embedded in the Realtek drivers themselves!
My System SpecsSystem Spec
06 Jun 2016   #16
fireberd

Windows 10 64 bit
 
 

I would use the driver directly from Realtek. That should be Realtek only, nothing else.
Download the 64bit High Definition Codecs driver R2.79

Realtek
My System SpecsSystem Spec
09 Jun 2016   #17
TDKMate

Win 7 Pro 64 SP1
 
 

Well... I'm giving up trying to get the Effects tab in the Realtek control panel to work. Yet again I've got many more hours in backing up, un/re-installing different flavors of Realtek driver, along with the new version of Nahimic, and so on.

Nahimic still does not play well with my other utility so it is again uninstalled.

I did figure out a fix for the reverb problem, though. The trick is that when Nahimic is uninstalled, whatever settings were in effect at that time, stay as set.

So I reinstalled it, set Reverb to zero, then to off. I also zeroed out things like Voice enhancement, which made watching YouTube videos a nightmare! (All sounds in the typical vocal range were boosted so the voice was blaring while the background music seemed muted somewhat. Terrible listening!)

Thanks for all the help!!!
My System SpecsSystem Spec
09 Jun 2016   #18
fireberd

Windows 10 64 bit
 
 

Too bad. But after a while we get to the point its not worth going further.
My System SpecsSystem Spec
Reply

 Sound Card for Win 7 in General, and Audigy 2 in Specific?




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Creative Sound Blaster Audigy FX Sound Card, no playback/recording
Hi, I recently purchased the Creative Sound Blaster Audigy FX and am having problems getting it to actually play any audio or record any sound. I've browsed other threads with similar issues on this board and as such have disabled my motherboards onboard audio in my BIOS settings, have...
Sound & Audio
Sound Blaster Audigy 2 Platinum ex does not sound in Win7x64
Hello; I'm trying to make my "Sound Blaster Audigy 2 Platinum ex" works on Windows 7 64 bits, I did install the most new version of the drivers provided by Creative Labs, it seems like it is installed without any problems....the Device Manager shows all drivers are installed correctly...when I...
Sound & Audio
SB Audigy SE 5.1 sound card
ok im running windows 7 32 bit, i have a creative sound blaster audigy SE sound card and 5.1 surround sound speakers. the problems are: -when i try to install the drivers from the cd i get a bluescreen -when i install modded win7 compatible drivers my pc just cuts out -when i install the...
Drivers
Creative Sound Blaster Audigy 24bit Sound Card
I installed windows 7 a little while ago but i cant seem to get a driver that will recognize my sound card. the computer doesnt think its installed correctly but when i was using Xp it was just fine. ive tried another PCI slot but no such luck. all of the drivers i have tried tell me that they dont...
Drivers
No sound with Audigy 2 sound card?
This is probably just a stop gap but I was finally able to get my old Creative Audigy 2 card to work with 5.1 surround by using Audigy 4 drivers for Windows 7. I haven't been able to adjust bass and treble yet but I've been too busy just enjoying the music to get around to looking for ways to make...
Sound & Audio


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 01:37.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App