Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Speakers show as Not Plugged In

08 Oct 2016   #1
hmkmonroe

windows 7 home premium 64 bit
 
 
Speakers show as Not Plugged In

Have tried almost all solutions posted and still no sound from Logitech speakers plugged into Dell HD monitor (RealTek High Definition Audio) . Speakers work when plugged directly into pc jack and have always worked when plugged into monitor. Upgraded to Windows 10 and went back to Wondows 7 recently. Any solution will be appreciated. Have tried making sure all is enabled & not muted, updating driver, defaulting to basic audio driver and still no sound. Thank you.


My System SpecsSystem Spec
.
08 Oct 2016   #2
fireberd

Windows 10 64 bit
 
 

How are you connecting audio to the monitor? Via HDMI? Via a separate audio cable from the PC (Green speaker jack) to the monitor?

Why are you using audio from the monitor rather than direct?
My System SpecsSystem Spec
08 Oct 2016   #3
AddRAM

Windows 7 Pro x64 Windows 10 Pro x64
 
 

I agree, why aren`t you connecting your speakers directly to the PC ? Do you need an extension cable ?

But if Device Manager shows the audio output is ok, and you ran a mini plug audio cable with green ends from the green port on the PC to the audio input on the monitor, you should be getting sound.

Answer Jack`s questions to shed some light.

Also what does the sound icon down on the taskbar show, does it show a white speaker or a white speaker with a red line through it ?


Attached Images
Speakers show as Not Plugged In-capture.jpg 
My System SpecsSystem Spec
.

10 Oct 2016   #4
hmkmonroe

windows 7 home premium 64 bit
 
 

I am connecting the monitor to the pc by HDMI. Speakers are plugged into to speaker jack on monitor -- this is for convenience and has worked for years on this pc and previously on different pc's. Speakers do work if I connect directly to pc and yes, I would need an extension cord. I just do not understand why suddenly the monitor connection setup that has previously worked would stop working and not be fixable. From my searches it seems this is a problem many people have. Any help is appreciated.

Taskbar icon shows white speaker, no red line. When you right click on icon and continue to playback devices, speakers show as not plugged in. Everything is enabled and shows drivers are up to date. Nothing is muted.
My System SpecsSystem Spec
10 Oct 2016   #5
fireberd

Windows 10 64 bit
 
 

That sounds like you have HDMI audio. If that is the case, HDMI should be set as the default audio playback device. The NVIDIA video card is supplying the sound, not your PC's sound card. If it worked and now does not, make sure HDMI audio is enabled. Possibly a new NVIDIA driver update caused the problem?
My System SpecsSystem Spec
10 Oct 2016   #6
AddRAM

Windows 7 Pro x64 Windows 10 Pro x64
 
 

Exactly right Jack Which hdmi port are you using, the motherboards or the video cards ?

hmkmonroe, make sure the correct hdmi port is set as your default audio source.

Last resort, just buy a mini plug extension cable for the speakers.

Dynex 6' Stereo Mini Extension Cable Black DX-AD106 - Best Buy

Staples 6' Mini-Stereo Extension Cable (3.5mm) | Staples(R)


Attached Images
Speakers show as Not Plugged In-default-sound.jpg 
My System SpecsSystem Spec
11 Oct 2016   #7
hmkmonroe

windows 7 home premium 64 bit
 
 

While I appreciate your suggestions, what I do not understand is that the speakers were working and I have not changed the HDMI port being used or the default status. This would seem to indicate some type of software issue vs hardware, unless hardware just broke. I see sound levels changing on sound bar graph, but no sound coming from speaker when plugged into monitor. I have not yet had the opportunity to check the NVIDIA driver or the HDMI audio being enabled. Thanks.
My System SpecsSystem Spec
11 Oct 2016   #8
fireberd

Windows 10 64 bit
 
 

The HDMI audio is generated in the Video card (sound chip). Verify that the HDMI is set as default audio playback device. If its set OK. Reseat the HDMI cable (unplug then plug back in) at both ends - the PC and monitor. Also check the interface audio cable . If you have a regular headset with a "TRS" plug, use that for testing and plug it into the audio out on the monitor and see if you have any audio. If you do, then the problem is in the speakers.
My System SpecsSystem Spec
12 Oct 2016   #9
hmkmonroe

windows 7 home premium 64 bit
 
 

Re-installed NVIDIA driver and re-seated HDMI cable. Still no sound from speakers plugged into monitor jack. RealTek high definition audio is shown on several displays but is grayed out and thus not available to select -- this is where speakers are shown as not plugged in. This same situation happened once previously in past 2 years and I cannot remember solution. Speakers have worked fine for 2 years since and then suddenly no sound. Perhaps cause stems from an update issue. The obviously simple solution of a system restore is not available for me as I lost my restore point history when I upgraded to Windows 10 and subsequently downgraded back to windows 7. I will probably purchase an extension cord and plug speakers directly into pc, but I still just do not understand what has happened to cause no sound through usual setup using speaker jack on monitor. Thank you again for your involvement and suggested solutions.
My System SpecsSystem Spec
12 Oct 2016   #10
fireberd

Windows 10 64 bit
 
 

Lets go back to beginning. If you are using HDMI to the monitor and getting audio from monitor and ONLY have HDMI cable attached then audio is being supplied by the NVIDIA video card. The Realtek is not being used and will show no speakers connected.

I don't have NVIDIA but if you have some type of NVIDIA control panel, there may be an option in that for audio?
My System SpecsSystem Spec
Reply

 Speakers show as Not Plugged In




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
No speakers or headphones are plugged in
I just reinstalled Win 7 Ultimate 64 bit and I have no audio. Not going to explain much but im just going to show you with a screenshot.
Sound & Audio
Speakers not plugged in when they are
After moving the PC into another room for a month I've moved back into my office but I'm getting no sound from the speakers. I've followed the steps in other posts and see a message that "Speakers are not plugged in". I've checked 1) the connections are ok 2) the speakers are on - I can hear...
Sound & Audio
No headphones or speakers plugged in.
Just finished building a new computer and my sound will not work. I have installed and uninstalled drivers several times now.
Drivers
Speakers and headphones not plugged in... even though they are
I have a HP Pavilion p6267. For some reason, I have no sound coming out of my stereo speakers or headphones (rear panel and front panel respectively). I have uninstalled and reinstalled the Realtek Audio Driver, downloaded the new update for the driver (which supposedly fixes an HDMI issue),...
Sound & Audio
No speakers or headphones are plugged in. PLEASE HELP!
I recently took my computer to get a new graphics card GeForce GT 240 and I came back plugged in everything and my speakers didn't work. It worked before I got my new graphics card, Please help this is extremely annoying, I've tried so many other ways.:cry::cry::cry::cry::cry:
Sound & Audio


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 19:39.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App