Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: External speakers not showing up in Playback Devices

4 Weeks Ago   #1
AaLF

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1
 
 
External speakers not showing up in Playback Devices

Win7 64bit PC. I have a set of external speakers + headfones.

Playback Devices > only headfones offered ( no sign of ext spkrs)

Devices & printers > V20 Notebook spkrs appear > Troubleshoot > unable to identify any problem.

I've re-started & switched USB ports without success. Can't get the driver install to kick in.

This issue has only just started. Things have been fine prior.


My System SpecsSystem Spec
.
3 Weeks Ago   #2
AaLF

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1
 
 

Any thoughts?
My System SpecsSystem Spec
3 Weeks Ago   #3
NoN

Windows 7 Professional SP1 - x64 [Non-UEFI Boot]
 
 

What kind of external speakers do you use for, 2.0, 2.1...? Are they only USB plugged in or does have a jack 3.5 too?
My System SpecsSystem Spec
.

3 Weeks Ago   #4
AaLF

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1
 
 

Logitech V20 notebook (USB only) speakers.

Amazon.com: Logitech V20 Notebook Speakers (Black): Electronics
My System SpecsSystem Spec
3 Weeks Ago   #5
NoN

Windows 7 Professional SP1 - x64 [Non-UEFI Boot]
 
 

It's USB so it should show in the devices manager, i view tab show hidden peripherals and search for the name of the speakers. Uninstall the device and driver, reboot with the speakers plugged in for it to be recognized at start up. It could be the speakers not mapping well.
My System SpecsSystem Spec
Reply

 External speakers not showing up in Playback Devices




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Headphone not showing in Playback devices
My motherboard is Gigabyte G41M. I have recently re installed my OS windows7, and so i downloaded the required drivers from the main site of Gigabyte. Ethernet,NIC,Audio every drivers are working fine. But Headphones are not working. I was able to use my mobile headphones earlier in my old...
Hardware & Devices
HDMI Audio not showing in playback devices???
I have an HTPC that I use to watch TV through Media Center with an HD Homerun Prime. Lately I've been getting an error message in Media Center that say something to the effect of "no audio device detected." When I close out of Media Center, I notice that the little speaker icon in the bottom...
Sound & Audio
Headphones not showing up on playback devices
This headphone I bought is a high quality one I bought. It doesn't show on playback but has bad quality with that. It gives the speaker sounds through my headphone instead. Help me please.
Sound & Audio
Playback devices (Speakers) being unplugged continuously
Hi Guys, I am facing a problem, since I installed windows 7 on my old pc (Core2Duo, 2GB RAM, DG41CN Motherboard). Whenever I play any song or video, my playback devices starts behaving ridiculous. Playback devices (Speakers) are being unplugged continuously. I have installed all updated...
Sound & Audio
Strange problem with audio playback devices. Headphones not showing up
Can someone help me solve this enigma? Can't find answers anywhere... So I've installed Adobe Audition on my brand new Asus K53E. When I try to record, I can't select my headphones as the default audio playback. So I go and try to do it in the control panel. But the headphones/headphone jack...
Sound & Audio
internal speakers not showing on playback devices
Hi I got my laptop last week and and yesterday the sound stopped working. The laptop is a ASUS G53SX: i7-2670QM 2,2 ghz. 8 GB RAM. GTX 560M. I have tried to update/re-install the drivers without any luck. I have also tried system recovery and still no sound. The latest software that I have...
Sound & Audio


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 13:54.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App