Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Upgraded to W7. No sound. Creative Xfi card. Help!


20 Nov 2009   #21

Windows 7 Home Premium x64 - Mac OS X 10.6.4 x64
 
 

Thanks you two for the rep...I guess I just got lucky but it just clicked to go to the creative website

My System SpecsSystem Spec
.

20 Nov 2009   #22

Windows 7 Home Premium 32 bit
 
 

Quote   Quote: Originally Posted by Zidane24 View Post
Thanks you two for the rep...I guess I just got lucky but it just clicked to go to the creative website
I was trying other drivers on their website, but I hadn't tried that one yet. Creative needs to get their stuff together.
My System SpecsSystem Spec
21 Nov 2009   #23
Microsoft MVP

Win 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by rocketdescends View Post
Quote   Quote: Originally Posted by Zidane24 View Post
Looks like Creative has your driver...

Creative Worldwide Support > X-Fi XtremeMusic

First download link
IT WORKED! HOLY #$%@! it worked! It is weird how the drivers work when its not the card I have. THANKS! *falls over in exhaustion* XD +1 rep Zidane and torrentg.
That would be because from what I can see looking up the DevID you have the X-Fi Platinum., and it is supported in the driver Zidane24 linked to. Also the driver you had installed back in your first screen shot is from back in late 2006, and came out before Vista did. Probably find that the driver on the CD is for XP only (the 5 at the start of the driver version is the giveaway, Vista and 7 drivers start with a 6).

If you want any of the apps to go with your card then you want (Volume Panel and Console Launcher mainly) you can try the downloads from Creative of you can get them already integrated in with the drivers in the modded set linked to in #3 here,

Creative Sound Cards.

P.S. It is usually much easier to determine which Creative card you have by using the model number stamped on the card (will look like SBxxxx or CTxxxx on the older cards) than from the DevID.
My System SpecsSystem Spec
.


21 Nov 2009   #24

Windows 7 Ultimate - 64-bit | Windows 8 Pro - 64-bit
 
 

I had the same problem then Creative Auto Update It will detect the sound card and updated .. It worked for me ;-)
My System SpecsSystem Spec
21 Nov 2009   #25

Windows 7 Home Premium 32 bit
 
 

Quote   Quote: Originally Posted by stormy13 View Post
Quote   Quote: Originally Posted by rocketdescends View Post
Quote   Quote: Originally Posted by Zidane24 View Post
Looks like Creative has your driver...

Creative Worldwide Support > X-Fi XtremeMusic

First download link
IT WORKED! HOLY #$%@! it worked! It is weird how the drivers work when its not the card I have. THANKS! *falls over in exhaustion* XD +1 rep Zidane and torrentg.
That would be because from what I can see looking up the DevID you have the X-Fi Platinum., and it is supported in the driver Zidane24 linked to. Also the driver you had installed back in your first screen shot is from back in late 2006, and came out before Vista did. Probably find that the driver on the CD is for XP only (the 5 at the start of the driver version is the giveaway, Vista and 7 drivers start with a 6).

If you want any of the apps to go with your card then you want (Volume Panel and Console Launcher mainly) you can try the downloads from Creative of you can get them already integrated in with the drivers in the modded set linked to in #3 here,

Creative Sound Cards.

P.S. It is usually much easier to determine which Creative card you have by using the model number stamped on the card (will look like SBxxxx or CTxxxx on the older cards) than from the DevID.
Ok thanks. At one point I did open the CPU, but due to other cards in the way I couldn't read the model number on the card.
My System SpecsSystem Spec
21 Nov 2009   #26
Microsoft MVP

Win 7 Ultimate x64
 
 

That's when you take the card out. Easy enough to do, it's only held in by one screw.
My System SpecsSystem Spec
Reply

 Upgraded to W7. No sound. Creative Xfi card. Help!




Thread Tools



Similar help and support threads for2: Upgraded to W7. No sound. Creative Xfi card. Help!
Thread Forum
Creative sound card not detected Sound & Audio
Creative Sound card problems Sound & Audio
Creative Sound Card Problem Thread Sound & Audio
Solved Low volume with new sound card(Creative Sound Blast 5.1 VX) Sound & Audio
Creative Sound Blaster Audigy 24bit Sound Card Drivers
Creative Sound card Sound & Audio
Problems with my Creative Sound Card. Drivers

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 10:24 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33